Is this a timing problem? Machines sometimes boot properly



  • I’m using Fog 1.2 on Ubuntu 13.10 with a proxy DHCP server. My Dell 790 machines will randomly error out (see pic) OR boot into a task. I tried to multicast to 6 machines last night: 3 of them errored out and 3 of them got to the grey download screen (2 had to be rebooted a couple of times because they errored out at first). I am using the undionly.kpxe.INTEL kernel right now.

    [url="/_imported_xf_attachments/1/1597_IMG_20150109_090943343.jpg?:"]IMG_20150109_090943343.jpg[/url]



  • Is it possible to roll my own using the kernel that is working for me now?


  • Senior Developer

    It would be evident.

    I don’t know why it’s not working, but it is why I added the prompt in the first place.

    You could create your own undionly.kpxe to thwart this issue by specifying the next-server variable natively and skipping the prompt for the server address entirely.



  • I tried the edit and restarting dnsmasq, but the tftp server prompt persists, even after several reboots. Should the change be immediately evident, or does it take some time?


  • Developer

    [quote=“Glenn Wilson, post: 40626, member: 240”]Do any services need to be restarted after changing the ltsp.conf file?[/quote]

    Yes you need to restart dnsmasq

    [code]sudo service dnsmasq restart[/code]



  • Do any services need to be restarted after changing the ltsp.conf file?


  • Senior Developer

    I think the middle option can go away to allow dynamic updating of next-server flag:

    Maybe the dhcp-boot needs to be:

    [code]dhcp-boot=undionly.0,xx.xx.xx.xx[/code]

    rather than
    [code]dhcp-boot=undionly.0,xx.xx.xx.xx[/code]

    The reason the tftp is asked is simply because it doesn’t know what it should be, and would simply fail because it can’t (for whatever reason) find it



  • We are using dnsmasq. The /etc/ltsp.conf file shows: “dhcp-boot=undionly.0,xx.xx.xx.xx”.


  • Senior Developer

    It sounds to me like you may be using DNSMasq?



  • Tom,

    I just tried the undionly.kpxe from the trunk files and it appears to work, except that I had to manually enter the tftp server address before the multicast would start. I’ve seen that with one other kernel I tried this morning. Any idea about that?


  • Senior Developer



  • I downloaded the latest undionly.kpxe from [url]http://svn.code.sf.net/p/freeghost/code/tags/1.2.0/packages/tftp/[/url] and it SEEMS to be working on both the 790s and 7010s. Both types of machine will now boot to a task or the Fog menu reliably.

    BUT there is another issue: When there is an active task, such as an image being deployed to one machine, no other machine, 790 or 7010, will boot past the /default.ipxe… (see pic) part of the process. They will error out right there until the task is completed, and then they will boot to the Fog menu. Any ideas about that?

    [url="/_imported_xf_attachments/1/1598_IMG_20150109_122017650.jpg?:"]IMG_20150109_122017650.jpg[/url]


  • Developer

    try using updated ipxe files from here [url]http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/[/url]
    your problem may already be resolved in trunk


Log in to reply
 

367
Online

38984
Users

10712
Topics

101686
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.