Snapin will not start



  • I’ve searched through the forums but I don’t believe I’ve seen anybody have this issue, or at least ask about it. Does a user have to be logged into the host machine in order for snapins to install? I have a snapin queued up for install and it won’t go through until I log in. Is there anyway to push snapins when nobody is logged into the machine?


  • Senior Developer

    @cotec , can you post this to a new topic, otherwise it will get buried.



  • @Jbob said:

    @cotec, you need to deploy the snapins before the client will run them. Goto your host, select’Basic Tasks -> Advance -> Either Single Snapin or All Snapins .

    thanks fot the hint, i thought link the snapin to host/group is all. Okay there must be a task to install - check.

    edit: it works - the snapin is installed :+1:

    edit2: I have configured “Reboot after install” in Adobe Reader Snapin - the PC reboots every 5 Minutes and the Snapin-Deploy-Task won’t kill in Taskmanagement. Its necessary to kill manually?
    “Active Snapin Tasks - State: In-Progress” - but it is installed…(?)


  • Senior Developer

    @cotec, you need to deploy the snapins before the client will run them. Goto your host, select’Basic Tasks -> Advance -> Either Single Snapin or All Snapins .



  • same problem here.
    fog.log on client-side says:
    08.01.2016 11:47 FOG::SnapinClient Attempting to connect to fog server…
    08.01.2016 11:47 FOG::SnapinClient Module is active…
    08.01.2016 11:47 FOG::SnapinClient No Tasks found for: <mac>
    08.01.2016 11:52 FOG::SnapinClient Attempting to connect to fog server…
    08.01.2016 11:52 FOG::SnapinClient Module is active…
    08.01.2016 11:52 FOG::SnapinClient No Tasks found for: <mac>

    on server side there are 2 snapins configured and linked to hosts
    7-zip and Adobe Reader
    0_1452250631675_reader.JPG 0_1452250644636_7zip.JPG



  • Is there a solution for this problem? I have the same problem.



  • Could this PHP error effect how the snapins work, or does this error effect another part of fog?

    Edit: I can’t seem to upload my error log but here is a copy and past of it.

    [Sun Jan 04 08:01:57.413135 2015] [mpm_prefork:notice] [pid 11208] AH00163: Apache/2.4.6 (Ubuntu) PHP/5.5.3-1ubuntu2.6 configured – resuming normal operations
    [Sun Jan 04 08:01:57.413161 2015] [core:notice] [pid 11208] AH00094: Command line: ‘/usr/sbin/apache2’
    [Mon Jan 05 06:57:23.371700 2015] [:error] [pid 19370] [client 172.52.8.27:49313] PHP Warning: require_once(…/commons/base.inc.php): failed to open stream: No such file or directory in /var/www/fog/service/usertracking.report.php on line 2
    [Mon Jan 05 06:57:23.371727 2015] [:error] [pid 19370] [client 172.52.8.27:49313] PHP Fatal error: require_once(): Failed opening required ‘…/commons/base.inc.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/fog/service/usertracking.report.php on line 2
    [Mon Jan 05 11:44:41.723248 2015] [:error] [pid 20919] [client 172.52.8.27:57690] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/plugins/accesscontrol/hooks/RemoveUpload.hook.php on line 38, referer: [url]http://172.28.2.21/fog/management/index.php?node=host&sub=list[/url]
    [Mon Jan 05 12:03:23.767489 2015] [:error] [pid 20505] [client 172.52.8.75:49181] PHP Warning: require(…/commons/base.inc.php): failed to open stream: No such file or directory in /var/www/fog/service/servicemodule-active.php on line 2
    [Mon Jan 05 12:03:23.767520 2015] [:error] [pid 20505] [client 172.52.8.75:49181] PHP Fatal error: require(): Failed opening required ‘…/commons/base.inc.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/fog/service/servicemodule-active.php on line 2
    [Mon Jan 05 12:19:13.255994 2015] [:error] [pid 20919] [client 172.52.8.75:49176] PHP Warning: require(…/commons/base.inc.php): failed to open stream: No such file or directory in /var/www/fog/service/servicemodule-active.php on line 2
    [Mon Jan 05 12:19:13.256029 2015] [:error] [pid 20919] [client 172.52.8.75:49176] PHP Fatal error: require(): Failed opening required ‘…/commons/base.inc.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/fog/service/servicemodule-active.php on line 2
    [Mon Jan 05 12:57:03.255565 2015] [core:notice] [pid 11208] AH00051: child pid 19371 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Mon Jan 05 15:18:03.299233 2015] [:error] [pid 20918] [client 172.52.8.49:58010] PHP Warning: require(…/commons/base.inc.php): failed to open stream: No such file or directory in /var/www/fog/service/servicemodule-active.php on line 2
    [Mon Jan 05 15:18:03.299261 2015] [:error] [pid 20918] [client 172.52.8.49:58010] PHP Fatal error: require(): Failed opening required ‘…/commons/base.inc.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/fog/service/servicemodule-active.php on line 2
    [Tue Jan 06 08:19:30.894781 2015] [core:notice] [pid 11208] AH00051: child pid 21340 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Tue Jan 06 14:33:51.590258 2015] [:error] [pid 20920] [client 172.52.8.41:55472] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/plugins/accesscontrol/hooks/RemoveUpload.hook.php on line 38, referer: [url]http://fogvm/fog/management/index.php?node=host&sub=import[/url]
    [Wed Jan 07 07:58:17.570724 2015] [core:notice] [pid 11208] AH00051: child pid 454 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Wed Jan 07 08:35:13.321552 2015] [core:notice] [pid 11208] AH00051: child pid 23262 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Wed Jan 07 09:07:10.898951 2015] [core:notice] [pid 11208] AH00051: child pid 733 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Wed Jan 07 09:12:59.258291 2015] [core:notice] [pid 11208] AH00051: child pid 1039 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Wed Jan 07 09:12:59.258444 2015] [core:notice] [pid 11208] AH00051: child pid 1136 exit signal Segmentation fault (11), possible coredump in /etc/apache2
    [Wed Jan 07 10:12:53.526333 2015] [:error] [pid 20505] [client 172.52.8.41:64059] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://fogvm/fog/management/index.php?node=group&sub=add[/url]
    [Wed Jan 07 10:17:40.236997 2015] [:error] [pid 1137] [client 172.52.8.41:64073] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://fogvm/fog/management/index.php?node=group&sub=add[/url]
    [Wed Jan 07 10:19:19.992102 2015] [:error] [pid 1417] [client 172.52.8.27:57423] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://172.28.2.21/fog/management/index.php?node=group&sub=list[/url]
    [Wed Jan 07 10:20:01.087661 2015] [:error] [pid 1040] [client 172.52.8.41:64085] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://fogvm/fog/management/index.php?node=group&sub=list[/url]
    [Wed Jan 07 10:20:55.618972 2015] [:error] [pid 21030] [client 172.52.8.41:64092] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://fogvm/fog/management/index.php?node=group&sub=add[/url]
    [Wed Jan 07 10:21:09.356977 2015] [:error] [pid 1417] [client 172.52.8.27:57437] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://172.28.2.21/fog/management/index.php?node=group&sub=list[/url]
    [Wed Jan 07 10:24:34.263077 2015] [:error] [pid 1406] [client 172.52.8.27:57455] PHP Warning: array_filter() expects parameter 1 to be array, null given in /var/www/fog/lib/pages/GroupManagementPage.class.php on line 252, referer: [url]http://172.28.2.21/fog/management/index.php?node=group&sub=list[/url]



  • I was looking around at some log files within the fog server itself and noticed that apache does have an error in it. This is the error:

    php fatal error: require(): failed opening required ‘…/commons/base.inc.php’ (included_path=’ .:/usr/share/php: /usr/share/pear ') in /var/www/fog/service/servicemodule-active.php on line 2



  • After the snapinclient module wakes up from it’s sleep the only thing it does is “Attempt to connect to fog server” and then relay the message that “SnapinClient Module is active”. I still have a snapin waiting to be pushed to the machine stuck in queued status.


  • Senior Developer

    The default file initially starts the checks at a random interval between 307 and 600 seconds. After it starts it will check in at the requested interval. There is a file that does more what you’re expecting somewhere on the forums though



  • Hmm. For some reason the snapinclient process is set to sleep for the next 372 seconds. I know I changed it to check every 60 seconds in the config file.


  • Developer

    i recommend editing the config file to increase the log size. just add a few 0’s, the default size is way too small for any real troubleshooting. you could perhaps even try viewing the file connected to the administrative share of the c: drive so you are not logging in to view it.



  • The OS is windows 7. The fog version is 1.2.0. I’ve changed the config file to check for snapins every 60 seconds. I’ve given the snapin about half an hour to go through but it stays at queued until I log in. Once I log in and look at the log file I don’t see any logs for the snapin client, just the task reboot client.


  • Developer

    how long have you given the computer to run snapins before you’ve logged in to check on them?
    what OS is the client running?
    what version of fog are you running?
    what does the c:\fog.log file on the client say?



  • No. The computers are attached to a domain, but I can easily remote into them before anybody logs into them so they do have network access.


  • Developer

    are you running any kind of authentication on your network that requires a valid login to get a network address?



  • Is there any sort of setting that could cause snapins to not work until a user is logged in?


  • Developer

    snapins should install no matter whether someone is logged in or not


Log in to reply
 

434
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.