Works with unmanaged 1Gb switch, but throws 'Failed to mount NFS Volume' with managed switch



  • Hi,

    My FOG setup works without a problem when using a dumb very cheap unmanaged 8-port Gbps D-Link switch.

    However, when I try it through my managed layer3 D-Link DGS-3120 Gbps switch it cannot mount the NFS volume. It says: [B]‘Fatal Error: Failed to mount NFS Volume’[/B]

    So I’m assuming there isn’t anything wrong with my FOG setup since it works in the one case. And, that the problem lies with my managed switch setup. I’ve already tried resetting the switch to factory defaults such that it runs in ‘unmanaged’ mode. But that didn’t help. I read somewhere on this forum someone reporting that enabling IGMP Snooping helped with a Cisco switch, but I can’t really see why it would help in this case. It is almost as if it is blocking the NFS traffic, but I can’t see how/why it would do that.

    Can anyone hint me the right direction?

    Thanks,

    MrsPotter.



  • I finally had a chance to look at this project again - I wiped the disk, re-installed a ‘blank’ ubuntu and re-installed FOG. Nothing special, and now it seems to work. Via dumb switch, and via smart switch.

    But, thanks for all the help thus far!



  • Hi Tom,

    Your help is much appreciated. I haven’t lost interest - it is just the client has closed offices for Xmas & New Years so I currently don’t have access to the hardware for further testing. I’m currently testing FOG as an alternative to Clonezilla to do regular disk clones for backup and archival purposes. Clonezilla worked great up until now, but FOG seemed like an slightly more polished alternative providing a little more automated feedback etc.

    So I’m actually mostly interested in the upload (to server) part and in case of emergency the download (to client) bit. I’m having trouble with the upload at the moment. Didn’t get to the download part yet.

    I’ll post once I had a chance to fiddle with it - I’m sure I disabled the firewall straight off the bat, but I might have forgotten about SELinux.

    In meanwhile - Happy New Year!

    MrsPotter.


  • Senior Developer

    [quote=“MrsPotter, post: 40335, member: 27740”]
    One thing though: While setting up FOG I went through a number of steps found on the wiki etc. One of them said to change the FOG Storage Nodes username and password to the standard: fog & password. I kept the fog username and password like this. The username was ‘fogstorage’ and I never knew what the password was. Could I have broken it this way?[/quote]

    I don’t think so, though changing the Storage node username and password may break other functions of fog, it shouldn’t impact imaging. The FOG Username and Password correlate to the FTP user and password (also the local *nix user and password) on the system. Without this File sizes and image uploads may be broken, but from a download standpoint, all should be fine.

    Can you ensure that the nfs server is running and that firewall is disabled on the system hosting fog? While I realize it works behind a “dumb” switch but seemingly fails behind a “managed” switch, It still files like a firewall issue more than a switch.

    Ubuntu firewall disabling would be:
    [code]sudo ufw disable
    sudo service nfs-kernel-server restart[/code]

    Redhat firewall disabled would be:
    [code]chkconfig iptables off
    service iptables stop
    service nfsd restart[/code]

    Redhat also natively enables SELinux so you’d have to disable it and restart the system if this is the case.

    As things seem to work behind a dumb switch, can you just remove the managed switch and verify that this is still the case?

    [quote=“MrsPotter, post: 40335, member: 27740”]I searched your forum for my problem but didn’t find anything similar - so I’m hoping I’m not a noob wasting everyone’s time.[/quote]

    Regardless, we’re here to attempt to help. If it were something fairly common I might tell you to search and provide a link, but I’m not recalling anything of this type of problem (where it works on dumb, but not on managed).

    It’s never a waste of time to ask a question.



  • After a while it times out and then throws the ‘Fatal Error: Failed to mount NFS Volume’ and then says it is going to reboot the PC within 1 minute.

    FOG works perfectly behind a dumb switch, but this is the behaviour as soon as I put it behind the managed switch. I kept the device to be imaged the same to be sure that it isn’t the device to be cloned that is at fault. I also tried other machines to be imaged but same result. Definitely something to do with the switch it seems.

    Creating the /images/.mntcheck didn’t seem to change anything.

    One thing though: While setting up FOG I went through a number of steps found on the wiki etc. One of them said to change the FOG Storage Nodes username and password to the standard: fog & password. I kept the fog username and password like this. The username was ‘fogstorage’ and I never knew what the password was. Could I have broken it this way?

    Sorry first time installing FOG. I’m quite familiar with Clonezilla and the bouquet of software it comprises. Many of which FOG seems to use too. But, this is the first time I’m trying FOG. I searched your forum for my problem but didn’t find anything similar - so I’m hoping I’m not a noob wasting everyone’s time.


  • Senior Developer

    So it never get’s beyond this point and has stopped throwing the “Failed to mount” message?



  • OK did this:
    touch /images/.mntcheck;
    chmod -R 777 /images

    But it is unchanged. I’ve attached a pic of the screen for you.
    [ATTACH=full]1576[/ATTACH]

    [url="/_imported_xf_attachments/1/1576_2014-12-23 20.23.34 (1).jpg?:"]2014-12-23 20.23.34 (1).jpg[/url]


  • Senior Developer

    Yes you should create it with:

    [code]sudo touch /images/.mntcheck
    sudo chmod -R 777 /images[/code]



  • /images/dev/.mntcheck - does exist
    /images/.mntcheck - does not exist (should I create one?)


    FOG Ver: 1.2.0
    OS Ver : Debian GNU/Linux 7.7 (wheezy)


  • Senior Developer

    My guess,

    Does the /images/dev/.mntcheck and /images/.mntcheck files exist?



  • From your reply I gather the STP should be turned off. However, in my case the STP is turned off. I also turned off everything else I could find, including all the smart security DOS prevention etc to try and get it as close to an unmanaged switch I can. Most functions are disabled after a factory reset in anyway. Once it is working I could work from there adjusting the switch to for our environment while checking that FOG still works.

    But, for the moment FOG is still saying ‘Failed to mount NFS Volume’.

    I’m scheduling an upload before PXE booting the machine. It then gets an IP via DHCP server and boots the PXE images etc. There is no menu in this case, but I did boot it to the menu and did a full registration. This worked with no error messages.

    Any ideas? (I’m hoping it is just something silly).

    Thanks in advance.


  • Developer

    [url]http://www.dlink.com/-/media/Business_Products/DGS/DGS 3120/Manual/DGS_3120_Series_R300_CLI_Reference_Guide.pdf[/url]

    This shows that STP is enabled by default. It’s surprising that you got to the “[B]Fatal Error: Failed to mount NFS Volume”[/B]
    Was this during a upload/download or does this occur before the FOG Menu appears?


Log in to reply
 

366
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.