Missing storage memeber



  • I have being using FOG for about 2 months and everything was working fine until today. I need to deploy some images on the rush and I noticed an error on the dashboard:
    Disk Information
    Failed to connect to
    DefaultMember
    I also noticed that all the information for the dashboard is missing. I tried to boot one of the system to be image and the system could not find the boot image.I tried to removed the storage and adding it again, with the same result. I also tried rerunning installfog.sh with the same result. I do think I made a mistake somewhere when I deleted a folder under /var/www/fog.rev that was right beside of /var/www/fog. I also made changes to Apache2 by configuring FOG site to the default 80 instead of xxx.xxx.xxx/fog. I am not sure if any of this changes affected the system but, for what I can see if the storage is not found then, nothing will work.

    I am also including images for a new system registration which just hangs and an image for an old systems that is already registered and need to boot to PXE to acquire the image.

    If any one have an idea how to fix this please let me know.

    [url="/_imported_xf_attachments/1/1559_FOG_Dashboard.png?:"]FOG_Dashboard.png[/url][url="/_imported_xf_attachments/1/1560_IMAG0309.jpg?:"]IMAG0309.jpg[/url][url="/_imported_xf_attachments/1/1561_IMAG0310.jpg?:"]IMAG0310.jpg[/url]



  • Thank you for the info Junkhacker. I was able to recover the storage. Somewhere along the lines the configuration got lost. I reconfigured the system manually and I was able to recovered the storage.


  • Developer

    if going to [url]http://192.168.1.133/fog/service/ipxe/boot.php[/url] does not return a boot configuration text file, then your changes are most likely the problem. the location of fog can change, but it requires changes to certain settings and at least 1 file.



  • In order to make it work in the way I want I converted the fog directory into a sub directory and place your code in the directory above. Still I think it should be possible to create a virtualhost site within Apache with a conf file to be accessible directly without crashing because it cannot find the rest of the configuration. Is this possible?



  • Thank you for your response Wolfbane8653.

    I don’t think the changes affected my system on a negative way as I noticed that FOG does not create a site in Apache. It is just in the directory which it is browsable by navigating to it by putting the path xxx.xxx.xxx/fog. If I am creating a site and a config file for FOG with the directive:
    DocumentRoot /var/www/fog

    Shouldn’t that place fog’s folder as the root for the directory and look down the tree? It seems as if there is a bug in the code. The site shouldn’t have to go out of its container to look down the tree.


  • Developer

    I would assume the edits to apache has effected your system.
    An easy way to redirect xxx.xxx.xxx.xxx to your xxx.xxx.xxx.xxx/fog/management is to edit/create the index.php file in /var/www/

    I have this in the file:

    [CODE]
    <?php header(‘Location: ./fog/index.php’);?>
    [/CODE]
    this will redirect to /fog/index.php which points to /fog/management/index.php taking you directly where you need to go.


Log in to reply
 

1.0k
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.