After Deploying Image, reboot loop; Dell e6520; Fog 0.32



  • I created an image using Windows 64bit and WAIK/sysprep. The image deploys, and on reboot, if PXE is enabled, it goes into a continual reboot loop.

    If you choose to boot from the first hard drive using the BIOS boot menu, it boots fine. If you disable PXE boot altogether, it also works fine. For some reason, it can’t use the “boot first hard drive” partition from the PXE boot menu and keeps rebooting.

    Any thoughts? I’d really like to leave PXE enabled for easier management.



  • For anyone with my problem described - it was due to me spelling kernel improperly… I had kernal chain.c32 instead of kernel chain.c32… live and learn. :)



  • We have a whole slew of Optiplex 790 Dells, and after applying this fix, the graphical menu displays, counts down from 3, then the countdown starts over again. I am using the exact syslinux version as the guide shows. I have setup a new fog server and tried the setup instructions and it behaves the same way. So either I am doing something identically wrong after following the guide, or perhaps this fix does not work on the Optiplex 790s? Any help?



  • This is the first issue I ran in to after 3 years of using FOG on a 500+ client network.

    [url]http://www.fogproject.org/wiki/index.php?title=Boot_looping_and_Chainloading[/url]

    Easy to follow instructions and works a treat! Thanks for all the help everyone



  • Interesting. Makes sense, though. Thanks for the response! I’ll keep that in mind whenever I’m working with Dell machines.



  • Chainloading is a workaround for a bug most often seen with Dell BIOS, and does add additional levels of complexity that do not need to exist for everyone. So the developers are hesitant to build chainloading in. And as long as it’s simple to implement after the fact they’d prefer to keep it that way.



  • Used BryceZ’s instructions to help resolve my problem with bootlooping as well (we typically only have the Dell Latitude E series in our organization).
    Just wanted to say thanks for the wiki, it was very helpful.

    Is there any talk of including chainloading in newer versions of FOG?



  • Thanks for updating the wiki. =) Things seem to be moving in a better direction with these new forums :)

    On a side note most Dell E series have this chain loading issue.





  • Go for it! I think I spent all of two minutes typing that up off the top of my head, so any clarifications or better wording would be greatly appreciated.



  • That did it, would you mind if i tidied up the page on the wiki to make it a bit more clear?



  • If you just want to modify fog.local so it looks like:
    [CODE]LABEL fog.local
    kernel chain.c32
    append hd0
    MENU DEFAULT
    MENU LABEL Boot from hard disk
    TEXT HELP
    Boot from the local hard drive.
    If you are unsure, select this option.
    ENDTEXT[/CODE]
    Pretty sure that’s what you’re wanting.



  • It works perfect if i make the changes to default using the text menu. But if i switch to gui it hangs, I think I need a clarification on:

    [LIST]
    [*]Edit /tftpboot/pxelinux.cfg/default to include the following DEFAULT option (only set this if you’re using the text based menu) and LABEL entry:
    [/LIST]

    gui default.

    DEFAULT vesamenu.c32
    MENU TITLE FOG Computer Cloning Solution
    MENU BACKGROUND fog/bg.png
    MENU MASTER PASSWD $1$0VRbLZUP$Jg1l3BT4NEtJmxyFo8MSG.
    MENU HIDDEN
    MENU AUTOBOOT

    menu color title1;36;44 #ffffffff #00000000 std

    LABEL fog.local
    localboot 0
    MENU DEFAULT
    MENU LABEL Boot from hard disk
    TEXT HELP
    Boot from the local hard drive.
    If you are unsure, select this option.
    ENDTEXT



  • Sounds like there might be a typo on your default file. Would you mind posting your copy of /tftpboot/pxelinux.cfg/default?



  • Is there anyway to make this work with the gui boot menu? It just hangs at “booting from local disk” if you use the gui menu.



  • I renamed the article in question to “Boot looping and Chainloading” as that seems like a more appropriate description of the article, and added it to the Troubleshooting section of the wiki.



  • That was exactly the ticket. Thanks! I did try to search the wiki and the forums before posting, but for whatever reason, I didn’t find it. I’m thinking adding this under the “Troubleshooting” section of the Wiki would seem like a good idea. Are there any problems with adding it there? It’s under the wiki under

    [URL=‘http://www.fogproject.org/wiki/index.php?title=FIX:_Chainloading_alternate_SYSLINUX_to_force_boot_from_first_hard_drive’]FIX: Chainloading alternate SYSLINUX to force boot from first hard drive[/URL]

    But that didn’t really ring a bell for me.



  • It seems that some computers have this issue. You can try referring to this post about chainloading.
    [url]http://fogproject.org/forum/threads/infinite-booting-loop.208/#post-1399[/url]



  • Yes, it is listed as the next boot device in the BIOS.



  • Do you have your hd listed as the next boot device after network boot in your bios. The boot first hard drive option in Fog doesn’t actually mean boot first hard drive. It just exits the pxe boot and moves on to the next device in your bios boot config


Log in to reply
 

464
Online

39.4k
Users

11.1k
Topics

105.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.