PXE boot error - Fog 1.2 on Ubuntu 12.0.4.5



  • I installed FOG 1.2 on a fresh install of Ubuntu 12.0.4.5. Installation went fine. I’m running on a box with 2 NICs, 1 for internet access for updates and accessing the FOG webui, and the other a private network for image deployment (in my network environment I’m not allowed access at the DHCP server, so Ubuntu is filling that role on the private network)

    From what i can tell, the PXE boot goes fine (machine pulls an ip from dhcp, ipxe loads) up until it tries to load bg.png, from the ip of wrong NIC.

    [ATTACH=full]1557[/ATTACH]

    Any suggestions on where I can adjust this setting? All the imaging work should be coming off the 192.168.x.x network. I have no idea why it is grabbing the boot.php from the proper address but then looking for bg.png from the 10.x.x.x network.

    Thanks

    [url="/_imported_xf_attachments/1/1557_fog 1-2 error.jpg?:"]fog 1-2 error.jpg[/url]



  • Junkhacker, thank you! I didn’t even think about this. I had it bound to the 10.x.x.x address. Changed to the 192.168.x.x and the FOG menu is now booting.

    I swear i had switched this earlier and tested, but apparently it did not save the change (please read: [U]I[/U] failed to save the change)


  • Developer

    on the fog settings page, what ip is set for “web server” ?



  • Yes, isc-dhcp server is running on the 192.168.x.x network on eth0. eth1 is statically assigned to the 10.x.x.x network for linux updates.

    [url="/_imported_xf_attachments/1/1558_dhcp server.jpg?:"]dhcp server.jpg[/url]


  • Developer

    Do you have a DHCP server on the private 192.168.x.x network?
    Is 10.x.x.x on eth0? and 192.168.x.x on eth1?


Log in to reply
 

484
Online

39003
Users

10718
Topics

101766
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.