TFTP & PXE from Windows



  • Hello. I am in a bit of a dilemma because I’d like to start using Fog but I’m in an environment where I’m unable to use the built-in DHCP feature and I don’t have access to our current DHCP servers.

    Is it possible to serve up the Fog PXE image through TFTP through Windows and then have the clients find my Fog machine once they’re booted?



  • [quote=“Tom Elliott, post: 39866, member: 7271”]Please forgive my brashness or don’t.[/quote]

    All is forgiven. I contacted Jaymes Driver via PM and in response on troubleshooting an IP address typo became apparent to me and I am now able to boot to the PXE menu. Haven’t tried imaging yet but I will soon. I appreciate yours and everyone’s assistance in helping me muddle through this. Prior to this I had close to zero knowledge of Linux so it’s been a learning experience thus far and will continue to be.


  • Senior Developer

    Please forgive my brashness or don’t.

    You fail to listen to what we’re asking you and I don’t know how to ask it any differently for your understanding.

    /tftpboot doesn’t matter at this point. The linux server is not where you are getting the tftp information if your’e tftp server is being hosted from windows. So why do you keep getting us information about the linux host?

    Please follow the instructions based on your setup, not what you think is going to happen. If you’re pointing the server (DNSMasq) at windows, you need to perform these tests at the windows side, not the linux side.

    Please check your Windows TFTP folder for the file named default.ipxe. My guess is this file does not exist, hence the problem you’re having.



  • [quote=“Junkhacker, post: 39860, member: 21583”]and you’re downloading this from the windows tftp server you set up, not the fog server, right?[/quote]

    The test was done on a totally unrelated workstation that has the Windows TFTP service installed. It’s even on a different subnet so that crossed over successfully.


  • Developer

    and you’re downloading this from the windows tftp server you set up, not the fog server, right?



  • [quote=“Wolfbane8653, post: 39856, member: 3362”]Can you download the file using a windows computer?

    Change undionly.kpxe to default.ipxe in the command in this wiki help.
    [url]http://fogproject.org/wiki/index.php/Tftp_timeout…#0.33_and_1.x.x[/url][/quote]

    Yes, I can tftp the default.ipxe from an unrelated Windows box. Transfer successful: 304 bytes in 1 second(s), 304 bytes/s


  • Developer

    Can you download the file using a windows computer?

    Change undionly.kpxe to default.ipxe in the command in this wiki help.
    [url]http://fogproject.org/wiki/index.php/Tftp_timeout…#0.33_and_1.x.x[/url]



  • [quote=“Junkhacker, post: 39837, member: 21583”]ipxe is trying to download default.ipxe from the same location as where it loaded undionly.kpxe from. is it there?[/quote]

    Both files are present in my /tftpboot folder.


  • Developer

    ipxe is trying to download default.ipxe from the same location as where it loaded undionly.kpxe from. is it there?



  • [quote=“Liam Sullivan, post: 39826, member: 23009”]Why don’t you save yourself a headache and just set FOG up the way it was intended then pass the DHCP option settings to whoever does have access to the DHCP server to configure. (Assuming you’re using a third party DHCP server from your original post) That way you wont have to faff on with this and you can have a fab fog server running peachy like :)[/quote]

    Well… this is somewhat of a “one-off” setup because the standard protocol is to use Symantec Ghost which I’m not a real big fan of, so that being the case I don’t think I’m gonna get any help with changes to the DHCP server back at headquarters.

    I’ve got things configured using Fog and the proxyDHCP to the point where the client is getting an IP and trying to pull something down via TFTP but it craps out and returns a message saying “[FONT=Tahoma]./default.ipxe connect timed out.” and I’m dead in the water. [/FONT]



  • Why don’t you save yourself a headache and just set FOG up the way it was intended then pass the DHCP option settings to whoever does have access to the DHCP server to configure. (Assuming you’re using a third party DHCP server from your original post) That way you wont have to faff on with this and you can have a fab fog server running peachy like :)


  • Senior Developer

    That part I understand, but if you’re using windows tftp32 for your tftp server.



  • [quote=“Junkhacker, post: 39801, member: 21583”]i still don’t see how that requires not using the tftp server fog provides[/quote]

    I was just wondering if it could be done through Windows since I’m having some trouble getting the FOG side of it up and running. Prior to this I was using Ghost and the 3Com TFTP and PXE solution they provide. So I am curious if it’d be possible to serve up the PXE images that way.

    [SIZE=13px][FONT=Tahoma][COLOR=#141414][quote=“Tom Elliott, post: 39802, member: 7271”]Does the default.ipxe file exist on the tftp32 folder?[/quote][/COLOR][/FONT][/SIZE]

    [SIZE=13px][FONT=Tahoma][COLOR=#141414]So I did make some progress with the FOG proxy. It looks like the client is trying to boot and then I get a message saying ./default.ipxe connect timed out.[/COLOR][/FONT][/SIZE]

    [SIZE=13px][FONT=Tahoma][COLOR=#141414]I do have the default.ipxe file in my /tftpboot folder[/COLOR][/FONT][/SIZE]

    [SIZE=12px]FOG Version 1.2.0[/SIZE]
    [SIZE=12px]OS Version Ubuntu 13.10 (hosted through VMware Desktop with bridged NIC)[/SIZE]


  • Senior Developer

    To add on to what Junkhacker’s saying, if you can get windows working with proxydhcp, you should be able to do the same on the fog server.


  • Senior Developer

    Does the default.ipxe file exist on the tftp32 folder?


  • Developer

    [quote=“phishphan, post: 39789, member: 27469”]ProxyDHCP via TFTP32.
    [/quote]
    i still don’t see how that requires not using the tftp server fog provides



  • [quote=“Junkhacker, post: 39788, member: 21583”]if you’re unable to access your current DHCP servers to change the settings, how would you configure it for the windows based TFTP server?[/quote]

    ProxyDHCP via TFTP32.

    I finally got it sorta working with the DNSmasq method but I’m getting the /default ipxe connection timed out error on one computer and the other just says no operating system found.


  • Developer

    if you’re unable to access your current DHCP servers to change the settings, how would you configure it for the windows based TFTP server?


Log in to reply
 

348
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.