Multicast tasks not creating properly



  • Hi folks,

    Recently we discovered an issue with multicasting. Unicasting is working fine, just for the record.

    What is occuring is that when we start a multicast task it adds the individual computers in Active Tasks successfully using the “Multicast Group Quick Deploy” task name (screenshot attached for a test multicast). However when they all connect it creates a multicast task called something completely unrelated from months ago, usually from June 2014 (back when we were still on 0.32) The computers just hang on the initial PartClone screen.

    It seems like maybe it’s a database issue but I’m far from even a MySQL rookie. Apologies if this has been fixed in a later revision than we are running, just wanted to ask before I got too far into further upgrades.

    Linux Mint 13 (64-bit)
    FOG Revision 2432

    [url="/_imported_xf_attachments/1/1537_screenshot.135.jpg?:"]screenshot.135.jpg[/url][url="/_imported_xf_attachments/1/1538_screenshot.136.jpg?:"]screenshot.136.jpg[/url]



  • [quote=“ch3i, post: 40609, member: 2513”]Hi,

    How you solve this problem ? ;)

    Regards,
    Ch3i[/quote]

    My wife would tell you that one is still a work in progress.


  • Developer

    [quote=“ch3i, post: 40609, member: 2513”]Hi,

    How you solve this problem ? ;)

    Regards,
    Ch3i[/quote]

    if anyone happens to figure out how to solve this one, i’ll keep a copy of it on hand for myself for regular use, and deploy it site-wide to my users on a regular basis as well.


  • Moderator

    [quote=“Jacob Gallant, post: 40567, member: 26524”]

    1. I’m an idiot.
      [/quote]

    Hi,

    How you solve this problem ? ;)

    Regards,
    Ch3i



  • Absolutely, the folder name was something along the lines of:

    \images\IMAGENAME(2015)


  • Developer

    Can you give us the example of your image folder path/name for future reference of this issue?



  • An update: multicast is now working again. Doing some digging into the logs I found error messages on the multicast tasks which revealed that there were brackets in the image folder name which udp-sender didn’t like. So to recap:

    1. Tom’s advice on truncating the multicast tables fixed the original issue.
    2. Removing the brackets from the image folder name fixed the second issue.
    3. I’m an idiot.

    Thanks all for your help. Happy fogging!



  • We do have to use multicast, especially for our labs with 10+ computers. We are limited to resources for our storage nodes and our network where if we’re unicasting any more than 8-10 computers at once it takes way too long.


  • Developer

    Do you have to use multicast? You can still create a unicast task (Download) using the group and deploy. Multicast is just a particular method of deployment.

    See:
    [url]http://fogproject.org/wiki/index.php/Deploying_your_Image_a_group_of_clients#Unicast_vs._Multicast_vs._Torrent-Cast_images[/url]



  • Anything else I can try? I’m starting to get some heat on this and I would really rather not downgrade or start from scratch…



  • I was able to run those commands this morning and now what is occurring is the systems in the multi-cast task are showing up in Task Management > Active Tasks momentarily and then they are gone, so they all boot onto the hard drive because there is no task for them. I’m not seeing the old multi-cast tasks like we saw before but the machines aren’t connecting to any tasks now.


  • Senior Developer

    Can you afford to remove the old taskings?

    (These commands will completely remove all multicast sessions and associations)
    [code]truncate table multicastSessions;
    truncate table multicastSessionsAssoc;[/code]

    Then kill all the udp senders that may be running on the server?
    [code]sudo killall udp-sender
    sudo killall udp-sender
    sudo killalludp-sender
    sudo service FOGMulticastManager restart[/code]



  • My apologies for the delayed response, yes we are up to 2868 and same story unfortunately.


  • Senior Developer

    Again, have you tried the latest svn?



  • FOGMulticastManager does not start correct on server reboot (at least for me on svn 2756 or some previous svn numbers). I have to remember to stop/then start the service every time I restart my server. I’d love to to get a permanent solution for this.

    [CODE]sudo service FOGMulticastManager stop
    sudo service FOGMulticastManager start[/CODE]

    (sudo service FOGMulticastManager restart will not do it).


  • Senior Developer

    Have you upgraded your version to be on the latest SVN as Wolf has suggested?



  • Attempted this but still no luck. The first multicast task in the attached screenshot is the one I just created, the second one is an old task from June that is completely unrelated (different location, image, storage node). The machines just hang at the first PartClone screen and go no further. If I kill the unrelated task most or all of the active tasks for that multicast are killed as well.[ATTACH=full]1593[/ATTACH]

    [url="/_imported_xf_attachments/1/1593_screenshot.144.jpg?:"]screenshot.144.jpg[/url]


  • Developer

    [LIST]
    []Newest revision is 2868. Please make sure you update then be sure that all old multicast tasks are killed. Then start a new task.
    [
    ][url]http://fogproject.org/wiki/index.php/Multicasting[/url]
    [*]I don’t use multicasting but I will help muddle through it.
    [/LIST]
    To kill multicast tasks:
    [CODE]sudo service FOGMulticastManager stop
    sudo killall udp-sender
    sudo killall udp-sender
    sudo killall udp-sender
    sudo service FOGMulticastManager start[/CODE]



  • Any words of advice? We’ve tried different images, different storage nodes, etc. and the same issue happens every time. We’ve been forced to unicast labs which can be a very time consuming process, obviously.



  • Back to having the same issues in our labs today, multicast tasks from back in May popping up rather than the tasks we’ve created, tasks just hanging. The revision upgrade doesn’t seem to have fixed it.


Log in to reply
 

355
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.