IPXE infinity loop on Acer TM5760



  • Hi All,

    I’ve been looking around the forum for answers to this but none that I found fix the problem for me.

    It is strange, other hosts work fine. Just seems to be this particular model of laptop. I have tried using undionly.kkpxe as the bootloader in DHCP but get same issue. A long row of dots accumulate after the “Configuring (net0 {MAC Address})” then an error flashes on the screen too quick to read and the laptop reboots. The error message tags itself to the end of the dots. It seems to be "Error {some sort of hex error code} {some further text I cannot catch}. I have tried many times to pause the screen just as it appears but have been unsuccessful. I could try videoing it if you think it may be important to know what the message says.

    Originally I thought it may be a dodgy kernel as our old fog server 0.29 used to image these with pxelinux.0 fine. But I downloaded an old “kitchensink” kernel and pointed the host to it but nothing changed. It isn’t getting as far as downloading the kernel files.

    I am currently using FOG 1.2.0 on Ubuntu 12.0.4 LTS.

    Any ideas or did I miss a post which sorted this?



  • Hi fre2709,

    Have you resolved your issue ?
    I have a similair problem with my HP8000 USDT … On twenty PCs, just 2 can boot (i)PXE correctly … Other computer model works fine)
    I have checked the BIOS version, try an update BIOS, etc etc …

    I’m going crazy …

    Basic informations :
    FOG Version : 1.2.0 on Debian 7
    OS Client : Windows 7 PRO.
    Fog Install LOG : [url]http://pastebin.com/uRiN9x3c[/url]



  • Hi Jaymes,

    have checked the manufacturers web-site and the BIOS on the machines is already the latest. As far as the switches go though, because I am having to remove the HDD to image it in another chassis, I have been doing them one at a time. All on the same switch, same port. I still don’t understand why every other unit could be imaged on this LAN cable except the T5760 Acer.

    Also it doesn’t explain why one out the twenty works fine and can be imaged in its own chassis, the other nineteen won’t…

    Kind Regards,

    Frank


  • Developer

    You can check with the manufacturer and see if they have a BIOS update you can apply. I have several machines that do this and a BIOS flash will solve it in my environment.

    Something else I noticed, some older managed switches don’t like FOG, they disable ports and cause all kinds of trouble with receiving the boot files. Can you try a different switch or hub?



  • Its looking like a possibility that there is some issue with the Acers getting an IP at iPXE handover.

    [COLOR=#ff0000]Tom Elliott said: System will only reboot, if it can’t pick up DHCP. 0x040ee119 or something like that.[/COLOR]

    It is strange though that I have one unit which PXE’s fine and 19 that will not. They are all on the same BIOS revision, same version of PXE Rom. Only thing I noticed during boot was all the others come up with what appears to be a valid GUID during DHCP. The one that works shows a GUID of all FF’s.

    Could this be the reason? Can’t really see how, but it is the only difference between them.



  • Hi Robin,

    the issue I have is with Acers. However, EUFI boot is disabled and has always been disabled because we were working with an older version of FOG. AHCI mode has been set to IDE (equivalent to LEGACY in other BIOS’s). Something in iPXE is not compatible with these laptops for some reason…

    Kind Regards,

    Frank



  • I guess it does depend on the device’s BIOS. I’m currently building 215 Panasonic G1 Toughpads on Win8.1 and my colleague who has produced the build decided early on to disable UEFI. On these units there is also a ‘CSM’ function which I believe can help with the problems you’re seeing.

    Nothing like that on these HP’s ?

    Cheers
    Robin



  • Thx Ch3i,

    i am not completely surprised HP do something non-standard. We have some Elite series ones which luckily work OK.

    This is something different. These laptops used to work with the old FOG 0.29 server fine. It is definitely an issue with the way FOG now uses iPXE. Hopefully Tom et al, will come up with a solution. If secure boot is starting to be an issue also, then something will need to be done about fixing FOG to work with it. More and more newer PC’s and laptops are using this EUFI boot which appears to be hit and miss whether FOG will work or not.

    Newer BIOS’s will not even let you “Legacy” boot now which was a workaround to getting an image put onto a computer with FOG.


  • Moderator

    Hi,

    I have this problem on some HP computers (Family series), and can’t resolve it. I think it’s like a secureboot but I can’t disable it.

    Regards,
    Ch3i.



  • Hi All,

    Have trunked the TFTP files and copied them as suggested by Tom and Robin. This has not changed the situation though. These darn Acer laptops will still not iPXE correctly…

    Any further ideas about this issue? Having to remove the hard drives and image them in a chassis that does iPXE.


  • Senior Developer

    When doing the upgrade of ipxe files the info you see there is relevant to do a full upgrade but it’s also relevant to only download the TFTP files. Two differences thought.

    Change the link to download from to [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp[/url]
    Just copy the files in the downloaded folder to /tftpboot.

    [code]cp -Rf tftp/* /tftpboot/[/code]



  • Hi All,

    Thx for the SVN info Robin. So the only way to try out the new trunk KPXE files is to upgrade our fog server?

    Tom, I tried ipxe.pxe and seem to be still getting the "Error {some sort of hex error code} {some further text I cannot catch}, so I swapped back to undionly.kpxe, so is trunk the only way to go now?..



  • Hi from another Linux noob ;-)

    There’s some information here that will help: [url]http://www.fogproject.org/wiki/index.php/Upgrade_to_trunk[/url]

    Kind Regards,
    Robin



  • Thanks Tom,

    I’ll try ipxe.pxe as a bootfile for DHCP.

    I am a bit of a noob with Linux. How do obtain and use the files in trunk.


  • Senior Developer

    It’s absolutely correct that Portfast will fix the dhcp problem.
    You could try ipxe.pxe, or maybe try the ipxe files contained in trunk?



  • Hi Tom,

    No, as I said it only seems to be this particular model of laptop. I took the hard drive out of it, installed in in a different model ACER (P255M) and downloaded an image to it (turned 255 off after imaging complete). I swapped it back to its original chassis booted it and am in the process of updating it ready to capture. Which I am unable to do at the moment and will have to juggle HDD’s to get it uploaded.

    Coincidentally we had the issue with infinity loop on everything until we turned on PORTFAST.

    The Atheros bootrom seems to pick up an IP because some addresses appear on the screen (again too quick to catch) until it hands over to iPXE. The error message seems a lot faster to disappear when using undionly.kpxe because I only managed to catch it when i switched to undionly.kkpxe so was it because undionly.kkpxe doesn’t exist? Did I use the wrong bootfile name?


  • Senior Developer

    System will only reboot, if it can’t pick up DHCP. 0x040ee119 or something like that.

    Are other systems having similar issues/


Log in to reply
 

371
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.