IPXE fails to boot to menu in 1.2



  • Hi guys,

    I setup a new box with Ubu 14.04 and Fog 1.2 I cannot get PXE menu. See the pic included with this post for what i get. After what you see in the picture it boots straight to the hard drive. Any ideas on what I need to check? Is there a key sequence I need to press to access the menu now?[ATTACH=full]1462[/ATTACH]

    [url="/_imported_xf_attachments/1/1462_20141031_075224.jpg?:"]20141031_075224.jpg[/url]


  • Developer

    I have a few questions about your network.

    1.)What network switches do you have?
    2.)Is STP enabled?
    3.)Are the host and server on different VLANS?



  • Do you have any firewalls enabled?

    Disable firewall, at least for testing
    [CODE]
    sudo ufw disable
    [/CODE]

    You could also try restarting the tftp service
    [CODE]
    service tftpd-hpa restart
    [/CODE]



  • I tried both, no dice. When I rename it I get a {trying to load pxelinux could not find bootfile} type message. When I do the sym link I get the same error as in the pic I posted.



  • It looks like there’s a pxelinux.0.old in the /tftpboot directory. You could try renaming it to pxelinux.0, or do as I suggested above

    To create the symbolic link:

    [CODE]
    ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0
    [/CODE]



  • I set my new fog box with the same IP as the old one and I am just unplugging/plugging them in when I need production at the moment. I will research the sym link and try if possible, otherwise I will do the dnsmasq. Thanks for your input, your comment about the tftp file is what made me go “oh yeah the pxe file name is different above .32”



  • Yeah, you also need that change, sorry, I assumed you did. Make sure option 66 is also the new FOG IP. You may be able to create a symbolic link from pxelinux.0 to undionly.kpxe for now without making change to option 67 or involving dnsmasq to verify it works, just make sure option 66 is the correct IP. I’ve never done it to try, so I can’t make any promises



  • I am starting to think this is an issue with the scope settings for the boot filename. 067 needs to be changed from pxelinux.0 to undionly.kpxe since I am trying to move from .31 to 1.2. I set the new fog server up to use dhcp for expediency sake so as not to have to involve the people that manage our dhcp until I had it up. I think I will try DNSMASQ for now and once I can see that I can indeed move my production box to 1.2 I will let theem know to make the change. If 067 is currently set to pxelinux.0 would DNSMASQ with proper settings for iPXE allow me to circumvent that while I test out 1.2?



  • You could try a kernel upgrade and see if that has any effect

    To download the 64 bit kernel:
    [CODE]
    wget --no-check-certificate http://mastacontrola.com/fogboot/kernel/bzImage
    [/CODE]

    then backup the original 64 bit kernel and replace it with the new kernel
    [CODE]
    mv /var/www/fog/service/ipxe/bzImage{,.ORIG}
    cp bzImage /var/www/fog/service/ipxe/bzImage
    [/CODE]

    Then see if you can boot successfully to the FOG menu

    or try a different tftp file



  • My current production box is fog .31 on Ubu 10.04. The situation above happens on both my HP6005’s and 6305’s models.



  • Have you had FOG running before and same version and setup? Does it do the same thing with all machines you try to boot or just one model?


Log in to reply
 

708
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.