Fog 1.2.0 and iPXE boot loop



  • Good morning all,

    I’ve been searching the forums for the past few days re my issue to no avail so hoping someone here can help or point me in the right direction to look. Most “official” documentation on the forums refernces the 0.3x versions

    Recently upgraded our old Fog Server running Ubuntu 10.04 32bit and Fog 0.32 due to various (non-fog) related performance issues. We now are running Ubuntu 12.04.05 32bit and Fog 1.2.0 which we are keen to try out to support new Windows 8 deployments.

    DHCP scope has been changed from pxelinux.0 to[FONT=Tahoma][B] undionly.kpxe[/B][/FONT]

    Clients are a mix of (very) old IBM S50s running XP, Lenovo Thinkcentre Edge 72s running Windows 7/8 and Dell 3010/390’s the same plus a hodgepodge of others.

    [B]THE ISSUE[/B]

    On boot the machine gets regular PXE menu which then changes to an iPXE menu and then at the end it throws an error but disappears to quickly to see and repeats the boot process in an endless loop.

    I’ve attached 2 images showing the PXE and iPXE menus I do see on screen during boot - sorry they are low quality as taken on my phone. I’ve also attached fog.log from one of the clients.

    [B]WHAT I’VE FOUND[/B]

    I’ve seen posts re others having an “infinity loop” and reference to making sure switches have Spanning Tree enabled (ours do) and Portfast enabled (ours don’t) but this was on one forum post and is not mentioned anywhere on the userguide as far as I can see. Links below are the 2 I’ve found with reference to “infinity loop”

    [url]http://fogproject.org/forum/threads/dell-optiplex-960-boot-loop.10769/[/url]
    [url]http://fogproject.org/forum/threads/cant-do-pxe-boot-on-hp-probook-645-fog-1-2-0.11297/[/url]

    The machines we use here are either using an old BIOS pre UEFI due to their age, or in the case of new machines are being booted in Legacy mode with Secure boot turned off.

    Having read a little of the documentation on the [url]http://ipxe.org[/url] site it would apper that ROMs need to be flashed to support ipxe or you need to set up chainloading to link ipxe to an existing pxe rom. I’ve also found this [URL=‘http://ipxe.org/howto/msdhcp#pxe_chainloading’]link [/URL]which refers to configuring the DHCP server via Define User Classes.

    [URL=‘http://www.fogproject.org/wiki/index.php/Boot_looping_and_Chainloading’]This link[/URL] on the fog forums details how to set up chainloading - is this the correct step to follow for latest version of Fog? Or do I just need new boot files as others have tried? And if so can someone advise how to set the defauly boot from undionly.kpxe to undionly.kkpxe for instance if that’s what is required.

    Any help anyone could give with the above would be greatly appreciated.

    regards, Kiweegie.

    [url="/_imported_xf_attachments/1/1446_PXE menu.png?:"]PXE menu.png[/url][url="/_imported_xf_attachments/1/1447_iPxe menu.png?:"]iPxe menu.png[/url][url="/_imported_xf_attachments/1/1448_fog.log.txt?:"]fog.log.txt[/url]



  • Hi Tom/Wolfbane

    thanks for the info and for getting documentation updated which will no doubt help others doing this. In our case the networking team have confirmed that STP is enabled but that portfast is not. We’re looking to roll this out again in a couple weeks but for now have gone back to 0.32.

    Our network team have advised tha as well as configuring portfast they will also configure BPDU Guard to avoid network loops which could bring network down as discussed in [URL=‘https://learningnetwork.cisco.com/thread/3160’]this cisco thread[/URL].

    I’ll confirm once we have this up and running and include any other gotchas we encounter.

    thanks again, Kiweegie


  • Developer

    OK, after some review we saw that there was no documentation on what exactly to do with STP/portfast/Rapid STP for fog v1.x.x. I hope this information helps clear a few things up. I understand you have a boot loop but this is typical of STP settings to be fussy.

    [url]http://fogproject.org/wiki/index.php/IPXE#What_do_I_enable_and_disable[/url] (See section 5)


  • Senior Developer

    It’s not fully documented as we don’t know really why it’s a requirement. We just know that it works best. Either disable STP, or enable Rapid/Portfast.



  • I’ve attached my foginstall.log and last bits of my apache error.log too in case thats useful at all. There are a stack of entries against multiple different IP addresses in the Apache log showing File does not exist: /var/www/fog

    regards Kiweegie.

    [url="/_imported_xf_attachments/1/1449_foginstall.log.txt?:"]foginstall.log.txt[/url][url="/_imported_xf_attachments/1/1450_apache_error.log.txt?:"]apache_error.log.txt[/url]



  • Hi Tom and many thanks for the speedy reply…

    We do have Spanning tree enabled but not Portfast as per my original message

    [QUOTE]I’ve seen posts re others having an “infinity loop” and reference to making sure switches have [B]Spanning Tree enabled (ours do)[/B] and [B]Portfast enabled (ours don’t)[/B] but this was on one forum post and is not mentioned anywhere on the userguide as far as I can see. Links below are the 2 I’ve found with reference to “infinity loop”[/QUOTE]

    I can get our network team to enable Portfast but wanted to confirm that was a requirement first as I’ve not seen it documented anywhere other than a comment you made on a post to another forum member.

    I’m not sure what you mean re the Modules though - could you elaborate on how to use the truncate piece and what that achieves?

    To recap, this is a clean install of Ubuntu 12.04 and a clean install of Fog 1.2.0, not an upgrade from ealier version. I’ve copied the original images directory over but all else is configured fresh.

    regards Kiweegie


  • Senior Developer

    Does your network have STP enabled?

    If you do have STP (Spanning Tree Protocol) is Rapid STP/Portfast enabled?

    For the client side of the house,

    I’d recommend this:

    For upgrades, so much changed particularly dealing more with ID’s rather than letters or phrases. For the Modules, Remove all module associations with:

    [code]truncate table moduleStatusByHost[/code]

    Then create a group and put all the hosts you want modules enabled to.

    From the group, choose service settings and select the ones you want on the host. Then submit. It will update all the hosts in the group with the related modules to be enabled.


Log in to reply
 

381
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.