Blank screen after PXE Menu when imaging on DVI port but, not on VGA



  • [FONT=Tahoma][COLOR=#141414]We setup a test bench to try out FOG 0.32 with a few Dell Optiplex 745’s. These Dell’s have both VGA and DVI display ports on their integrated Intel Graphics Media Accelerator 3000. If we plug the monitor into the DVI port, we can see the PXE boot menu but the screen goes blank and displays a, “Cannot display this video mode” error when uploading/downloading images or anything after it exits the initial text-mode after selecting a PXE menu option. If the monitor is plugged in to the VGA port then we can see everything as you would normally expect.

    With monitor plugged into DVI port of client:

    1. Graphical PXE Menu - OK
    2. Brief Text Mode ("…Ready.") - OK
    3. Actually doing something - Not OK

    Superficially, even if we can’t see what’s happening it still works but if we go live with FOG this will be a problem - we have 100’s of machines that will have the monitor plugged into the DVI port and the lack of feedback is going to be an issue.

    Any clues as to how I can change the display mode/resolution would be greatly appreciated.[/COLOR][/FONT]



  • Thank you very much, Tom, and thanks for everybody who spent time on this discussion thread. It has been of immense assistance to us. My production fog is running 64 bit Ubuntu Server, but I’ll try your kernel on my test fog in Virtual Box. We will virtualize the fog server within 6 months time, so a testing of a redo of the fog configuration is ahead of us, just after Christmas. Anyway, I fixed the problem by using another computer, without a DVI graphic, to upload the image the image of the computer with the DVI interface.


  • Senior Developer

    You can try my kernel.

    I’m back to 32 bit kernel and init.gz for the time being.

    Try:

    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]



  • I guess not. Thanks.


  • Developer

    If no video displays, the kernel drivers are STILL not right for your video card.



  • And if we did both of the above and the screen still shows up blank, what then. I really appreciate the help above, finding out that the Kernel for Fog was also something that could be upgraded, but what next?



  • Yahoo!



  • Thank You so much for your help that worked!! I have been able to upload my image and download an image onto these computers, again thanks so much for your instructions they worked perfectly :-)



  • [FONT=Tahoma][COLOR=#141414]/tftpboot/pxelinux.cfg/default is owned by fog:root so you need to sudo/su yourself to edit and save changes to the file by executing something like this from the terminal:[/COLOR][/FONT][COLOR=#000000][SIZE=3][FONT=Andale Mono][CODE]$ sudo nano /tftpboot/pxelinux.cfg/default[/CODE][/FONT][/SIZE][/COLOR]

    [COLOR=#141414][FONT=Tahoma]I haven’t tried updating the kernel from the FOG web interface - I did it manually:[/FONT][/COLOR]
    [CODE]$ su

    wget https://downloads.sourceforge.net/project/freeghost/Kernels/Kernel-3.2.4.core/Kernel-3.2.4.core

    cp /tftpboot/fog/kernel/bzImage /tftpboot/fog/kernel/bzImage.bak

    mv Kernel-3.2.4.core /tftpboot/fog/kernel/bzImage[/CODE]



  • I have this same issue except I have no option to connect VGA these are ultra small form factor Optiplex 745, I am running Ubuntu 11.10 and 0.32 of FOG. I tried to update the kernel to 3.2.4 from the web interface in FOG but it fails when it tries to download. I am still learning about FOG and I tried to add the append vga=771 in this file /tftpboot/pxelinux.cfg/default but it would not save the changes any help getting this resolved would greatly be appreciated :-)



  • Yep! Also all better with the 3.2.4 kernel!!!



  • The “vga=771” addition to FOG_KERNEL_ARGS and every “append” in /tftpboot/pxelinux.cfg/default has got us 100% happy with the DVI issue on these Dell’s. I downloaded the 3.2.4 kernel and will give it a try and report back.
    Thank you!!!


  • Moderator

    are you using the latest kernel, 3.2.4 ? this has resolved some glitches i received relating to graphics of certain machines



  • Adding “vga=771” to the “append” definitions in “/tftpboot/pxelinux.cfg/default” resolved the issue but, isn’t global.

    I tried adding “vga=771” it to Other Information -> FOG Settings -> General Settings -> FOG_KERNEL_ARGS in the FOG Manager to make it global but that did not work. I also tried adding it per host via Host Management -> myHostName -> Host Kernel Arguments but that also did not work. The settings FOG Manager may only apply to imaging because with the changes to “/tftpboot/pxelinux.cfg/default” and FOG_KERNEL_ARGS everything seems to work fine with DVI.

    FWIW, I found a similar thread at [SIZE=12px][FONT=Helvetica][COLOR=#223cfb][U][url]http://fogproject.org/forum/threads/optiplex-990-issues.145/[/url][/U][/COLOR][/FONT][/SIZE]


Log in to reply
 

736
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.