Make "Capone Deploy" the first option in PXE Boot Menu



  • Is there a way to make Capone Deploy the first option in the Boot Menu Sequence?


  • Senior Developer

    Okay,

    So there is no issue with Capone, or the menu generation.

    Rather, it’s the method at which you’re creating the DMI/Shutdown fields with the image association fields.

    These are two separate forms.

    What this means:

    When you are setting up capone, it gives one page full of all the information you need.

    The DMI and shutdown fields are their own form because these are global values.

    The Image association field is it’s own form to separate between the two.

    Please, set your DMI/Shutdown fields and use it’s corresponding button to update.

    Then set your image associations (or leave them if you set them already.)

    Then boot a host, if the menu isn’t set, it will create the menu item.

    After the item is created, you can specify it as default.



  • Alright, I don’t know what I did, but I think that clicking the “Save Changes” in the General Settings window added the fog.capone item to my iPXE Menu items. I think it is working now.



  • i configure Capone in the plugin management page.


  • Developer

    did you configure capone on the plugin management page, or on the general settings page?



  • Tom,

    I’ve done this a few times and I can’t seem to get it to work. I even uninstalled Capone, disabled plugins, and then proceeded to upgrade to SVN. Reenabled the Plugin system, reinstalled Capone, reconfigured it. Nothing. I check inside MySQL and I see the Capone table installed. (I also checked that it had been cleared when I unintalled Capone).

    Plugins are enabled.
    Capone is installed.
    Capone is configured with DMI and Image.

    fog.capone is not in iPXE Menu Configuration. And I don’t see Capone Deploy as an option during a host bootup.

    I could add the menu item manually, but I don’t know the correct parameters for Capone.

    I’m doing this based on your recommendation to upgrade to SVN to show Capone as the First Option in the Boot Menu.


  • Senior Developer

    My guess is you don’t have to upgrade to SBN know it won’t hurt anything but I think the problem is Capone table is still in the database and it needs to be removed. Then rerun the installer for it and you should see things appear



  • Should I uninstall the plugin before I upgrade to SVN?



  • It was installed before I upgraded to SVN. I removed it, and installed it again, but it ain’t coming up on PXE Menu options.


  • Senior Developer

    Install the capone plugin?



  • Tom,

    I upgraded to SVN and the server is up an running (ran into a few issues with passwords again). But I can’t seem to be able to add Capone into the Boot menu. I don’t have fog.capone as an option either. How can I manually add fog.capone? What are the necessary parameters?



  • Cool, I will make a copy of my VM and try to upgrade.


  • Senior Developer

    You can upgrade.



  • I was afraid you were going to say that. Is it possible to upgrade my current installation to SVN? Or would I need to start again from scratch?


  • Moderator

    [quote=“Tom Elliott, post: 37808, member: 7271”]I think this is only valid for SVN, I’m pretty sure this wasn’t quite yet implemented in 1.2.0.

    That said, if you want to try out SVN so you can see the differences coming forward, please feel free. In that case, you shouldn’t need the customized versions of the init’s either.[/quote]

    Oups ! Sorry ;)


  • Senior Developer

    [quote=“ch3i, post: 37805, member: 2513”]Hi,

    I have not test, but in Fog Configuration\iPXE Menu Configuration, you can select fog.capone and check “default item”. By default it’s fog.local.

    Regards,
    Ch3i.[/quote]

    I think this is only valid for SVN, I’m pretty sure this wasn’t quite yet implemented in 1.2.0.

    That said, if you want to try out SVN so you can see the differences coming forward, please feel free. In that case, you shouldn’t need the customized versions of the init’s either.


  • Moderator

    Hi,

    I have not test, but in Fog Configuration\iPXE Menu Configuration, you can select fog.capone and check “default item”. By default it’s fog.local.

    Regards,
    Ch3i.


Log in to reply
 

510
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.