Join Domain "Unknown Error Code:2"



  • First post so be gentle :)

    When I try to join a domain I get “Unknown Error Code:2”

    I have searched and only found one other person with this error so far and it was pertaining to AD OU. I verified that my syntax is correct in that, and I also tried it blank as well and still get error code 2.

    When I add the computer to the domain manually the log file indicates that it found the account and was already added to the domain. That means that its communicating with the AD server correctly, right?

    I run fog 1.2.0.

    Has anyone experienced this before?



  • AH! I think I fixed it. I noticed the default group was a CN not an OU. I made a OU and changed it in both spots and upon next reboot it joined successfully.


  • Developer

    These seem correct but I don’t use anything in the FOG_AD_DEFAILT_OU.

    Please check the Hostname Changer service. There are 3 that is THREE locations that this must be ticked.
    1.)Fog Configuration–>Fog Settings–>Fog Service - Hostname Changer
    2.)Service Configuration–>Host Registration
    3.)Host Management --> [Selected Host] --> Service Configuration

    Also what EXACT revision are you using? I confirmed a bug in one of the revisions but It may not have been localized to that revision.



  • Here are the files you requested.

    Thanks for any help!

    Untitled.pngUntitled2.pngfog.txt


  • Developer

    Please provide the host fog.log, snapshot of fog settings–>AD, and verify that under Hostmanagement that that service is enabled.


Log in to reply
 

390
Online

38918
Users

10688
Topics

101399
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.