Fog 1.2.0 / DNSMasq / Ubuntu 14.04.1 - pulling my hair out :)



  • Hi, so I have been having some problems with fog lately. The issue is very difficult to pinpoint as it sometimes works flawlessly and sometimes does not.
    For example, I booted to FOG and registered a host, assigned the image and imaged a machine perfectly all working great. Then rebooted and tried to get to get back into the FOG menu but all I got was default.ipxe…timed out. I read that there have been some problems with booting iPXE so I tried [URL=‘http://fogproject.org/wiki/index.php/Chainloading_PXE_to_iPXE_using_pxelinux.0’]chainloading PXE to iPXE. [/URL]This seemed to be working for me as the FOG menu came back. But when I try to load any of the menu items, the client can’t interact with the network.
    For example at the moment, I can go to my advanced boot menu, [URL=‘http://fogproject.org/forum/threads/fog-0-33b-edit-pxe-menu.10403/#post-26425’]details about this computer[/URL] and it will show an IP of 10.129.1.124 but when I go to the main menu and “check client system information”, I get lots of “DHCP/BOOTP: Reply not for us…” messages.
    [IMG]http://i.imgur.com/fjbDym8.jpg[/IMG]
    When the “check client system information” finally loads, I try to check the assigned IP details and it doesn’t show anything for eth0 as if it hasn’t been able to initialize it.
    [IMG]http://i.imgur.com/ZN0yj68.jpg[/IMG]

    Any idea where to go next for troubleshooting?

    Output from Syslog when booting to FOG:
    [CODE]Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 available DHCP subnet: 10.129.1.4/255.255.252.0
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 vendor class: PXEClient:Arch:00000:UNDI:002001
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 user class: iPXE
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 PXE(eth0) 00:24:e8:b3:c7:8c proxy
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 tags: eth0
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 bootfile name: undionly.kpxe
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 next server: 10.129.1.4
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 broadcast response
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 sent size: 1 option: 53 message-type 2
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 sent size: 4 option: 54 server-identifier 10.129.1.4
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 sent size: 9 option: 60 vendor-class 50:58:45:43:6c:69:65:6e:74
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 sent size: 17 option: 97 client-machine-id 00:4c:4c:45:44:00:31:37:10:80:57:ca:c0:4f…
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 sent size: 41 option: 43 vendor-encap 06:01:03:0a:04:00:50:58:45:08:07:80:00:01…
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 available DHCP subnet: 10.129.1.4/255.255.252.0
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 vendor class: PXEClient:Arch:00000:UNDI:002001
    Oct 8 13:29:22 rndubuntu dnsmasq-dhcp[6454]: 3196037634 user class: iPXE
    [/CODE]

    Apache2 access.log
    [CODE]10.129.1.124 - - [08/Oct/2014:13:32:52 +0100] “GET /fog/service/ipxe/boot.php?mac=00%3A24%3Ae8%3Ab3%3Ac7%3A8c HTTP/1.1” 200 3101 “-” "iPXE/1.0.0+ (53653)"
    10.129.1.124 - - [08/Oct/2014:13:32:52 +0100] “GET /fog/service/ipxe/bg.png HTTP/1.1” 200 45139 “-” "iPXE/1.0.0+ (53653)"
    10.129.1.124 - - [08/Oct/2014:13:32:55 +0100] “GET /fog/service/ipxe/advanced.php HTTP/1.1” 200 1567 “-” "iPXE/1.0.0+ (53653)"
    10.129.1.124 - - [08/Oct/2014:13:32:57 +0100] “GET /fog/gparted/vmlinuz HTTP/1.1” 200 2650370 “-” "iPXE/1.0.0+ (53653)"
    10.129.1.124 - - [08/Oct/2014:13:32:58 +0100] “GET /fog/gparted/initrd.img HTTP/1.1” 200 16241083 “-” “iPXE/1.0.0+ (53653)”
    [/CODE]

    Attached the foginstall.log file if that’s any use too.
    Appreciate the help! :)

    [url="/_imported_xf_attachments/1/1414_foginstall.log.txt?:"]foginstall.log.txt[/url]


  • Developer

    Separate those VLans and everything should be golden.


  • Moderator

    [quote=“d31b0y, post: 37642, member: 24199”]Hmm, that must be it then in that case. We use Lync here. Ok, thanks I will look at putting the FOG server on it’s own VLAN. I only use it for imaging anyway so it shouldn’t cause too many problems.

    Thanks for the info.[/quote]

    I test this morning on our Lync Vlan, and I have the same problem !!! ;)



  • Hmm, that must be it then in that case. We use Lync here. Ok, thanks I will look at putting the FOG server on it’s own VLAN. I only use it for imaging anyway so it shouldn’t cause too many problems.

    Thanks for the info.


  • Developer

    Do you have a VOIP phone system? If so is it on a separate VLAN?

    Typically you see this error when you are using the same vlan for VOIP and for imaging.



  • Yes, I have tried with a few different machines. Each machine seems to be consistently failing now.


  • Moderator

    Hi,

    Did you try with another machine ? (another model)

    Regards,
    Ch3i.


Log in to reply
 

802
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.