FOG Virtual Machine



  • Hello,

    I am not sure where to put this, so anyone who thinks it must be moved, please do so.
    I tried to get Fog on a series of hardware, but recently i bought a I5 with 8GB for my Windows 2012 server, and from there i used a virtualbox to get FOG Virtual machine to work. Installing went very smooth, redirecting the virtual network card to the hardware NIC made it possible that i could ping this FOG installation. Then i wanted pixie-boot to the FOG machine, but what i tried and what i did, didn’t make it work. I got no errors from FOG, but in the proces i found that the TFTP was not responding. Is there a way to get that vital part of FOG working? or am i just stupid and overlooked something important. Please fire any question you have, i will try it and tell you what it says.
    Thanks for any input.


  • Developer

    The client is for things after imaging(Renaming, deploying snapins, etc).

    As far as your problems now it looks like your client is not connecting to your DHCP server as that is where the IP comes from.



  • Hi, thanks for thinking along, but i had to reinstall that old HP laptop in order to get a fresh view. I changed the bootp option in undionly.kpxe and i think too that it was a coincident, shameless OS!! ;)
    Well, we have to work with it, and don’t tell me that i have to step away from Windows, because i don’t want to…it has it’s advantages too. :D
    To the point: I am now so far that when i start a task in FOG to upload that HP image to the fog server, it wakes the laptop but there is no connecting to the fog server for uploading. It tries to connect, it does not get a ipadres and all, but by memory i thought there should be a client that i need to install, i can’t find it. Must have over looked it in the process. So i’m looking on the forum at this time to find that missing piece.
    I still am puzzled why it does not connect to the DHCP from my windows server. I’m shutting down one of them now and see if that helps.


  • Moderator

    Option 60 on your DHCP did not have anything to do with the domain loosing trust on your laptop. That was just a bad coincidence.

    It sounds like you are getting pretty close to getting it working!


  • Developer

    You want undionly.kpxe in option 67.

    Don’t you have a local account on any of your machines? You can log into the local admin account and disconnect/rejoin the domain instead of reinstalling windows.



  • No go this last option, deleting number 60. I can’t get into my domain because of a failing trust relationship. It is in Dutch so i can spill it here but that makes no sense if you don’t understand the language.
    I’m putting thing back the way they were and retry to log in on the domain.
    Btw. the task i gave FOG, upload a image, got on the laptop from which i just spoke a tftp timeout. it is still trying… and the home screen of the fog server says that there is no task, no activity…
    I’ll be back later…

    And later it is, it seems that for no reason at all my old hp laptop decided to “I will not log in anymore” in windows domain. So, i have to reinstall the darn thing. Coming back on a later time.



  • I had done a few tweaks,
    sudo /bin/sleep 30 && /etc/init.d/tftpd-hpa restart
    DHCP option 66 10.1.0.21
    DHCP option 67 pxelinux.0 or undionly.kpxe (which one do i really need here?)
    and as stubborn Microsoft sometimes is, i deleted option 60 in DHCP (PXEClient) from both servers in scope and server options.
    Now when i start my older laptop and go to boot from lan, i get FOG. So the next step is quick host configuration and that worked too.
    Now i try to get an image from it, remotely… cross my fingers…



  • Hi there, new day, fresh start, new problems to come…((-:
    I looked at SVN, briefly, but when i get this VM running, or when i get the right hardware to install ubuntu and FOG, then there’s no need for this SVN. I guess at this point, i want to make this work, so stubborn as i am, i need this for my egoboost ((-:
    No, i’m joking, but it is on my W2012 server at this time the simplest solution without compromising a lot on my server.
    I’m still looking into former reactions, and trying the best i can do for now.



  • [B]Thanks for that:) [/B],
    version is
    Ubuntu 8.04.3 LTS
    I will look into your other option, but not at this moment, i need to relax. I’m coming back on this issue tomorrow


  • Developer

    [CODE]lsb_release -a
    [/CODE]

    Will give you the OS version.

    As for upgrading within the VM, why not use SVN?

    [url]http://www.fogproject.org/wiki/index.php/SVN[/url]



  • The version of ubuntu, i don’t know (is there a way the cmd can tell me?)
    I would like to know how to upgrade FOG within VM, but i can’t find a neat way to do it.
    Updating on retry to [FONT=Consolas]ps ax|grep tftp[/FONT]
    4490 ? Ss 0:00 in.tftpd -s /tftpboot
    6105 tty1 R+ 0:00 grep tftp
    This was the output, but from WS or W2012 server still no tftp cmd line response… Weird.


  • Developer

    I did miss a letter, my apologies. If it started the service there should be an output listing the pid hat it started with.

    What version of Ubuntu are you running? And if you are doing re-installs of FOG why are you not using a more recent version??



  • So, you say tftp is not working, i had to reinstall the whole thing, and disabled the firewall, i tried to get your option to work, you forgot a letter, [FONT=Consolas]sudo /etc/init.d/tftpd-hpa restart [/FONT]so, i tried testing with the TFTP command but no response.
    There was no output from the server when i used the sudo command, it accepted and went to the next line…


  • Developer

    [quote=“avandel, post: 37492, member: 26498”]@BPSTravis i done that and the only reponse was:
    16451 tty1 R+ 0:00 grep tftp
    @ VincentJ, the first thing i tried was update Ubuntu and FOG. Ubuntu went ok through the fog menu but FOG itself got the error message: name or service not known
    download not found
    So i’m stuck with this. Yes, other downloads work fine, but the menu i’ll get, the one with 7 options, if i quit that, fog still runs???
    I guess so because i can still access the webinterface. How do i update within the VM environment, and does it save in the VM-file?[/quote]

    Then your tftp service is NOT running on your system which is why it’s not working…

    open a terminal and type:
    [CODE]sudo /etc/init.d/tftp-hpa restart[/CODE]

    If it starts correctly give it another shot, if it doesn’t please post the output.



  • I have my network safe, i mean i use only cabling. Had too much troubleshooting days finding that some wall had more iron in it than it needed. So, no wireless is interfering. I can ping the FOG server, i can reach its webserver from my ws and i can ping from my W2012 server to the FOG environment.
    Earlier i answered that this is a temporarily setup, and i do not want to install Hyper-V, because this will bring unkown areas to the problem. Later maybe if the hardware is still too far away i’ll reconsider installing Hyper-V.



  • I’ve noticed that if WDS is running on any other server, clients will look there first.
    I just moved FOG VHD off virtual box and onto HyperV and had problems until I realized that I got a new IP assigned.
    This was due to new mac address being issued which made my prior reservation invalid.
    In HyperV, VM settings, Advanced Features, I was able to assign a static MAC address to match the prior DHCP reservation



  • @BPSTravis i done that and the only reponse was:
    16451 tty1 R+ 0:00 grep tftp
    @ VincentJ, the first thing i tried was update Ubuntu and FOG. Ubuntu went ok through the fog menu but FOG itself got the error message: name or service not known
    download not found
    So i’m stuck with this. Yes, other downloads work fine, but the menu i’ll get, the one with 7 options, if i quit that, fog still runs???
    I guess so because i can still access the webinterface. How do i update within the VM environment, and does it save in the VM-file?


  • Moderator

    why are you running 0.27 when 1.2 is out? :)


  • Developer

    Have you checked to make sure tftp is running?

    On your fog server:
    [CODE]ps ax|grep tftp[/CODE]

    Your output should look like this if the TFTP service is running:
    [CODE] 6864 ? Ss 0:00 /usr/sbin/in.tftpd --listen --user root --address 0.0.0.0:69 -s /tftpboot
    13104 pts/1 S+ 0:00 grep --color=auto tftp
    [/CODE]



  • I give up, i have failed in my work, my life and in the choice of computer programs… sigh…
    I think i go back to the time where i had to install windows 3.1 manually with floppydisks:( sometimes 40 times a week or more…
    I know that it can work, but i lack the people around me with the same interest and virality.
    Anyone to tell me to change this all the way around? happy to hear from you because there are so many variables doing a little bit of this and that, that it looks a no-go-situation.
    I’m not sure where to look now…


Log in to reply
 

434
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.