Unable to register Hosts (SVN 2361)



  • When trying to register a host via pxe it fails with “Unable to register host for reason” and never gives a reason…

    The the apache error logs has

    [Thu Oct 02 13:05:27 2014] [error] [client 10.72.92.246] PHP Parse error: syntax error, unexpected ‘[’ in /var/www/fog/service/register.php on line 33
    Followed by a large amount of the following error
    [Thu Oct 02 13:08:39 2014] [error] [client 10.72.94.48] PHP Fatal error: Call to a member function isValid() on a non-object in /var/www/fog/service/inventory.php on line 52


  • Senior Developer

    I believe this is now fixed.

    Most of the problem was because of duplicate hostMAC entries.

    The way I fixed:
    In mysql:

    [code]ALTER IGNORE TABLE hostMAC ADD UNIQUE INDEX hmHostID (hmMAC);[/code]


  • Developer

    That is happening because there is no task for the host. The error you encountered while starting the task prevents it from being made.

    Try setting the password for the fog user on the unix system to what shows in the web ui for your FTP password.



  • [quote=“BPSTravis, post: 37343, member: 22444”]Under storage management did your image path change? Otherwise this really sounds like an FTP issue. You can try resetting the password for the user “fog” to the FTP password you have listed in the web UI.[/quote]
    nothing has changed that i know of other than me doing the updates heres a video of what is happening

    [url=“http://www.youtube.com/watch?v=GSUa4u33hak”]www.youtube.com/watch?v=GSUa4u33hak[/url]

    and this happens for any host that is register to fog if the host is not register the menu screen will pop up


  • Developer

    Under storage management did your image path change? Otherwise this really sounds like an FTP issue. You can try resetting the password for the user “fog” to the FTP password you have listed in the web UI.



  • this is the error i get even on 2367
    Failed to create deployment tasking for the following hosts
    You must first upload an image to create a download task

    this is when i try from the webconsole



  • nothing should had change i just upgraded im about to upgrade to the latest bluid and see if that helps.


  • Senior Developer

    Did you FTP information change? Meaning, did you have to reinstall or did just upgrading help you out?



  • no i only have one and its on the same server


  • Senior Developer

    Do you have multiple storage nodes?



  • This post is deleted!


  • also when i try to deploy from the web console it now says i must first upload an image



  • ok I’m able to register host now but now I am unable to deploye or upload an image when i try to deploye the image the computer will boot to fog then as soon as it boots to fog it goes straight to boot to hard drive and it looks like it does this for any computer that is registered to fog now if it’s not register to fog it will let me register it and after i tell it to image now it reboots and it will boot to fog but as soon as it finishes the pxe boot to fog it goes straight to boot to hard drive


  • Senior Developer

    Once again, please try SVN 2263



  • same here still unable to register host in 2362 in full host registration and also when i try to manually add at host in the web console after i add it the mac address disappears and after i hit update and when i goto list all host the host is not in the list at all. Also want to point out that in the full host registration when i boot back to fog it will tell me the host is not registered however when i try to regesiter it with the same name it tells that a hostname a mac address is already register with that host name but if i go to the web console that host is no where to be found so try to name it something else same thing looked like it register but then when boots back to fog says its not register and i do the same steps again and it tells me that the last hostname is already register even tho you cant see it in the web console



  • I have reverted back to a VM snapshot taken of 1.2 before the SVN upgrade, I will have another look at updates when I get a chance.

    The SVN since 1.2 seems to be a lot better with the snapins though.



  • Updated to 2362

    Still unable to register via “Perform Full Host Registration and Inventory” pxe menu, get the same error message.
    When trying to register a host through the web interface claims to have been registered but, then unable to search for the Host.

    Checked the database,

    The hostID in the inventory table is being set to "0"
    The hmHostID in the HostMAC table is also being set to “0”

    Still seeing the below in the apache logs.

    [Thu Oct 02 13:41:41 2014] [error] [client 10.72.93.33] PHP Parse error: syntax error, unexpected ‘[’ in /var/www/fog/service/register.php on line 33


  • Senior Developer

    try 2362.


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.