Please Help: Fog Error 0x040ee119

  • Hi there,
    I co-manage a network of about 25 computers, all of them Dell Optiplex 790s running Windows 7. We decided to deploy an image. Using a 26th, identical Optiplex 790, I installed Debian and then Fog v1.2.0. When I try to PXE boot using a neighboring computer, it gives me the error: ERROR 0x040ee119 ( and the computer goes into a boot loop.
    Going to that URL did not provide me with any useful information.
    Please help with constructive comments, and please have any suggestions actually be pertinent to the problem at hand.

  • Developer

    We updated the wiki about a month ago to reflect these settings on Cisco, Dlink, and other smart network switches.

  • I ran into this issue with 250 HP 430 G2 laptops. DHCP would take 20+ seconds and then they would error. Other machines ie: 450+ Dell 3330’s had no problem. I make use of chainloading for some old HP probook 4320’s that ipxe doesn’t seem to like and have a standard deployment of fog on a debian box.
    Anyhow the switching gear is all Cisco 3560’s and that’s where my problem was.
    What solved it for me was that I needed to enable spanning-tree portfast on the ports that i was imaging from.
    DHCP is now less than 5 seconds and the machines no longer give the 0x040ee119 error and image correctly.

    Hope that helps someone.

  • You’re right… it’s not MySQL. 8):)

    Do your other 790 computers take that long to pull up DHCP? It may not matter but I ran into a similar but not identical issue with earlier FOG SVNs with lower revision iPXE.

    These earlier iPXE would fail on certain make/models until it was updated later. When iPXE failed, it did something weird to the NIC’s ability to communicate with the DHCP. On subsequent restarts, DHCP would take a very long time to eventually throw up a strange error (which I don’t recall), which led to no IP, and no iPXE and a boot loop.

    I was forced to launch into an OS on that computer, then release and renew the IP. Then after rolling back the iPXE on the FOG server, the client would grab an IP at the next startup and continue to iPXE.

    It probably has no connection, but I thought I’d throw that up there.

    However, I can’t recommend strongly enough that you update the BIOS on your 790.

    A18 is the latest at:
    There is an easy to reproduce security flaw that will allow any user to bypass your BIOS password security allowing them to boot from any device … if that sort of thing worries you. ;)


    I couldn’t upload a video directly, but here’s a link to it on my Google Drive account.

  • What would the ideal configuration be like?

  • Developer

    that’s usually an indicator that your network is not configured properly

  • Replacing the current file with the one you recommended did not help.
    It’s possible there is a new error code, but the screen flashed way too fast for me to catch it (as did the first error code), so I’ll have to record it on video and slow it down like I did before.

    If it makes a difference, it appears as if it takes a very long time to acquire DHCP information and, then it takes an equally as long time to configure the MAC address. I could be wrong but I want to cover all the bases.


  • This post is deleted!

  • Developer

    use it to replace the file of the same name in /tftpboot
    you may want to rename the existing file so that you may revert back

  • Pardon my ignorance, but what do I do with this file when I download it.
    I am very unfamiliar with FOG, and Linux in general.

  • Developer

    this has nothing to do with the kernel or mysql
    try the latest version of undionly.kpxe located here

  • Try updating to the unofficial kernel 3.15.5 (x86_x64) or even all the way to 3.16.3 (x86_x64).

    Also try: sudo service MySQL restart

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.