MAC IS null! only 0 mac address was found



  • 9/22/2014 11:52 AM FOG Service Engine Version: 3
    9/22/2014 11:52 AM Starting all sub processes
    9/22/2014 11:52 AM 14 modules loaded
    9/22/2014 11:52 AM * Starting FOG.AutoLogOut
    9/22/2014 11:52 AM * Starting FOG.SnapinClient
    9/22/2014 11:52 AM * Starting FOG.DirCleaner
    9/22/2014 11:52 AM FOG::ClientUpdater Starting client update process…
    9/22/2014 11:52 AM FOG::ClientUpdater Sleeping for 388 seconds.
    9/22/2014 11:52 AM FOG::AutoLogOut Starting process…
    9/22/2014 11:52 AM FOG::DirCleaner Sleeping for 52 seconds.
    9/22/2014 11:52 AM * Starting FOG.DisplayManager
    9/22/2014 11:52 AM * Starting FOG.GreenFog
    9/22/2014 11:52 AM FOG::DisplayManager Starting display manager process…
    9/22/2014 11:52 AM * Starting FOG.GUIWatcher
    9/22/2014 11:52 AM FOG::GUIWatcher Starting GUI Watcher…
    9/22/2014 11:52 AM * Starting FOG.HostNameChanger
    9/22/2014 11:52 AM FOG::GreenFog Sleeping for 33 seconds.
    9/22/2014 11:52 AM * Starting FOG.HostRegister
    9/22/2014 11:52 AM FOG::HostRegister Starting host registration process…
    9/22/2014 11:52 AM * Starting FOG.MODDebug
    9/22/2014 11:52 AM FOG::HostnameChanger Starting hostname change process…
    9/22/2014 11:52 AM FOG::HostnameChanger Yielding to other subservices for 9 seconds.
    9/22/2014 11:52 AM * Starting FOG.PrinterManager
    9/22/2014 11:52 AM * Starting FOG.SnapinClient
    9/22/2014 11:52 AM FOG::PrinterManager Starting interprocess communication process…
    9/22/2014 11:52 AM FOG::MODDebug Sleeping for 100 Seconds
    9/22/2014 11:52 AM FOG::PrinterManager interprocess comm startup: OK
    9/22/2014 11:52 AM * Starting FOG.TaskReboot
    9/22/2014 11:52 AM * Starting FOG.UserCleanup
    9/22/2014 11:52 AM * Starting FOG.UserTracker
    9/22/2014 11:52 AM FOG::SnapinClient Starting snapin client process…
    9/22/2014 11:52 AM FOG::TaskReboot Taskreboot in lazy mode.
    9/22/2014 11:52 AM FOG::TaskReboot Starting Task Reboot…
    9/22/2014 11:52 AM FOG::UserCleanup Sleeping for 18 seconds.
    9/22/2014 11:52 AM FOG::UserTracker Starting user tracking process…
    9/22/2014 11:52 AM FOG::DisplayManager Unable to continue, MAC is null!
    9/22/2014 11:52 AM FOG::AutoLogOut Unable to continue, MAC is null!
    9/22/2014 11:52 AM FOG::HostRegister Exiting because only 0 mac address was found.
    9/22/2014 11:52 AM FOG::SnapinClient Sleeping for 442 seconds.
    9/22/2014 11:52 AM FOG::TaskReboot No valid MAC addresses found!
    9/22/2014 11:52 AM FOG::TaskReboot No task found for client.
    9/22/2014 11:52 AM FOG::UserTracker Unable to determine MAC address, exiting…
    9/22/2014 11:52 AM FOG::HostnameChanger Attempting to connect to fog server…
    9/22/2014 11:52 AM FOG::HostnameChanger Module is disabled on this host.
    9/22/2014 11:52 AM FOG::HostnameChanger Host name was not found in the database.
    9/22/2014 11:52 AM FOG::UserCleanup Starting user cleanup process…
    9/22/2014 11:52 AM FOG::UserCleanup Attempting to connect to fog server…
    9/22/2014 11:52 AM FOG::UserCleanup Module is disabled globally on the FOG Server, exiting.
    9/22/2014 11:53 AM FOG::GreenFog Starting green fog…
    9/22/2014 11:53 AM FOG::GreenFog Attempting to connect to fog server…
    9/22/2014 11:53 AM FOG::GreenFog Module is disabled on this host.
    9/22/2014 11:53 AM FOG::DirCleaner Starting directory cleaning process…
    9/22/2014 11:53 AM FOG::DirCleaner Attempting to connect to fog server…
    9/22/2014 11:53 AM FOG::DirCleaner Module is disabled on this host.
    9/22/2014 11:54 AM FOG::MODDebug Reading config settings…
    9/22/2014 11:54 AM FOG::MODDebug Reading of config settings passed.
    9/22/2014 11:54 AM FOG::MODDebug Starting Core processing…
    9/22/2014 11:54 AM FOG::MODDebug Operating System ID: 6
    9/22/2014 11:54 AM FOG::MODDebug Operating System Minor: 2
    9/22/2014 11:54 AM FOG::MODDebug MAC ID 0 B0:10:41:61:CF:69
    9/22/2014 11:54 AM FOG::MODDebug MAC POST String: B0:10:41:61:CF:69
    9/22/2014 11:54 AM FOG::MODDebug A user is currently logged in
    9/22/2014 11:54 AM FOG::MODDebug Username: *Edited (Username)
    9/22/2014 11:54 AM FOG::MODDebug Hostname: LENOVO-PC
    9/22/2014 11:54 AM FOG::MODDebug Attempting to open connect to: [url]http://HSFOG/fog/service/debug.php[/url]
    9/22/2014 11:54 AM FOG::MODDebug Server responded with: Hello FOG Client
    9/22/2014 11:54 AM FOG::MODDebug Module has finished work and will now exit.


  • Senior Developer

    In addition to what BPSTravis said, please do the following:

    Attached is a custom build of the new service. [B]IT IS NOT FINISHED, IT IS MODIFIED FOR YOUR NEEDS. DO NOT USE IT ANYWHERE ELSE. DOING SO MAY RESULT IN DAMAGE. THERE MAY BE UNFORESEEN SIDE EFFECTS. USE AT YOUR OWN RISK.[/B]

    With that disclaimer said, if you wish to proceed please uninstall the current fog service. Remove fog.log on the C: drive. Install the new service and reboot your computer. Please upload the new fog.log file when you feel that sufficient data has been collected. (Preferable after 10+ minutes). Once completed, [B]remove the pre-build service IMMEDIATELY[/B]. the service will take a few extra steps as it is a pre-build.

    To uninstall open a task manager. Find FOGUserService and FOGTray and kill them. Open a command prompt as administrator and run “net stop fogservice”. Then in your control panel run the default FOGService uninstaller.

    [B]Once again, please note that much of the new installer’s functionality has been disabled and should purely log/do basic tasks for safety reasons. Whatever your do, DO NOT USE THIS SERVICE ANYWHERE ELSE. IT IS A HYBRID OF THE OLD SERVICE AND NEW SERVICE, DESIGNED SPECIFICALLY FOR YOUR ISSUE.[/B]

    The reason I have you run this custom pre-build is that it provides us with much more debugging information.

    I would also like to take a moment to address a something. If there is an issue, such as this you need to understand that almost all of us (the developers) do this in our [B]free time[/B]. With my current schedule my free time is limited to a few hours a week. What little free time that I have is spent on developing the new service. In order take make our jobs of providing support easier (and more enjoyable) please attempt debugging on your own. If you can’t solve the issue post it here with as much information as possible, even if it may not seem immediately relevant.

    [url="/_imported_xf_attachments/1/1426_FOGService.zip?:"]FOGService.zip[/url]


  • Developer

    Is there anything showing in your apache2 error log when this client tries to connect?

    Stop the fog service on the client
    [CODE]net stop “FOG Service”[/CODE]
    Follow the apache2 error log via a terminal to the fog server:
    [CODE]tail -f /var/log/apache2/error.log[/CODE]
    Start the FOG service:
    [CODE]net start “FOG Service”[/CODE]
    Watch the error log, if any entries show up, please post them here.



  • This one i rebooted and left all night and it was checking in all night and stopped when i logged into the device! now it has not checked in for 20 min before that i can see the log updated every 5 min!



  • Im getting really frustrated with this new fog version never had so much issues with .32 anyways now i get it to update the log all the time but it only shows taskreboot updates and nothing else no snapins deploy under the client on fog all snapins are enabled i tryed to global disable task reboot and now the client reports module is globally disabled but only reporting for task reboot!



  • like i said it will run for around 5 min and then nothing gets added to the fog file untill i reboot! I have disabled all snapins and nothing changes!



  • No av at this time


  • Developer

    what antivirus do you have installed?
    i’m not aware of any antivirus that kills the fog client, but i just want to cover our bases here


  • Senior Developer

    Did you try disabling the snapin module?



  • Nothing changes these things i have only snap in enabled and like all other times it reports to the log for up to 10 min and then its dead! Like something is killing fog client or something it states the service is running but untill you reboot it wont do anything! Is this compatible with windows 8.1 i really don’t want to go find a new app deployment solution! fog .32 worked so well with windows 7!


  • Senior Developer

    One by one, go through each module on the web portal and disable it for the host. Once you disable it, restart your device and see if the logging issue is fixed. Repeat for all modules.



  • All snapins are removed from the queue i rebooted device and fog log started adding at 10.08 and stopped at 10:12


  • Senior Developer

    Can you try removing all scheduled snapins for the device, and restarting the device. Does that fix the log issue?



  • here is what i get this station as not updated the fog file since yesterday at 11:16

    [url="/_imported_xf_attachments/1/1379_fog service.JPG?:"]fog service.JPG[/url]


  • Senior Developer

    I need the output of this command;
    [CODE]sc query “fog service”[/CODE]
    Make sure you run it on the toublesome device after FOG stops logging.



  • thats it until i reboot! i have 150 of these windows 8.1 devices and so far i have tryed 4 and they all do the same thing!


  • Senior Developer

    Is that all of the log file; is that the last entry before the service stop? Also, have you tried other devices and do they work?



  • Here is the log

    [url="/_imported_xf_attachments/1/1378_fog.txt?:"]fog.txt[/url]


  • Senior Developer

    You state that the log file is written to when you restart your device. Can you upload that log file here? Without it I have no idea what could be happening.



  • I open and close the fog.log file as like you said notepad wont update as its changes.i just opened the log file on the tablet and the last entry was from yesterday at 11:49 AM usercleanup

    i can open and close the file all i want but nothing is changing in the file unless i reboot the deive


Log in to reply
 

373
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.