Image upload time incorrect



  • I have noticed of late (not sure how long it has been like this) that the image upload time is off several hours, appears to be mostly ahead 4-5 hours. I have check my VM and the FOG server time and all are correct. What else might be causing the time to be off? This isn’t a priority fix, but just an observation I wanted to bring forward.



  • worked for me; here is the line:

    [CODE]date.timezone = America/Los_Angeles[/CODE]



  • Definitely no semicolon at the beginning of the line.


  • Senior Developer

    I know you said you’re sure, but is the date.timezone = Europe/Berlin, or is it ;date.timezone = Europe/Berlin?



  • [quote=“Tom Elliott, post: 36665, member: 7271”]Berlin is +2 hours from GMT?[/quote]

    Yes.


  • Senior Developer

    Berlin is +2 hours from GMT?



  • The time zones in both ini files are set correctly (in my case to Europe/Berlin). The time shown on FOG is still wrong.

    My system time (what I get after typing date) was wrong, although it is also set to Europe/Berlin. After typing “[SIZE=14px][FONT=Ubuntu Mono][COLOR=#222222]sudo ntpdate ntp.ubuntu.com[/COLOR][/FONT][/SIZE]”, system time is correct now. However, “FOG time” is still wrong (2 hours behind).


  • Senior Developer

    When putting in your time zone, make sure it’s not in as:
    [code];date.timezone = America/New_York[/code]

    Notice the prepending semicolon? That tells the apache config files (more specifically the php.ini) that it’s to be ignored and similar to a comment.

    Make sure the line is simply listed as:
    [code]date.timezone = America/New_York[/code]

    You can use quotes around the timezone as well, but I don’t think it matters as much.

    For the web interface on ubuntu it’s /etc/php5/apache2/php.ini

    For the CLI side (FOGMulticastManager, FOGImageReplicator, FOGScheduler) it’s /etc/php5/cli/php.ini

    To my knowledge, there’s only two php.ini files in use for Ubuntu systems so if you place the same timezone information in both of the files, you’ll need to restart the Web server itself: (e.g. sudo service apache2 restart) and the FOG Services (e.g. sudo service FOG{MulticastManager,ImageReplicator,Scheduler} restart) for the time to start being reflected correctly. If this still doesn’t work for you, maybe your system time is not set to the local timezone either?



  • I’m on FOG 0.32 and I have never been able to make the web interface show the correct time (e.g. in the bandwidth/transmit graph on the dashboard), although I put my time zone in every php.ini file I could find including apache restarts. I eventually gave up on that matter.


  • Senior Developer

    Have you restarted the apache service after making the change? Not just refreshing the page but
    [Code]sudo service apache2 restart[/Code]



  • [quote=“Tom Elliott, post: 36573, member: 7271”]Quotes are not needed, nor will they hurt.

    I found out the issue.

    The file you need to add the date.timezone on Ubuntu 14.04 (and possibly others?) Is in:

    (Drumroll please)
    .
    .
    .
    .


    [code]/etc/php5/cli/php.ini[/code][/quote]

    Oh well, I edit the setting on both php.ini’s with and without quotes with no success.



  • [quote=“Tom Elliott, post: 36573, member: 7271”]Quotes are not needed, nor will they hurt.

    I found out the issue.

    The file you need to add the date.timezone on Ubuntu 14.04 (and possibly others?) Is in:

    (Drumroll please)
    .
    .
    .
    .


    [code]/etc/php5/cli/php.ini[/code][/quote]

    Great. I guess we have something like a 1 in 3 chance to have got it right…haha. I will give that a try.


  • Senior Developer

    Quotes are not needed, nor will they hurt.

    I found out the issue.

    The file you need to add the date.timezone on Ubuntu 14.04 (and possibly others?) Is in:

    (Drumroll please)
    .
    .
    .
    .


    [code]/etc/php5/cli/php.ini[/code]


  • Developer

    i believe you need quotes around the America/Los_Angeles part



  • [quote=“PomonaIT, post: 36554, member: 24658”]Let me check that out and see what is set. Thanks.[/quote]

    I am using Ubuntu, so I found the php.ini at /etc/php5/apache2/. The date.timezone setting was blank, so I added “date.timezone = America/Los_Angeles”. I restarted server for good measure, uploaded image and time is off by 7 hours. Any other ideas?



  • [quote=“Tom Elliott, post: 36547, member: 7271”]“If it isn’t broken, don’t fix it.”

    It isn’t “broken” persay. It’s not even a “problem” persay.

    Your /etc/apache2/php/php.ini? Maybe needs the date.timezone?[/quote]

    Let me check that out and see what is set. Thanks.


  • Senior Developer

    “If it isn’t broken, don’t fix it.”

    It isn’t “broken” persay. It’s not even a “problem” persay.

    Your /etc/apache2/php/php.ini? Maybe needs the date.timezone?


Log in to reply
 

341
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.