Creating images



  • When imaging a computer, the images stay in the /images/dev/180373c462fb directory and dont get copied to the /images/faymastr directory. The files are being created with the owner of root and not fog. The image files are being created with permissions owner rw group r and others r. The images directory has rwx permissions set as 777. Why are the images not being copied to the correct image directorie?

    We have just upgraded to version 1.2.0 of fog and we havent been able to get this working since upgrading from 0.32.



  • hmmm. seemed to have worked. I moved the files over manually to /images but didnt like the image. I went and uploaded a new image. Worked then. But I had already made the dir in /images.



  • I am having the same issue. I already checked and my passwords are the same in both those places. We did change our DHCP server, but images come down fine so i think tftp 66 and 67 are set ok in it. Also I can ftp into the box using the credentials.



  • [quote=“SupEric, post: 36406, member: 25086”]OK, I have set the password in TFTP, Storage management and the fog linux password to be identical. Starting an upload to see if it works. Takes about 4 hours until it fails. Seems like it gets the image all uploaded and then crashes.

    Thanks!![/quote]

    That worked!!! It now creates and restores an image.

    Thanks!!!



  • [quote=“Junkhacker, post: 36402, member: 21583”]on the storage management page
    Storage Management > <storage node, usually default> > Management Password[/quote]

    OK, I have set the password in TFTP, Storage management and the fog linux password to be identical. Starting an upload to see if it works. Takes about 4 hours until it fails. Seems like it gets the image all uploaded and then crashes.

    Thanks!!


  • Developer

    on the storage management page
    Storage Management > <storage node, usually default> > Management Password



  • [quote=“Junkhacker, post: 36396, member: 21583”]did you update the password in storage management?[/quote]

    I am not sure how to update the password in storage management?


  • Developer

    did you update the password in storage management?



  • [quote=“Junkhacker, post: 36392, member: 21583”]well, is it a valid password? this is the password for the user “fog” on your linux server[/quote]

    I had changed the Linux password for the user fog to password and the password for the TFTP server to password and I got the same error with the same password of 21c… Can you think of a reason it was still trying to use the old password?


  • Developer

    well, is it a valid password? this is the password for the user “fog” on your linux server



  • [quote=“Junkhacker, post: 36336, member: 21583”]the client isn’t told this password, it is used by the fog server to complete the move by ftp when the client tells it that it is finished uploading[/quote]
    I changed the TFTP password and I got the below error.

    Now afte the upload task finishes the image I get an Error FOGFTP login failed. Host 192.168.131.50, UIsername: fog password 21c565abee44cbdb83f51a1814b8cf92, Error: ftp_login() [a href=‘function.ftp-login’>function.ftp-login(/a)]: Login incorrect.

    Then I changed the password back to 21c565abee44cbdb83f51a1814b8cf92 and I still get the error after an upload.

    How do I convince this thing what the password is?


  • Developer

    the client isn’t told this password, it is used by the fog server to complete the move by ftp when the client tells it that it is finished uploading



  • [quote=“Junkhacker, post: 36326, member: 21583”]no, this is unencrypted[/quote]

    What tells the client what the password is and when does it tell it? The client it saying invalid FTP password and prints out the old password. I did change the password at the same time it was creatinbg an image.


  • Developer

    no, this is unencrypted



  • [quote=“Junkhacker, post: 36318, member: 21583”]Fog configuration > Fog settings > TFTP Server > FOG_TFTP_FTP_PASSWORD and
    Storage Management > <storage node, usually default> > Management Password
    should usually match and be a valid for FTP login[/quote]

    Do you need to use fogcrypt for this password?


  • Developer

    Fog configuration > Fog settings > TFTP Server > FOG_TFTP_FTP_PASSWORD and
    Storage Management > <storage node, usually default> > Management Password
    should usually match and be a valid for FTP login



  • [quote=“Junkhacker, post: 36314, member: 21583”]this is usually a sign of a FTP issue, most likely an incorrect password[/quote]

    Where do I set this password?


  • Developer

    this is usually a sign of a FTP issue, most likely an incorrect password


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.