Chromium OS



  • [U][B]Install:[/B][/U]
    ubuntu-14.04.1-server-amd64
    FOG Project 1.2.0 (svn2250)

    [U][B]FOG Configuration:[/B][/U]
    PXE Boot Menu = Menu Timeout = 30 (default=3)
    FOG Settings
    FOG Boot Settings
    = FOG_PXE_MENU_TIMEOUT = 30
    = FOG_PIGZ_COMP = 3 (default=9)
    FOG View Settings
    = FOG_VIEW_DEFAULT_SCREEN = LIST (default=search)
    General Settings
    = FOG_FORMAT_FLAG_IN_GUI = selected (default=not)
    Login Settings
    = FOG_INACTIVITY_TIMEOUT = 4 (default=1)
    SAVE

    [U][B]Fixes:[/B][/U]
    Repair MySQL crashing out one minute after restart
    vim /etc/rc.local
    "i"
    insert new line at line 14 : service mysql restart

    =-=-=-=-=-

    [U][B]Symptom:[/B][/U]

    Like any other operating system I want to upload an image of a drive containing my custom Chromium OS installation for duplication with FOG.

    So far, any image I’ve created then deployed does not boot. No errors, no text, nada.

    I’m on my last two options for uploading Linux/Raw/Everything, and Other/Raw/Everything … which is going to take a long, long time before I can test the results.



  • Using the CloudOS from Neverware. I successfully installed it on a computer and imaged it successfully. I think you would classify it as Chromium OS but it has been modified with more driver support and other things. I am using the free version not the paid for one with Google Apps support.

    I used the Linux with multiple partitions single disk.

    I was actually able to install this on several different hardware models with no issues as long as the hard drive was the same size or larger than my original test machine.

    Optiplex 360.380, and 390
    Lenovo X130
    Inspiron Duo

    Might be able to extend some of the old hardware this way.



  • Be sure to indicate whether you are using Chromium OS vs Chromium on Linux.

    I expect I’ll be retouching my Chromium OS solution in the not terribly distant future and will update things here too.


  • Moderator

    I’ll be attempting to install ChromeOS onto an HP Elitebook 8730w here in the future, in order to get a little more life out of these old devices instead of just surplusing them. I expected to use the Linux image type. I’ll try to find this thread in the future and update it with my findings.

    #Chrome


  • Senior Developer

    I’ve been working pretty hard to see about getting this included, though it may need to be it’s own OS, I’d imagine for right now Linux would be the proper selection.



  • Hi, I’m attempting the same cloning for our school to give life back to some old laptops. I too haven’t had any luck with the non-raw settings - I’m trying the Linux/Raw/Everything method the captured imaged is about 40gb (muddy I guess :) ) about 1hr 20min to deploy… Haven’t tried zeroing the HDD first. My Chromium OS is only different in I’ve installed the pdf & flash missing plugins, havn’t got the mp4 working.



  • IMGtoISO 1.0 errors out in Win7 and Win8 with “Error, cannot create vdisk”.
    MagicISO expects the .ISO compatible .IMG.

    The Chromium .IMG is a RAW or proprietary file system.



  • Zeroing the HDD before installing Chromium made for a 2.35 GiB image . Very much an improvement over the original dirty HDD 24 GiB image.

    However it still effectively takes just as long to capture and deploy.


  • Moderator



  • Well, installing Chromium OS to a Virtual Machine appears easier said than done, at least when it comes to Hyper-V. Hyper-V 2012 will only allow me to connect an ISO to the ODD.

    Can I convert the non-standard RAW .IMG of the Chromium OS installer to an ISO? … not as far as I can tell. Hopefully someone can prove me wrong.

    Now zeroing the drive …



  • It’s not so easy finding a .img of Chromium, unless you compile your own from the sources provided by Chromium.org.

    Most every page that points to someone else’s published .img that I found points to Hexxeh.net, which hasn’t been updated in nearly 1.5 years.

    ArnoldTheBats World of Whimsy at [URL=‘http://arnoldthebat.co.uk/wordpress/chromium-os/’][U][COLOR=#0066cc]http://arnoldthebat.co.uk/wordpress/chromium-os/[/COLOR][/U][/URL] is fantastic and updated daily with automated compiles.

    From [url]http://chromium.arnoldthebat.co.uk/[/url] I used:

    [url]http://chromium.arnoldthebat.co.uk/special/Cx86OS_R33-5111_broadcom.7z[/url]

    … and

    [url]http://chromium.arnoldthebat.co.uk/daily/Cx86OS-20140904010101.img.7z[/url]

    I installed to a dirty HDD on a Netbook for my initial tests. We’re a Windows house but how the bootable installer disk is created shouldn’t make a difference

    1. burn .img to USB ( 4GB )

    2. boot from USB

    3. @ Sign in/Welcome: CTRL+ALT+F2

    4. @ login, username: chronos

    5. password: password

    6. Enter the following commands:

    sudo su
    /usr/sbin/chromeos-install --dst /dev/sda

    1. When complete, remove the boot device and power down.

    That’s it.

    I also did power up, then logged on, changed the passwords for root and chronos, then built in Broadcom wireless drivers per the instructions at ArnoldTheBats. But otherwise it’s vanilla.

    Come Monday I will attempt a build a Virtual Machine or on a zeroed HDD which should make for a much smaller image capture.


  • Senior Developer

    I’m intrigued by the prospects of this.

    I don’t know what’s causing the problem.

    Is there a possibility of getting your installer so I can try to install on a vm and test it out?



  • Linux/Raw/Everything worked.

    But what a trade-off.

    Do it manually in 10-15 minutes, or push out an image in 45-50 minutes?



  • Linux/Raw/Everything has finished uploading. Non-Raw images are less than 1GB. This puppy is 24.

    I’m pushing it out now to two systems (Dell Latitude netbooks btw). PartClone claims it will take 45+ minutes. I could install from scratch in 1/4 that time. hmmm

    Other/Raw/Everything is uploading now.

    If you don’t hear from me again today, I will report my results on Monday.

    Thanks for your help.



  • All partitions are copied.

    When Ethernet is disconnected I receive a typical BIOS error: No bootable devices


  • Senior Developer

    Also, when booting to OS after deploy, are you still allowing the system to pxe boot first?


  • Senior Developer

    So is it copying all the partitions properly and you’re just having issues with booting the system? Or does it not make it that far?



  • According to Gnome Partition Editor 0.19.1-4:

    /dev/sda11 = unknown
    /dev/sda6 = unknown
    /dev/sda7 = unknown
    /dev/sda9 = unknown
    /dev/sda10 = unknown
    unallocated space
    /dev/sda2 = unknown
    /dev/sda4 = unknown
    /dev/sda8 = ext4, label=OEM, flags=msftdata
    unallocated space
    /dev/sda12 = fat16, label=EFI-SYSTEM, flags=boot, esp
    /dev/sda5 = ext4, label=ROOT-A
    /dev/sda3 = ext4, label=ROOT-A
    /dev/sda1 = ext4, label=H-STATE, flags=msftdata


  • Senior Developer

    My first question on this then is what format is the filesystem in


Log in to reply
 

386
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.