Upgrade from .32 to 1.2.0 Problems



  • Hello Everyone,

    I am running into interesting issues that everyone here seems to be running into and have found a few things.
    I have created a FOG server on my VMWare 5.5 server with the new FOG server 1.2.0 and Ubuntu 12.04 and the old setup was coming from a Ubuntu 10.04 server with FOG .32 on a hardware system.

    After creating the new server on the VMWare server, I then followed the instructions here to move the server information:

    http://community.spiceworks.com/how_to/show/2631-moving-a-fog-server-to-new-hardware

    I did change the new server’s IP address one Number up from what it was and made sure all my IP’s for all my information was changed as well.

    Here is the interesting things I am seeing as some of the others in forum are seeing:

    • Some of my images are not showing up with image size information. Even after I image a machine (yes, but with Win7 only not XP)
    • I cannot image a XP machine with any of my WinXP images. After looking through the logs and booting the system with new fog it tells me something about a partition outside of disk as panthersfan25 has stated??
    • I CAN, however, image a machine using my W7 image on the same machine I tried to push the WinXP image to…
    • The windows XP disk reads "Single Disk -Resizeable’ and the Win7 image reads the same, but only the Win7 image works.
    • I have tried messing with the Hard Drive settings in the BIOS and not luck there for the XP Image.
    • The Win7 img that works shows no Size on the FOG server for the Client or the Server
    • The WinXP img looks like this, (and most of them do look like this)
    • Some actually have sizes in the columns, but they do not represent the correct size. The HSLIBWIN7 img above has been used a few times to image since the new server is up and notice it did not populate the information for the client or the image size on server.

    I have made sure that ALL IP’s were changed in the software and I ran through the setup listed above.

    Again kind of weird that the Win7 image worked and the WinXP image didn’t? All of them say that they were created with PartImage, and if one works they should all work yes? It sounds like it has something to do with that error ‘partition ouside of disk’.

    If it was something in the way I brought the images over any way to fix that? Or is it something in the program that is causing these strange issues?

    I have had to restart my old FOG server to image machines since I cannot be without it for long.
    Any ideas so far on what could be the issue?

    Thanks for any help or thoughts on this matter.

    IdahoTech…


  • Moderator



  • So where is the option to enable the selection between partimage and part clone? is it under fog settings?



  • I hear ya…gotta cut mine…soon I can make grass skirts if I don’t get out there soon…


  • Developer

    Always willing to help! As long as it’s not after 3:30pm on a Thursday… I have to mow the grass on Thursday <.<



  • OK I will do. Thanks for the quick reply and the down and dirty on how to… Being 1 of 2 techs in a district and the other tech is on vacation for 3 weeks :eek: helps me out greatly with the quick run down. I will try it later on Today and let you know what comes about. :)


  • Developer

    You can export a list of your current hosts and then import them again after installation, (would be fastest and safest).

    I would install 0.32 and then put back my current images from 0.32: name the image store the EXACT same as your previous image name (it will be the folder that houses your partition files)

    After adding the image stores in, I would chmod everything to make sure that fog is happy and can see the images.```
    chmod -R 777 /images

     
    Then I would immediately update to 1.2.0, I would not worry about 1.1.0 or anything between.
     
    Afterwards I would restore my final images (if desired) and then import my host list.
     
    This would be the most painless process I can think of (while saving your images and hosts).


  • I appreciate the information and yes I will have to bite the bullet and install .32 and then upgrade. Do I just go from .23 to 1.2.0? Or go through the steps of certain versions like from .32 to 1.X then from there to 1.2.0?

    Can I uninstall the FOG 1.2.0 from my VM and install the .32 to it without loosing my clients I have already registered to it?

    I know I am being kind of a wanny, but just want to do this as painless as possible, if it is at all possible. And yes I did have that same setup where I created the images in Virtual Box and then did a snap shot before I syspreped the machine just in case something happened, then did another snapshot after the sys-prep when I imaged it down to a machine and all went well.

    However the machine I had that on the HD drive crashed and I lost all my images for it. I mean dead as a door-nail. AH well so goes the life of a techie…always telling people to backup, backup, backup and the one thing I forget to backup…well lesson learned. Yeah I was a idiot on that one. Let the insults commence :o)

    If you can give me any kind of quick step by step to either reinstall on my VM with the old then upgrade or what i would appreciate it. If not I understand and can muddle through it, just got a lot going on here and the less I have to muddle the better it would help…;)


  • Developer

    What I do, and this is my personal preference and I will explain why, Is I build my images in a virtual format, and I ALWAYS keep this virtual Format.

    I use Virtual Box, I have had the best speeds when compared to other virtual machines, but we have a pseudo work around for VMWare speed issues. I also chose Virtualbox because it is easy to port out your appliance and import else where. You can also take snapshots (and if you sysprep this is VERY important).

    I always keep my virtual machine alive in some aspect, sometimes I even upload the image before completing the sysprep so I have a fall back in case my snapshot gets corrupted or deleted. Then I just start a new appliance and use FOG to image the machine and pick up where I left off.

    This leaves me the opportunity (should it arise) for me to upgrade my fog server and re-upload my images if the format was not correct from a previous version (and that is just because I still use the 0.32 as a production server and I use my 1.2.0 for testing and breaking).

    This would alleviate the issue of needing to change the type or to enable the legacy flag.

    I realize that it’s probably too late for that, so my next suggestion is similar to the one Thiago gave. Back up your images, install FOG 0.32 fresh, and then perform the upgrade to 1.2.0. This will allow the legacy flag to be enabled so that when you restore your images they will be in the correct “format” if you will. This should solve your ‘partition out side of disk’ issue. I realize this is not the ideal solution, but it is A solution.

    Sorry the upgrades have caused you trouble, I promise that all the changes are well worth it though, the system is much faster, and supports a wider range of partition types and OS types than we could previously cater to, plus now we have a really good means of compression that is easily changed :)



  • This depend of your hardware, how you work and what you want to do.
    My image were not working and i had to deploy some before this was fix by Tom so i had no choice than build a second server and keep the old one ready to deploy.



  • i guess that upgrade process from 0.32 to 1.2 is more effective than fresh install and move images folder.
    My IT friend at work, have this same issue. He did a reinstall of .032 and then updated to newer version and simply worked again.



  • OK so where would i find this setting. In the Fog Configuration under Fog General Settings? The main problem I am having is imaging with the Windows XP images…For some reason the WIndows 7 images work and deploy. The Windows XP images come up to the screen where it starts to image then reboot. It happens so fast I cannot see what it states on the screen, but in the logs it states that error I quoted before about cannot have partition outside…

    These images were made on the .32 version of fog and I did do a clean install, because instead of going through the upgrades I thought a fresh install would be less troublesome.

    Is it because I made such a huge jump in versions that I am having these issues? Is there a way to get it to see the image sizes properly as well as use my XP images?

    Thanks for all you do…


  • Senior Developer

    The GUI option isn’t enabled, but on upgrade from 0.32 (or earlier) to 1.x.x, the flag that tells if it is partclone or partimage is set to tell the system it’s partimage.



  • I was thinking that the gui option wasn’t enable during update between theses versions.
    Thank you for this information Tom.


  • Senior Developer

    @jmeyer, post: 35897, member: 6537 said:

    Image from 0.32 are not supported on 1.x unless you activate support in the FOG option and then set image type as partimage.
    So it depends with what version of FOG you made them.
    Images made with 0.32 must be set to partimage and 1.x images set to partclone

    Sort of.

    They are supported. If you upgrade from 0.32 to 1.2.0, not a fresh install and move over the images, the images are marked as partimage and imaging can begin. However, as a lot of people go the route of installing fresh, then migrating the images and hosts over, the images would not be known as partimage and you need to enable the gui option to make the necessary changes.



  • Image from 0.32 are not supported on 1.x unless you activate support in the FOG option and then set image type as partimage.
    So it depends with what version of FOG you made them.
    Images made with 0.32 must be set to partimage and 1.x images set to partclone



  • Sorry there should be some images there where it states ‘The WINXP img looks like this’. Don’t know why they didn’s upload.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.