Computer can't be removed from group



  • For some reason, I cannot delete a computer from a group.

    I’ve tried from group view, and also from the host view.

    There is the “updated” message but nothing happens.

    The host in mention is the first member of the group


  • Senior Developer

    In svn I’ve changed how this field is viewed. While still not resizable it’s done more like how search/list hosts can be added to groups.



  • After the problematic host was removed directly from the database, there has been no re-occurences of the problem.

    As per suggestion, the initial group has been deleted, and all hosts could be added and deleted in the group using the GUI.

    Something went wrong with the first hosts being added, but there is no indication what it was, and now it’s not reproducable.

    as a side note. would it be possible to make the list of hosts window in Group management -> group -> membership
    dynamic so one can resize the window. giving a better overview, and easier access to marking hosts for adding.


  • Senior Developer

    What happens if you delete the group entirely and recreate it using the GUI? Can you still join hosts to the same group from registration?



  • bump



  • Sorry for triple posting in a row here… I can’t say if this is a bug so it’s up for a discussion here, posting here as it might have some relevance to the prior.

    looking in the database table groupMembers I can see there is a row gmHostID, I can imagine that this row should refer to the ID in hosts (if it isn’t please disregard this post) the groupMembers.gmHostID doesn’t seem to match hosts.ID.

    Strangly enough, the host that had problems in the group (mentioned above), did have the same number in both groupMembers.gmHostID and hosts.ID.

    what it seems to be wrong is that there are fx hosts.ID 4,5,6 but there are no groupMembers.gmHostID 4,5,6, though there are some higher numbes in gmHostID which doesn’t exist in hosts.ID

    except for the few first clients (3), which was added manually. The rest of the clients were added using the netboot to Full host registration



  • After deleting the host from FOG
    and try to multicast to the rest of the group, I get an error message that the hosts doesn’t have unified image assignments,
    which they do, and there were no problems scheduling a multicast prior to the host deletion.

    Running FOG 1.2.0

    EDIT:
    In the regular groupview there are 21 hosts
    but looking in groupview in tasks, there are 22 hosts


Log in to reply
 

445
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.