FOG Is Inoperable After Server Reboot



  • Hello. I am new to Ubuntu and FOG, however I have learned a great deal about both in the past week. Does anyone know why I get asked to Update the Database Schema for a second time, after I reboot the server? I have installed clean versions of Ubuntu 13 and 14.04 (Latest Version), as well as clean installs of FOG (1.2.0 and 1.1.0) multiple times. I install FOG, install the schema, and everything works fine, untill I reboot the server. Once I do this, the FOG webpage tells me to update my schema again. If I click ‘Download and Install Schema’ it then gives me a very long page of what appears to be mysql errors. I have beat my head against the wall with this issue. By default, I have NOT been using a mysql password, but I have tried it both ways. Also, I am logged in as ‘Root’ when installing FOG.

    Thank you for your help in advance.


  • Moderator

    @cadyfish Thank you for your answer greatly. This post has been added to the WiKi here: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_MySQL



  • I just wanted to say that the reconfiguring of the MySQL database did it for me after I had this error following a kernel update. The kernel update fixed an issue I was having with [FONT=Calibri][COLOR=#000000]kswapd0 running my CPU to 100%. Now my server’s cpu is running at expected norms and my server is functioning normal. Thanks![/COLOR][/FONT]



  • Banjo,

    That error occurs when the SQL database information doesn’t match what is in fog. This is what I would suggest doing.
    [LIST]
    []Open up [CODE]sudo nano /var/www/fog/lib/fog/Config.class.php[/CODE]
    [LIST]
    [
    ]Notate both the host, username & password
    [/LIST]
    []Open up [CODE]sudo nano /opt/fog/.fogsettings[/CODE]
    [LIST]
    [
    ]Fill in the following portions
    [/LIST]
    [/LIST]
    snmysqluser="{root}“
    snmysqlpass=”{password if you have one}“
    snmysqlhost=”{localhost}"
    [LIST]
    []Reset the mySQL database password to be what is in the config files
    [LIST]
    [
    ]run [CODE]sudo dpkg-reconfigure mysql-server-5.5[/CODE] replace the last two numbers if using a different version of mySQL
    [*]enter in the new password
    [/LIST]
    [/LIST]
    If you still have issues re-run the installer. I tested with a VM using 14.04 and it resolved the same issue



  • Ok, it did it again. Here is a screenshot after the server reboot. It wants me to update the schema again. When I try, this is what it gives me. And it’s pages long…

    [url="/_imported_xf_attachments/1/1298_Screenshot from 2014-08-18 16:43:16.png?:"]Screenshot from 2014-08-18 16:43:16.png[/url]



  • [CODE]chkconfig --levels 235 mysqld on [/CODE]

    That will do it assuming mysql is installed correctly. If not manually install mysql then run that command.



  • That’s kinda weird. Is there anything I can do so I don’t have to do this every time? Perhaps an older version? I guess it could be a problem with the MySQL that Ubuntu downloads during install.


  • Developer

    If that works, chances are you’ll have to run “service FOGMulticastManager restart && service FOGImageReplicator restart && service FOGScheduler restart” to get everything running properly.



  • I’ll try that. Thank you.

    But if im not mistaken, I think I have tried that, and I get a message saying something regarding mysql not being installed.


  • Developer

    run “service mysql restart” after the reboot and see if you can get in


Log in to reply
 

468
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.