WOL Not working FOG .32



  • So I’ve moved my fog server 3 times. The reason for this is that I deployed FOG on a couple VMs for testing purposes. Also, it’s good practice. Migration is fairly straight-forward.

    I am running fog .32

    For moving servers, I followed the instructions in the wiki:
    [url]http://fogproject.org/wiki/index.php?title=Moving_Between_Servers[/url]

    On this 4th server, which is a physical machine (specs to follow), WOL simply does not work.
    WOL worked perfectly on the VMs.

    I have enabled WOL on all clients tested.

    All FOG servers were based on ubuntu 10.04.3LTS x86_64

    Current physical machine:
    [CODE]Linux Fog4 2.6.32-33-server #72-Ubuntu SMP Fri Jul 29 21:21:55 UTC 2011 x86_64 GNU/Linux
    [/CODE]

    I’ve checked permissions in /var/www/fog (I don’t think x should be set…)
    [CODE]drwxr-xr-x 2 www-data www-data 4096 2011-12-18 16:23 wol

    -rw-r–r-- 1 www-data www-data 54 2011-12-18 16:23 index.php
    -rw-r–r-- 1 www-data www-data 1043 2011-12-18 16:23 wol.php[/CODE]

    I’ve made sure that the WOL server is set correctly in /var/www/fog/commons/config.php

    [CODE]define( “WOL_HOST”, “172.17.14.206” );
    define( “WOL_PATH”, “/fog/wol/wol.php” );
    define( “WOL_INTERFACE”, “eth0” );
    [/CODE]

    I even re-installed the server by moving /var/www/fog and /opt/fog and renaming .fogsettings

    Still no joy…

    Is there anything else I can try to diagnose this issue? I haven’t messed with ubuntu firewall and/or iptables yet, come to think of it…

    This is because I didn’t touch firewall before and things ran fine…
    I’ll give that a shot after I hit “post”.

    CPU specs below:
    [CODE]root@Fog4:~# cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 15
    model : 5
    model name : AMD Opteron™ Processor 246
    stepping : 10
    cpu MHz : 2008.884
    cache size : 1024 KB
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm 3dnowext 3dnow rep_good extd_apicid
    bogomips : 4017.76
    TLB size : 1024 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 40 bits physical, 48 bits virtual
    power management: ts fid vid ttp

    processor : 1
    vendor_id : AuthenticAMD
    cpu family : 15
    model : 37
    model name : AMD Opteron™ Processor 246
    stepping : 1
    cpu MHz : 2008.884
    cache size : 1024 KB
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm 3dnowext 3dnow rep_good extd_apicid
    bogomips : 4018.65
    TLB size : 1024 4K pages
    clflush size : 64
    cache_alignment : 64
    address sizes : 40 bits physical, 48 bits virtual
    power management: ts fid vid ttp
    [/CODE]

    Thanks, FOG forums!



  • I am having the same problem, I am running the FOG server under Hyper-V on Windows 2008R2 datacenter. Could the virtualized network adapter (legacy network) on Hyper-V cause this?

    It does not work either manually or thru the menu. I have used a WOL utility from the same subnet and it works. FOG does not seem to be sending any WOL packet.



  • I have the Same issue manualy wol is working ok
    I use the menu option in FOG (.32) nothing is happening!

    192.168.48.150 - - [15/Jun/2012:14:51:17 +0200] “GET /fog/management/index.php?node=tasks&confirm=406&type=host&direction=wol&singlescheddate=&cronMin=min&cronHour=hour&cronDOM=dom&cronMonth=month&cronDOW=dow HTTP/1.1” 200 1606 “[url]http://fog/fog/management/index.php?node=tasks&type=host&direction=wol&noconfirm=406[/url]” "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5"
    192.168.48.150 - - [15/Jun/2012:14:51:17 +0200] “GET /favicon.ico HTTP/1.1” 404 496 “-” “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5”



  • I have too, if I test whit the command [I]wakeonlan [mac][/I] it works fine.
    But if i test it whit [url]http://10.0.0.1/fog/wol/wol.php?wakeonlan=40:61:86:01:72:43[/url] it[COLOR=#000000] send [/COLOR][COLOR=navy][COLOR=#000000] nothing.[/COLOR][/COLOR]


  • Developer

    Here is the wireshark wiki page on WOL.

    [url]http://wiki.wireshark.org/WakeOnLAN[/url]

    That is what you are looking for. You want to verify the WOL packet is getting to your client.


  • Developer

    The log reports HTTP 200, so the page GET was successful and the PHP page was processed. Did the WOL event work?

    If not, what happens if you manually go to below, does it work?
    [url]f1:9e:d9:10%5B/url%5D" target="_blank" rel="noopener noreferrer nofollow">http://172.17.14.206/fog/wol/wol.php?wakeonlan=f0:de:f1:9e:d9:10[/url]

    It looks like its working as intended. There should be zero difference between you manually requesting that page and FOG requesting (its basically the same thing)

    This sounds like some sort of configuration issue.

    The next step would to tcpdump and see what the traffic is doing.
    You will need to dump from your server and from your client to get a full picture of what is going on.
    You want to check if the client is receiving the WOL Magic packet or not.
    It should be a broadcast UDP packet to port 7 or 9 with a total of 102 bytes. 6 bytes of nulls, followed by the clients MAC address 16 times.



  • [quote=“Blackout, post: 120, member: 1”]‘server_ip’ was 172.17.14.206, right?[/quote]
    That is correct.



  • I see this when executing a WOL from advanced task menu
    [CODE]::1 - - [18/Dec/2011:20:23:37 -0500] “GET /fog/wol/wol.php?wakeonlan=f0:de:f1:9e:d9:10 HTTP/1.1” 200 192 “-” “-”
    [/CODE]


  • Developer

    Next i would test that the WOL script is being called correctly.

    On the FOG server 172.17.14.206, run:
    [code]tail -f /var/log/apache2/access.log[/code]
    Now execute a WOL, you should see the WOL call in this access log. If you dont, then the call is never getting to Apache.

    [I]NOTE: You will see other URL calls here from FOG / FOG Clients… make sure you are looking at the right IP[/I]



  • Ha!
    I changed FOG_WOL_HOST server_ip
    To FOG_WOL_HOST localhost
    and now it works!


  • Developer

    ‘server_ip’ was 172.17.14.206, right?



  • Yes, sorry I forgot to mention that.

    I went to the UI, other information > fog settings:
    FOG_WOL_HOST server_ip
    FOG_WOL_PATH /fog/wol/wol.php
    FOG_WOL_INTERFACE eth0


  • Developer

    Did you look in ‘FOG Settings’ like i asked?



  • [url]f1:61:xx:xx%5B/url%5D" target="_blank" rel="noopener noreferrer nofollow">http://172.17.14.206/fog/wol/wol.php?wakeonlan=f0:de:f1:61:xx:xx[/url]
    This worked!
    What next?
    This is very strange.
    It works directly… I wonder where things are breaking down.
    Wracking my brain to see what is different between the two installs…


  • Developer

    Those WOL variables are not in use anymore.

    The settings are in: Web UI > Other Information > FOG Settings
    Scroll down and look for the WOL settings.

    If they are correct, then manually test WOL works.

    http://[COLOR=#3366ff]FOG_WOL_HOST[/COLOR]/[COLOR=#3366ff]FOG_WOL_PATH[/COLOR]?wakeonlan=[COLOR=#3366ff]MAC[/COLOR]

    Let me know if that works, ive got more things to try.


Log in to reply
 

374
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.