Error fog booting from san device 0x80 after deploy



  • I have a couple of Thinkpad R60e which upload/download OK, but after a deploy they cannot boot from iPXE. I get an error telling “fog booting from san device 0x80”. Then the machine hangs. If I unplug the LAN cable it works and boot as expected.

    Running Windows 7 (one disk, resizeable). Server is running FOG 1.2 on CentOS.


  • Developer

    Same thing happens on Lenovo R500’s and Lenovo R61’s. Changed AHCI to compatibility. Its a known issue and its related directly with the hardware and BIOS. This will affect any install of Windows, ghosting, Acronis True Image and FOG. Sorry but not a FOG issue.



  • I know that i am jumping in a bit late…

    I also had this problem on a hp dc7900 i found that the sata emulation in the bios was set to ahci when i put it back to ide it would boot properly.



  • If I recall correctly, there were some machines that failed with GRUB, and there were others that failed with EXIT, and I definitely cannot risk that right now. I guess that’s is more of a feature request, but I agree with Gordon that per-workstation or maybe per-group adjustment of this setting would be great!

    Thank you for all of your work,
    D.L.



  • I’ve swapped to grub and so far I’ve not seen anything fail :-) but it would be good if it could be per workstation configurable at some point :)


  • Senior Developer

    You could try grub style exiting?



  • I would also like to know about this on a per-workstation basis. I have a few HP dc7900’s that show this behavior, stuck on SANBOOT 0x80 after imaging. I’ve tried updating the BIOS to the latest, etc, and cannot get past this…

    The strange part is how most dc7900’s are fine, but I have at least 4 where this happens - perhaps it has to do with the make/model/firmware of the HDD or NIC?

    If my memory serves me correctly, in our environment EXIT boot type caused problems on a greater number of systems, and that is a risk that I’d rather not take right now, as it would affect all machines PXE booting to FOG.

    Thanks for any advice or help,
    D.L.



  • is this possible to do on a per workstation basis? I only have a handful of workstations that don’t work with sanboot?


  • Developer

    previous version of fog used the pxelinux.0 network boot file, we now use a ipxe network boot file
    these two systems use entirely different methods for their boot exit methods



  • Was Grub the default setting in previous releases? Just wonder as I had no problems in older versions of FOG.



  • [quote=“cadyfish, post: 35303, member: 24458”]With the current version of fog by default it uses SANboot as an exit type to get out of the fog menu. To change it do the following:
    [LIST=1]
    []Navigate to the FOG configuration page (gear symbol)
    [
    ]Click on PXE Menu settings
    []Change the exit type to “grub”
    [
    ]Save settings
    [/LIST]
    [/quote]

    Thanks a lot for this info!


  • Developer

    the problem is in the way the bios of the computer handles the boot process. due to the number of inconsistent and buggy systems, we have included 3 different methods to tell the system to boot to the next boot device. you may also find that updating the bios on a system may fix the issue.



  • [quote=“pmonstad, post: 35300, member: 17422”]Hm, I need some more info here as I really dont know what you suggest ;-) I have never chosen SANboot, and where do I turn it off? I have never run into this problem on hundreds of computers. Only these two R60e from Lenovo.[/quote]
    With the current version of fog by default it uses SANboot as an exit type to get out of the fog menu. To change it do the following:
    [LIST=1]
    []Navigate to the FOG configuration page (gear symbol)
    [
    ]Click on PXE Menu settings
    []Change the exit type to “grub”
    [
    ]Save settings
    [/LIST]



  • [quote=“Junkhacker, post: 35269, member: 21583”]boot menu exit type
    try something other then sanboot[/quote]

    Hm, I need some more info here as I really dont know what you suggest ;-) I have never chosen SANboot, and where do I turn it off? I have never run into this problem on hundreds of computers. Only these two R60e from Lenovo.


  • Developer

    boot menu exit type
    try something other then sanboot


Log in to reply
 

529
Online

39008
Users

10721
Topics

101838
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.