Can Upload but Can't Download Images - FOG 1.2.0



  • Good afternoon! I just completed a new install of FOG 1.2.0 on Ubuntu 14. Have run other FOG versions without this problem I’m having. After completing the install, I uploaded an image to the default fog storage. Tried to download and got this message… “Download task failed to create for [U]HP-042[/U] with image [U]HP450[/U]
    To setup download task, you must first upload an image”.
    Tried to look at MYSQL config using terminal, hoping it’s a password issue, but that file is not there. (During FOG setup, the MYSQL password was left blank.) Any ideas would be much appreciated!



  • Hi,

    Do you know how I would fix this for and additional storage device on the same server, I have it listed as a seperate storage group and it uploads properly but doesn’t move out of my area called Storage1/dev… it just has the MAC address of the machine I uploaded it from rather than the image name… Its probably a simple thing but im banging my head against a wall now.

    Sorry its running Ubuntu 12.04 and fog 1.2

    Thanks


  • Senior Developer

    Glad to see you got this working for your environment. I’m sorry about the installer issues, but ultimately the changes I’ve made should help future installs actually run more smoothly.



  • Yep!! Saw that fix in another forum. Sorry to not search before posting the issue. We are UP and RUNNING!!!


  • Developer

    fog settings > general settings > FOG_FORMAT_FLAG_IN_GUI to enable changing image format on images



  • [quote=“pmonstad, post: 34933, member: 17422”]same problem here. It has worked for months now but suddenly it fails (I have done a lot of svn upgrades and run 2145 now). Cannot imagine this has to do with ftp on my server as I have never changed anything lately.[/quote]

    I fixed my issue by setting the password in Storage Management. Use the same password as when you login to your machine.



  • Fixed this issue by setting the password in Storage Management. Now, I’m getting the “This Is Not A PartClone Image” error. I did not see the option to change that like in the previous version of FOG.



  • [quote=“Junkhacker, post: 34922, member: 21583”]the fog user and it’s password should have been set for you when you installed fog. let’s try to figure out what happened there.
    did you change any passwords in the gui after installing fog?[/quote]

    I did not. Passwords were left alone.



  • same problem here. It has worked for months now but suddenly it fails (I have done a lot of svn upgrades and run 2145 now). Cannot imagine this has to do with ftp on my server as I have never changed anything lately.



  • Good morning.

    I have exactly the same problem. When I upload a image, they don’t move from /images/dev to /images. If i try to move manually and rename them the problem continues. When the image finish the upload, in the images list size on client is correct but size on server is 0.

    Thanks for your help.


  • Developer

    the fog user and it’s password should have been set for you when you installed fog. let’s try to figure out what happened there.
    did you change any passwords in the gui after installing fog?



  • Thanks! Can you point out the areas where I need to look to fix this? Still learning your product…


  • Developer

    if the upload didn’t move the image from /images/dev to /images, then you have an ftp login problem



  • Thank you kindly! The image is from 1.0.1. I also uploaded a new image, tried downloading but got the error. The only place the image copies to when uploading is the /dev folder and the folder name comes up as the MAC address of the PC I uploaded from. I then copied the file to /images, renamed it to exactly what FOG lists it as and got the same error.


  • Developer

    if you were able to get far enough to schedule a download, then it’s not a mysql password issue.
    fog checks to see if the file exists before it lets you schedule a download. for some reason, it is unable to find the file. i assume that you brought this file over from another fog install, so you may need to check permissions, ownership and make sure you have the file path exactly correct (it is case sensitive). also, if the image came from a fog version prior to 1.0 you will need to set the image format type to partimage.



  • Thanks for the quick response!! So, there has to be a MYSQL password set? I’ve always left mine blank, if I remember correctly. What would go in these two text boxes located in the Fog Configuration Settings?

    FOG_STORAGENODE_MYSQLUSER
    FOG_STORAGENODE_MYSQLPASS



  • Hi,

    the location of the password has changed, wait a second.
    edit: [url]http://fogproject.org/forum/threads/troble-with-mysql-after-upgrading-from-32-to-1-2-0.11302/#post-34627[/url]
    [quote=“TJ333, post: 34627, member: 793”]Found the answers while looking through the release thread. The config.php has become /var/www/fog/lib/fog/Config.class.php. Added my SQL password in and it all worked.[/quote]

    Regards X23


Log in to reply
 

364
Online

38988
Users

10712
Topics

101691
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.