Upgrade to FOG 1.2.0 seems to have broken Apache2



  • Hi All,

    Not sure where to post this as it is an Apache2 issue rather than FOG. But Apache was working until I tried to upgrade…

    fog installer script all ran fine until the setting up of services. MySQL worked fine, but when it tried to start Apache it failed. Attempts to restart it “sudo service start apache2” quickly gives an error message relating to syntax in “/etc/apache2/apache2.conf line:210” There are a couple more errors following this but I suspect they are all related.

    I have looked at line: 210 and it appears to be a line in the “Includes modules section” it reads…

    Include mods-enabled/*.load

    Being a relative Linux newbie, I’m unable to say if the line has a syntax error or not. I have seen some suggestions to “sudo apt-get purge apache2” and “sudo apt-get install apache2” which I tried. The package re-installed without error, but the service still will not start.

    Please help, my FOG server is broken and I have much work to do…



  • Hi DoubleD,

    I don’t know if there is a broken distro of Apache out there. When you run installfog.sh it runs apt-get to fetche all the bits it needs. It seems to be downloading an apache which does not have the mods enabled or are incomplete for some reason.

    Maybe it will get fixed at some point, but at least we have a workaround…



  • [quote=“DoubleD, post: 35149, member: 24577”]I upgraded my FOG server from 1.1.x to 1.2.0 and my FOG server died too - luckily I found this thread

    I did a sudo apt-get install libapache2-mod-php5
    then I re-did the fog installation cd ~/fog_1.2.0/bin
    ./installfog.sh
    Did the KEY thing [url]http://x.x.x.x/fog/management[/url] (pressed the button to install key)

    and now my FOG server is back up & running

    I’m running on Ubuntu

    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.4 LTS
    Release: 12.04
    Codename: precise

    64 Bit

    (wonder why the install broke it)[/quote]

    I’m using dnsmasq to make PXE work for FOG and it seems that the Fog update undid a symbolic link to undionly.kpxe casuing the PXE boot to fail

    To fix that I did the following

    cd /tftpboot
    sudo ln -s undionly.kpxe undionly.0



  • [quote=“fre2709, post: 34072, member: 24947”]Sorry All,

    forgot to mention my version of Ubuntu is 12.04LTS.

    Having dug a little deeper, the /etc/apache2/mods-enabled/php5.load file points to /usr/lib/apache2/modules/libphp5.so" which isn’t there. The only file beginning with “l” is “libphp5filter.so

    As suggested on an Ubuntu server forum I tried: sudo apt-get install libapache2-mod-php5

    It installed a module (libphp5.so has appeared) uninstalled another (libphp5filter.so seems to have gone). Re-installed FOG 1.2.0 and hey presto “it works”. Updated the schema and I am back in and working.

    Did I see on the download page that there is a SVN 2094 for FOG 1.2.0 already. What does that fix?[/quote]

    I upgraded my FOG server from 1.1.x to 1.2.0 and my FOG server died too - luckily I found this thread

    I did a sudo apt-get install libapache2-mod-php5
    then I re-did the fog installation cd ~/fog_1.2.0/bin
    ./installfog.sh
    Did the KEY thing [url]http://x.x.x.x/fog/management[/url] (pressed the button to install key)

    and now my FOG server is back up & running

    I’m running on Ubuntu

    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.4 LTS
    Release: 12.04
    Codename: precise

    64 Bit

    (wonder why the install broke it)


  • Developer



  • Sorry All,

    forgot to mention my version of Ubuntu is 12.04LTS.

    Having dug a little deeper, the /etc/apache2/mods-enabled/php5.load file points to /usr/lib/apache2/modules/libphp5.so" which isn’t there. The only file beginning with “l” is “libphp5filter.so

    As suggested on an Ubuntu server forum I tried: sudo apt-get install libapache2-mod-php5

    It installed a module (libphp5.so has appeared) uninstalled another (libphp5filter.so seems to have gone). Re-installed FOG 1.2.0 and hey presto “it works”. Updated the schema and I am back in and working.

    Did I see on the download page that there is a SVN 2094 for FOG 1.2.0 already. What does that fix?


Log in to reply
 

413
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.