• Good Morning All,

    I tried searching the forum and couldn’t find anything exactly like my issue so I apologize if I missed it and I am double-posting.

    I have a fog server and it has been running smoothly for about a month, I had to shut it down as a test for another thing in our environment. When I turned it back on this morning everything came up normal.

    When I tried to do a full host inventory, it came back and gave me the below error messages (screenshots), after it sits at the screen for about a minute then the 2nd image happens and I have to hard boot.


    In trying to research a fix, many people tried using different kernels, when I went to the folder with bzImage in it, I feel there is stuff missing, see below…


    Everyone else I had looked at had some form of config file named bzImage and bzImage32.

    Has anyone seen this before? Is there a way to resolve it?


    [url="/_imported_xf_attachments/1/1200_photo 1.JPG?:"]photo 1.JPG[/url][url="/_imported_xf_attachments/1/1201_photo 2.JPG?:"]photo 2.JPG[/url][url="/_imported_xf_attachments/1/1202_FOG.gif?:"]FOG.gif[/url]

  • Good to know…That means “video=uvsafb:mode_option=1024x768-16” would not make any difference, right?

  • While I understand what you’re trying to do, my kernel’s have no uvesab stuff and would not require additional parameters.

  • Try adding kernel argument “nomodeset video=uvsafb:mode_option=1024x768-16”, without quotes

  • The bzImage is not a config file, but a binary kernel.

    The “graphic” display is not necessarily an accurate representation of what the file actually is.

    This is why I always prefer cli representations. Another way to test is run the command:
    [code]file /tftpboot/fog/kernel/bzImage[/code]

  • Moderator

    Mine always looks like this 😛

    [url="/_imported_xf_attachments/1/1205_Screen Shot 2014-07-24 at 9.34.33 AM.png?:"]Screen Shot 2014-07-24 at 9.34.33 AM.png[/url]

  • Okay, I installed your kernel and everything appears to be working normal again, it is now getting me to the registration and inventory screen. The one thing I noticed through all of this is that now the bzImage file is back to the config looking file instead of just numbers on a sheet, see below…



    Thanks for the help!!


  • Moderator

    What is running in VMWare? the FOG server or the client or both? Maybe a VMware hardware version upgrade/change could have affected this. Sometimes VM’s are set to upgrade HW on the next boot cycle.

  • Can you please try downloading the kernel I stated above.

    Your issue with the “fuzzy” screen is because of the kernel you’re currently using.

  • I am running Ubuntu 12.04 32-bit. I am using Fog 0.32. Yes it was functioning properly until yesterday when I had to shut it down and restarted it this morning. I have not made any changes, it is running on a virtual machine in VMware.

  • You can also try my 32 bit kernel:

    [code]wget -O /tftpboot/fog/kernel/bzImage http://mastacontrola.com/fogboot/kernel/bzImage32[/code]

  • Moderator

    You can try to use the WEB ui to upgrade the kernel. Or you can download a new bzImage to another folder. backup your original, and then overwrite the bzImage file in /tftpboot/fog/kernel with the new one. You may have to chown/chmod.

  • Moderator

    When requesting help, please include the OS and FOG versions you are using and if you have modified anything that may have an impact, list it also.

    It appears you kernel (bzImage) is loading, and the init file (init.gz) is also loading, but having a problem with something else. I don’t think this is a PXE boot problem because at this point, you have finished PXE and are now in the FOG kernel and boot image.

    Has this exact machine/hardware worked on your FOG system in the past? Very important to know whether your FOG is not working, or you just have new hardware that may need additional drivers/settings.

  • Okay, how do I install the newer kernel?

  • Developer

    video driver incompatibility, maybe? i believe that newer kernels will work with 0.32 if you want to upgrade your kernel. i could be wrong, though. i have no experience with 0.32

  • Okay, I only have 0.32 so I shouldn’t have either one of those, just that 1 file that’s in there?

    Any idea where my issue is coming from?

  • Developer

    bzImage is the 64 bit kernel, bzImage32 is the 32 bit
    these both should exist in any 1.0+ install of fog