Computers won't image



  • I recently installed Fog, and everything was going great. I was able to configure just what I wanted, upload images, and register hosts, but I tried earlier today to do both a multi-cast and a uni-cast, and neither of them worked. On the multi-cast, only the computer that I built the image on would connect to the server and wait for the image, the rest went through the MBR screen (at least that’s what I think that it is) and then rebooted. A screen then came up saying that the computer was missing the operating system. For the uni-casting, once again, only the computer that I built the image on would work, every other computer would just restart. I am running fog 1.1.2. The image that I am trying to push is single disk, multi partition, Windows 7 32-bit. I read some other threads where people has very similar issues, but I didn’t understand some of the answers (I am new to fog and I am not a linux guy) or the questions were never fully answered. Thanks in advance for your help!



  • Sorry that I never updated this post in a timely manner. Right after I started this thread, I went on a 2 week vacation, and when I got back, I had been so busy that I didn’t have the time. As of today, I have a working FOG Server. I know now that the black screen with white writing is the partition and mbr screen. This is the screen that would flash right before the computers would reboot. I know now that the problem was that we didn’t completely clear out the old partitions before imaging, so the image had about 5 partitions and some were logical, which I know now that FOG doesn’t like. Now, I have the standard 100 mb system partition and then the C: partition, and everything is working great. I imaged my first 10 computers today in under 40 minutes. Thank you all for your help!



  • I was thinking of upgrading my .32 FOG installation because it runs on better hardware. With all of the problems I’ve had since testing 1.1.2 I’m worried my entire imaging system will come to a screeching halt. I have a ton of machines to image for the start of the school year. Any recommendations? I assume others are imaging correctly.

    Can I upgrade from .32 to 1.1.2?



  • Trying to download. I uploaded the image last week. How can we tell upon upload if the image file is good or not?


  • Senior Developer

    That error looks like the image file is corrupt. Was this download or upload?



  • I updated the through the latest svn per the above. Thank you for that. I attached a picture of the failure I am getting. Not sure what is going on.

    [url="/_imported_xf_attachments/1/1179_image fail.jpg?:"]image fail.jpg[/url]


  • Senior Developer

    [code]svn co https://svn.code.sf.net/p/freeghost/code/trunk fog_trunk
    cd fog_trunk/bin
    ./installfog.sh[/code]



  • Forgive me for this question but how to I get the latest SVN to try this? I really appreciate the help.


  • Senior Developer

    Please give a try to the latest svn.

    The only issue I think may be happening is the laypart size was specified to 99%. If your resized image is 40GB and the drives you’re trying put the image on are 40GB, the drive end’s up only using 39.5 GB, or something like that. This would cause a problem with sizing.

    You ask why 99%? Because not all drives like the 100% setting that was in use. It only affected, seemingly, 50GB drives or smaller, but larger doesn’t seem to care as much.

    I have finally figured out a more proper method to use the end of the disk as was intended and it doesn’t care about the size of the disk and therefore doesn’t care about the percentages either.

    Hopefully it will fix this issue for people.



  • I feel I am having the same issue but don’t understand why this would be happening. We buy all of our computers with the same exact hardware configuration. If they are the same drives why would they be having a sizing issue? I’ve been using FOG for years and have never had this problem. Could it be because FOG now uses partclone now instead of partimage? Never had this problem on partimage. Nothing but problems since I switched from .32 to 1.1.2.

    If I reduce the size of the partition and upload the image do I have to go into each computer after I deploy it and resize it to get use of all my drive space? Seems like an unbelievable waste of time.

    Please help!!! I have 200 laptops to image.


  • Developer

    Funny thing is I made this same mistake just last week. The issue is most likely that you are using a partition larger than the harddrive can contain. I ran this download on an entire lab and 4 of 30 machines worked without issue.
    My issue was the original partitions were larger than the host harddrives on 26 of the machines. I’m talking just by a few MB too.

    1.)Please check your harddrive of the original image. Verify that it says the same GB as the target Host/client machines.
    –a.)if the same size continue to next. if not then the original image must be smaller than the host/client machines
    2.)Check to see if your original hard drive is using all the available space
    –a.)if it is using the entire drive use a partitioning tool to shrink the size of the largest partition.(EASEUS Partition Master works well)
    –b.)make it the smaller. I use 80GB drives so I shrank it to 59.2GB just incase.
    3.)once the partitioning tool has completed the task…UPLOAD AGAIN! to the fog server.
    –a.)then download to the host and see if partclone starts up for the download

    I can run you through the troubleshooting but I threw out the most likely solution.



  • @Wolfbane8653: What you said is exactly what happened except for the “task complete” screen, which I never saw. The black screen with white text showed up and it appeared to be replacing the MBR, and then something else flashed on the same screen really quickly, which I couldn’t read or get a picture of, and then the computer rebooted.

    @undead-rattler: I am about to go back in and check this out, I will post results.

    @junkhacker: I should have been more clear. I meant the black screen with white text that appeared to be replacing the MBR.


  • Developer

    So I’m going to say this in simple terms. Did the task start then clear the partitions then set up the mbr on a “black screen with white text” then it never went to a “blue screen with the title partclone” then says “task complete” on another black screen and reboot?



  • How big is the HDD you made the image on, the client that works? If it’s bigger than the others, you’re gonna have a bad time. Find the smallest HDD you can build your image on, and use that; I had similar issues where fog didn’t say anything about it being too big, but just whooshing by the imaging part of the deployment. That was 0.32, though, so ¯_(--)

    Best of luck, and welcome!


  • Developer

    mbr screen?


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.