Issues, cannot delete host, cannot add image to host



  • Hello all.

    Not sure what is going on here. I create a new image. That works properly. I create new host, and associate new image with host. That works properly. When I try to edit the host, the image information is gone, and I get the following error message:
    "[CENTER][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000]Upload task failed to create for[/COLOR][/FONT][/SIZE][/CENTER][CENTER][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000] [/COLOR][/FONT][/SIZE][/CENTER][CENTER][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000]with image[/COLOR][/FONT][/SIZE][/CENTER]
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER] [/CENTER][/COLOR][/FONT][/SIZE]
    [SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][CENTER]You need to assign an image to the host"[/CENTER][/COLOR][/FONT][/SIZE]
    [LEFT][SIZE=16px][FONT=Ubuntu][COLOR=#ff0000][SIZE=13px][FONT=Tahoma][COLOR=#141414]Now I am stuck. I can delete the image entry, but I cannot delete the host. On the server itself, there is no file for this host. HELP!!![/COLOR][/FONT][/SIZE][/COLOR][/FONT][/SIZE][/LEFT]



  • Been there - done that!

    Tom’s reply worked perfectly! After months of playing with this thing, I finally have a working FOG server! Yea!

    Thanks Guys


  • Developer

    Sorry I got dumped full of house work in the evening.



  • Worked perfectly!

    Thanks Tom!


  • Senior Developer

    Open a terminal.

    Type: If you set blank mysql password at install remove all of the -p stuff.

    [code]mysql -u root -p’YOURPASSWORDHERE’ fog[/code]

    Once logged in to mysql you should see a prompt like:
    mysql>

    In there type:
    [code]DELETE FROM hosts WHERE hostID=‘0’;[/code]



  • Yup! Going to need some help on this one.


  • Developer

    Unfortunately you may need to dive into mysql and delete this host. If you need some help I can assist.


Log in to reply
 

448
Online

39209
Users

10856
Topics

103338
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.