TFTP Open Timeout



  • Forgive me if this has been answered before but I couldn’t find the solution. I used to have v.32 working just fine.

    I keep getting a TFTP Open Timeout error when a client tries to boot. I can’t get this thing to boot from the server.

    CentOS 6 Server running FOG 1.1.1 (TFTP without DHCP)
    PFsense router with DHCP correctly configured. The clients are given DHCP addresses properly.
    firewall is disabled
    Option 67 is set as /undionly.kpxe.

    Am I doing this right? I can’t tell if TFTP is running because it’s under xinet. That part is new to me.



  • I’ve solved this. I hadn’t configured dhcpd.conf correctly in my pfSense router.

    Apparently, [CODE]option tftp-server-name “ipaddressofserver”;[/CODE] doesn’t do anything, which I find weird. Only the [CODE]next-server[/CODE] seems to work.

    Thanks for your help everybody.


  • Developer

    Connection refused means that there is a firewall(iptables/ufw) issue or the service is no longer operating correctly. On some versions of Ubuntu tftp will fail for unknown reasons and will need to be restarted.



  • option 67 was set to undionly.kpxe.

    [CODE] tftp x.x.x.x get undionly.kpxe[/CODE]

    gives me a server error:

    tftpd: read(ack): Connection refused

    selinux is set to permissive and iptables is off. Permissions on /tftpboot are 777.


  • Developer


  • Senior Developer

    Is it set as: /undionly.kpxe or undionly.kpxe?


Log in to reply
 

445
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.