Upgrade from version 0.32 to 1.0.1 PXE-M0F errors



  • Hi I have upgrade my server of Fog to 1.0.1 on a Ubuntu 14.04 64 bit. But you the client come up with the PXE-M0F: Exiting Intel Boot agent. My DHCP provider is a Cisco WAG120N router and doesn’t have the “next” server option. or I can’t find where too set the DHCP 66 option either

    Q1 do I upgrade to latest version 1.1.2 ? if so can I have a tutorial on this as I can’t find an upgrade option from 1.0.1 to 1.1.2

    Q2 do I amend my current settings to get this to work? As in the past on version 0.32 the same letup let me create several image no problem.

    All help appreciated



  • @Tom I have made the changes as you suggested. Restarted the Ubuntu box, restarted my connection. Just to be sure everything is all puka. Now I get the message as per screen shot attached and the laptop booth to WinTosh

    [url="/_imported_xf_attachments/1/1122_WP_20140709_14_32_06_Smart.jpg?:"]WP_20140709_14_32_06_Smart.jpg[/url]


  • Senior Developer

    Can you do me one more favor?

    Run:
    [code]ln -s /tftpboot/pxelinux.0 /var/lib/tftp/pxelinux.0[/code]



  • @Wolf as stated before I have a Cisco WAG120N which doesn’t have the option67
    @Tom: ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0 didn’t work either

    Do I need to install a separate DHCP server?and then amend the dhcpd.conf to add filename = undionly.kpxe for the subnet I am providing IP address for ?
    Can I install dhcp sever on the same Ubuntu box that is currently running Fog?
    Or do I need to get a router where I can change these options?

    Please advice the quickest way to get my fog server back up and running as I need to image my director’s wife new laptop ASAP


  • Developer

    [quote=“purpleturtle99, post: 32413, member: 23775”]Thanks Jaymes, No I have changed the boot file name yet. I upgrade via the following instructions:
    [url]http://www.fogproject.org/wiki/index.php/Upgrade_to_1.0.0[/url]

    Can you please advise how to change this file? As I have now tried another laptop that was work on 0.32 and I receive PXE-T01, PXE-E3B and PXE-M0F[/quote]

    …added to Upgrade page
    [SIZE=6][B][FONT=sans-serif][SIZE=24px][COLOR=#000000]Change your DHCP Option 67[/COLOR][/SIZE][/FONT][/B][/SIZE]

    [LIST=1]
    [*]Go to your DHCP server and change your Option 67 to undionly.kpxe
    [/LIST]


  • Senior Developer

    Or, link the undionly.kpxe file to pxelinux.0 if you can’t make this change yourself:
    [code]ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code]


  • Developer

    You need to edit the settings of your DHCP server for option 067 to point to undionly.kpxe instead of pxelinux.0



  • [quote=“Jaymes Driver, post: 32407, member: 3582”]Did you change the bootfile name from pxelinux.0 to undionly.kpxe as instructed by the installer script?

    The latest version, 1.1.2 has a number of marginal improvements I would highly recommend upgrading to 1.1.2

    As far as “amending your current set up” we don’t know what your set up is, without more information we can’t offer recommendations. If you need to please use your native language and use google translate.[/quote]

    Thanks Jaymes, No I have changed the boot file name yet. I upgrade via the following instructions:
    [url]http://www.fogproject.org/wiki/index.php/Upgrade_to_1.0.0[/url]

    Can you please advise how to change this file? As I have now tried another laptop that was work on 0.32 and I receive PXE-T01, PXE-E3B and PXE-M0F


  • Developer

    Did you change the bootfile name from pxelinux.0 to undionly.kpxe as instructed by the installer script?

    The latest version, 1.1.2 has a number of marginal improvements I would highly recommend upgrading to 1.1.2

    As far as “amending your current set up” we don’t know what your set up is, without more information we can’t offer recommendations. If you need to please use your native language and use google translate.


Log in to reply
 

455
Online

39176
Users

10821
Topics

102960
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.