Images upload but are maintaining the MAC address as the name and staying in the DEV folder



  • I have had more issues with moving to Fog 1.1.2 than I ever had with the .32 version. Images upload and I don’t get any error while they are uploading. But when I try to multicast or deploy them I get an error that I must upload an image in order to perform an Image Download task. I am not sure what it going on here. Any ideas would be greatly appreciated. By the way I am running this on Ubuntu 13.10 desktop version.

    Thanks,



  • Thanks to everyone for their help and suggestions. I finally found the issue was dealing with the password setting in TFTP_FTP_PASSWORD and Storage management not matching. That was causing the issue with Image not showing properly. I did however, freshly install Fog 1.1.2 on Ubuntu 13.10 and so far so good. Thanks again for all the help everyone.



  • I would suggest using Ubuntu 10.04
    All the problems I’ve had have been easily fixed and they were minor
    I’ve used every version starting at .32 and newer and just upgrading by running the installation script, no clean installs other than the first



  • @Junkhacker, post: 31934, member: 21583 said:

    are you upgrading the os before you run the installer?

    I was not upgrading the OS prior to install. I am going to attempt to use Ubuntu 14.04 and perform all updates first and then install.

    After reading some more in the forums I am not going to attempt to use 14.04 as it seems it has been stated that there are some issues with it. I am going to start all over again with 13.10 and try the installation again. I did not have any problems with the previous version 1.1.1 other than some quirkie issues with tftp and mysql on restart. If all else fails perhaps I’ll go back to the previous version.


  • Developer

    are you upgrading the os before you run the installer?



  • I have been doing fresh installs each time. I reinstalled the OS and started over.



  • When you reinstall are you removing every trace of Fog and starting clean or just running the script again?



  • Wow this is great now I am getting the Database Schema Installer / Updater. I don’t get this what is the world is going on with this thing… If I stop mysql service then I can get into Fog and not get the schema updater. This is so strange. Perhaps, I need to reinstall for only the 5th time today… I am not sure what I am doing wrong. I never had any issues with .32 it worked like a charm.



  • @David Herrington, post: 31901, member: 3549 said:

    I had a similar problem when upgrading from .32 to 1.1.1
    Go to the image you’re trying to deploy under Image Management and make sure the Operating System is set correctly (All my Windows 7 images would default to Windows XP)

    Also check every single host you’re trying to deploy to and make sure they have the correct Host Image selected

    Thanks for the tips also, I took a look at that to make sure that they are set correct. The one thing I did notice was that it was showing 0.00Gb for the size of the image on the Server. I changed the location of the image to match a folder I created in the images folder and now I am seeing that parameter populated, but still get the same error when trying to multicast of deploy the image.



  • @SuP3R_Ch1cKeN, post: 31900, member: 4306 said:

    That seems odd. I would try the following code then try to upload again. However a temp workaround would be moving the files from the MAC address folder (/images/dev/{MAC address}) to a folder named the same as the image name(/images/{image name}).

    >sudo chown -R fog:root /images
    >```
     
    Thanks for the tip but for what ever reason I am still getting an error message stating to setup download task you must first upload an image.


  • @Stanley Parker, post: 31897, member: 2529 said:

    I have had more issues with moving to Fog 1.1.2 than I ever had with the .32 version. Images upload and I don’t get any error while they are uploading. But when I try to multicast or deploy them I get an error that I must upload an image in order to perform an Image Download task. I am not sure what it going on here. Any ideas would be greatly appreciated. By the way I am running this on Ubuntu 13.10 desktop version.

    Thanks,
    I had a similar problem when upgrading from .32 to 1.1.1
    Go to the image you’re trying to deploy under Image Management and make sure the Operating System is set correctly (All my Windows 7 images would default to Windows XP)

    Also check every single host you’re trying to deploy to and make sure they have the correct Host Image selected



  • That seems odd. I would try the following code then try to upload again. However a temp workaround would be moving the files from the MAC address folder (/images/dev/{MAC address}) to a folder named the same as the image name(/images/{image name}).

    sudo chown -R fog:root /images
    


  • It appears to finish and the machine reboots…



  • Does the image actually finish when you’re uploading or does it display a " every few seconds?


Log in to reply
 

352
Online

38746
Users

10569
Topics

100052
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.