Changes to UDP-SENDER



  • Hi,

    I have tweaked the file lib/fog/MulticastTask.class.php, changing from the Client Count to 2 the mínimum receivers (just in case there’s a broken PC) and I have set a mínimum wait of 300 seconds.

    I have changed the several lines to look like this

    
    $cmd .= 'cat "'.$path.'"|'.UDPSENDERPATH.'  --min-wait 300 --min-receivers 2 --portbase '.$this->getPortBase().' '.$interface.' '.$wait.' --full-duplex --ttl 32 --nokbd;';
    
    

    but when I launch the multicast task, it is not applying the change, taking the new parameters.

    In the multicast.log file you can see

    
    [06-26-14 12:48:14 pm] CMD: cat "/images/Windows7x64Limpia/rec.img.000"|/usr/local/sbin/udp-sender --min-receivers 13 --portbase 63494 --interface eth0  --full-duplex --ttl 32 --nokbd;cat "/images/Windows7x64Limpia/sys.img.000"|/usr/local/sbin/udp-sender --min-receivers 13 --portbase 63494 --interface eth0  --full-duplex --ttl 32 --nokbd;
    
    

    Is it there any other place where I should change that ?


  • Senior Developer

    Just remember, any changes you make to have “service” controlled files is just loading a cached version of the needed files at service start time. It has no clue about any changes until after a restart. I wish I could make it work without having to restart, but at least we know how to fix it when you edit these files.



  • That was it! … I forgot to restart the service.

    Thanks!!


  • Developer

    Did you restart the service after making changes?

    
    sudo /etc/init.d/FOGMulticastManager restart
    

Log in to reply
 

913
Online

38717
Users

10545
Topics

99837
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.