How to reboot clients?



  • Maybe my searching abilities are failing me, but I cannot figure out how to reboot a client from the server.

    I am trying to automate a large deployment which includes installing drivers and joining computers to a domain. The image pushes fine and everything works, but there is one point when the newly imaged client requests a reboot and requires a user to click the button. I would like to avoid pushing “reboot now” on all of my machines. Ideally, I would run a reboot task, but I can’t find one. I have tried creating a reboot batch file and pushing it as a snap-in, but I get an error that reads, “Failed to create deploy task. Snapins Are already deployed to this host.”

    So how do I force a bunch of clients to reboot when I want them to? The documentation for “Task Reboot” makes it sound like this will only work when an image is set to be deployed to a machine, so the functionality is built in to the client service, but isn’t really helpful for my situation.



  • batch file should have:

    shutdown /r

    This will notify all users logged on that in 1 minute the computer will reboot … snapin executes with exit 0 :)



  • The original question I asked in this thread has been answered. My question was, “How do I push a reboot?” The answer is to create a batch file that does something trivial, make a snapin from that script, and configure the snapin reboot the client. I am still having snapin problems, but I will open another thread to address that.

    Tom & Junkhacker, thank you for your help.



  • No. “No results found.”


  • Developer

    is anything listed under “Active Snapin Tasks” ?



  • I tried, but it fails. I am going to Task Management > List All Hosts > choose my host > Advanced Deployment (gear icon) > Single Snapin. The only thing that shows up is, “Failed to create deploy task. Snapins Are already deployed to this host.”


  • Developer

    have you scheduled a snapin deploy?



  • I just tried setting up a different snapin. The Fog documentation links to a youtube video for how to use SFX to create an Office installer. I created and tested that and set it up as a snapin. Then I went to Hosts > my hosts > Snapins and added it. Still nothing. Is there a different way I should be pushing snapins to hosts? The fog service is running (installed as administrator) and the fog.log file shows nothing happening but regular checkins with the server.



  • So it’s not just rebooting after the task I’m having a problem with. The task is not running at all. I created a new batch file and had it create a file after it ran, but that file still does not exist. The recent snapin items in the log file:
    [QUOTE]FOG::SnapinClient Attempting to connect to fog server…
    FOG:SnapinClient Module is active…[/QUOTE]


  • Senior Developer

    Those lines are referring to a Task on the server. Such as an image upload, image download task. They’re not referring to a system reboot after snapin task.

    Those would be in the snapin lines of the FOG Log.



  • I wasn’t sure, so I just uninstalled, reinstalled as admin for all users, and rebooted. While it was rebooting, I went into Host management and removed the snapin and let it check in once. Then I added the snapin to the host again. Same problem.
    fog.log shows four lines concerning the reboot task:
    [QUOTE]FOG::TaskReboot Attempting to connect to fog server…
    FOG::TaskReboot Module is active…
    FOG::TaskReboot Attempting to connect to fog server…
    FOG::TaskReboot No task found for client.[/QUOTE]



  • This post is deleted!


  • This post is deleted!

  • Developer

    when you installed the client service, did you run as administrator and install for all users?



  • Yes, I did.


  • Developer

    when you created the snapin, did you check the “[FONT=Ubuntu][COLOR=#555555]Reboot after install” [/COLOR][/FONT]checkbox[FONT=Ubuntu][COLOR=#555555]?[/COLOR][/FONT]



  • OK.
    I created a batch file with the command “echo” in it (like yours, but I’m not on a domain yet so echo seemed more appropriate). I added it to the snapins. I went into Hosts, chose my host, clicked Snapins, and added the echo snapin to the host. I edited the config.ini to force reboots. No luck. When I open fog.log, there is a line that reads, “FOG::TaskReboot No task found for client.” I also tried going to Task Management > List All Hosts > choose host > Single Snapin, but I get an error reading, “Failed to create deploy task. Snapins Are already deployed to this host.” Am I doing something wrong?


  • Developer

    reboots are associated with tasks. it can be a very simple task though. i have a gpupdate.bat snapin that i sometimes deploy just to make a system reboot. it’s just
    [CODE]
    gpupdate

    [/CODE]



  • Thanks for the quick reply. :)

    I haven’t deployed any software yet. The only thing I have installed are some drivers from the DriverPacks website. I’m following along with the tutorial at [url]http://fogproject.org/forum/threads/windows-7-deployment-fog-sad2-driver-tool.380/[/url]. The drivers install and then the system reboots. Then at the next boot, it automatically logs in (configured to in sysprep) and immediately asks for another reboot.

    Is there no way for the fog service to check in with the server and see a reboot is requested?


  • Developer

    there is an option to make computers reboot after snapin deploy, but that probably will not work for you if your program requires interaction to finish. it sounds to me like your problem is in your software deployment and how automated (or not) it is. there are a number of options for making installers operate without interaction.


Log in to reply
 

371
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.