Cannot upload - too many bad sectors



  • Hi, one of the ways I use FOG is to use it to upload an image of a PC with bad sectors, so that I can swap a failing hard drive out.

    I know in general it’s not a good idea to upload an image from a bad hard drive but the previous version was actually quite forgiving and I never really ran into any problems with it when I did use it. When I get round to it, I tend to use a disk to disk cloning ISO, for this situation, but I thought I would use the issue as an excuse to try the latest Fog and and also make a copy of this XP image, which has an Office 2010 license on it.

    So after installing latest Fog and scheduling the upload task, it turns out that Partclone doesn’t run if there are too many bad sectors.

    I thought I’d try a debug upload and fiddle with the script but that just launches a script off the server by the looks of things.

    Nothing seems to be in Fog Settings either.

    My next step would be to look through the scripts and see where I can change the options on the partclone call - can anyone give me a pointer to where this might be?

    Thanks



  • Thank you for the information. Actually, the hard drive was too far gone, I tried RAW and no luck with that it crashed quite quickly. I have copied using another utility for now.


  • Developer

    @Wolfbane8653, post: 30648, member: 3362 said:

    I’m curious…If you change Fog Configuration–>FOG Settings–>General Settings–>FOG_LEGACY_FLAG_IN_GUI tick this option. Then go to Image Management–> Select your image --> change image settings and set the Deployment Method to partImage instead of partClone.

    Then upload with the bad sectors and deploy on the new HD.

    What happens? Will this actually work?

    all images are uploaded in partclone format in the latest fog. if an image is set to partimage, it still uploads as a partclone image, then changes the setting from partimage to partclone.


  • Developer

    I’m curious…If you change Fog Configuration–>FOG Settings–>General Settings–>FOG_LEGACY_FLAG_IN_GUI tick this option. Then go to Image Management–> Select your image --> change image settings and set the Deployment Method to partImage instead of partClone.

    Then upload with the bad sectors and deploy on the new HD.

    What happens? Will this actually work?


  • Senior Developer

    You might look in /bin/fog.upload and tweak the partclone call by simply adding --ignore_crc?

    I don’t know how well it will work though. Did you try setting the image as raw? This might help. I’m using partclone.imager to do raw copying and this may help you as well.


Log in to reply
 

447
Online

38717
Users

10545
Topics

99837
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.