Fog 1.1.1 with ProxyDHCP: /default.ipxe... Connection timed out



  • Hi,

    I am trying to set up a working fog server with ProxyDHCP. I use this howto:[URL=‘http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP’][COLOR=#555555]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/COLOR][/URL]
    and /opt/fog_1.1.1/installation.txt.

    If boot a client pc by network I end with this mesage:
    [INDENT][I]/default.ipxe… Connection timed out ([url]http://ipxe.org/4c126035[/url])[/I][/INDENT]

    Here are some technical details:
    [LIST]
    []Kubuntu 12.04 (updated)
    [
    ]Fog 1.1.1
    []Firewall is turned off
    [
    ]FritzDSL-Router (without any options set that hould cause problems)
    [/LIST]

    Content of /etc/network/interfaces
    [INDENT][I]auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet static
    address 192.168.1.254
    netmask 255.255.255.0
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1[/I][/INDENT]

    Content of /etc/dnsmasq.d/ltsp.conf
    [INDENT][I]# Don’t function as a DNS server:
    #port=0

    Log lots of extra information about DHCP transactions.

    log-dhcp

    Dnsmasq can also function as a TFTP server. You may uninstall

    tftpd-hpa if you like, and uncomment the next line:

    enable-tftp

    Set the root directory for files available via FTP.

    tftp-root=/tftpboot

    The boot filename, Server name, Server Ip Address

    dhcp-boot=undionly.kpxe,fog-Aspire-5110,192.168.1.254

    rootpath option, for NFS

    #dhcp-option=17,/images

    kill multicast

    #dhcp-option=vendor:pXEClient,6,2b

    Disable re-use of the DHCP servername and filename fields as extra

    option space. That’s to avoid confusing some old or broken DHCP clients.

    dhcp-no-override

    PXE menu. The first part is the text displayed to the user. The second is the timeout, in seconds.

    pxe-prompt=“Press F8 for boot menu”, 3

    The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,

    Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI

    This option is first and will be the default if there is no input from the user.

    pxe-service=X86PC, “Boot from network”, undionly

    A boot service type of 0 is special, and will abort the

    net boot procedure and continue booting from local media.

    #pxe-service=X86PC, “Boot from local hard disk”, 0

    If an integer boot service type, rather than a basename is given, then the

    PXE client will search for a suitable boot service for that type on the

    network. This search may be done by multicast or broadcast, or direct to a

    server if its IP address is provided.

    pxe-service=x86PC, “Install windows from RIS server”, 1[/I][/INDENT]

    Could anybody help please?

    Tob



  • Matthew,

    thank you for this idea. I already switched to a more reliable solution. I might try Fog in the future again with firewall turned off.



  • Tob,

    I was having the same problem. The way around it was to turn off the firewall on my router. Let me know if that helps.


  • Developer

    [quote=“Meitar Ronen, post: 30549, member: 24536”]I have the same problem…
    some clients are succsefully conncting to FOG (and uploading\downloading images) and some get the 4c126035 error…[/quote]

    Try different switch gear, there may be a settings on a switch that is preventing information from being passed. If you are using these settings (ltsp.conf), then the settings are correct. If you are successful in booting some but not others, please note the location, the model number, and the nic card. These errors are typically from the ipxe kernel and you should try the most up to date ipxe files that Tom has included for us. I am willing to bet the machines are a different model number of have different hardware.

    If moving to a different switch solves the issue, you know where to look/work. If not, I would look into the ipxe files and finally Wireshark to see if the files are getting properly to the destination.

    Or you can thread jack, then go start your own thread… I guess that works too -.-

    [url]http://fogproject.org/forum/threads/defualt-ipxe-connection-timed-out-ipxe-error-4c126035.10842/[/url]



  • I have the same problem…
    some clients are succsefully conncting to FOG (and uploading\downloading images) and some get the 4c126035 error…


Log in to reply
 

541
Online

39007
Users

10720
Topics

101798
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.