Problem after upgrading from 0.32 to 1.1.1



  • Hi, sorry in advance I’m a total newbie to this. I just started working in a new gig where they had a FOG server running 0.32. It would kernel panic when trying to PXE boot our new ThinkPad T540p devices, so I thought an upgrade was in order. The upgrade went fine, and according to dhcpconfig my option 067 is correct, but for some reason whenever I PXE boot any device at all I now get the following:

    [INDENT=1]Client MAC ADDR: xx xx xx xx xx xx GUID: xxxxxxxx xxxx xxxx xxxx xxxxxxxxxxxx[/INDENT]
    [INDENT=1]Client IP: xxx.xxx.xxx.xxx MASK: xxx.xxx.xxx.xxx. DHCP IP: xxx.xxx.xxx.xxx[/INDENT]
    [INDENT=1]Gateway IP: xxx.xxx.xxx.xxx[/INDENT]
    [INDENT=1]TFTP.[/INDENT]
    [INDENT=1]PXE-M0F: Exiting Intel Boot Agent.[/INDENT]
    [INDENT=1] [/INDENT]
    I’ve checked my tftp by using it to get the new 067 kpxe file, but then again if I connect to the web interface and try to download a new kernel it will hang at “moving file to TFTP”.

    Any ideas? Any help would be so greatly appreciated!



  • I have problems with fog 1.1.1 working correctly if the GUID of the computer is not displayed. Fog 1.1.1 is ok if the GUID is displayed, however if it sees FFFFFF …etc it says not for us.



  • so with TFTP off, the message I get at PXE boot is the expected TFTP . . . . . until it finally times out. This is making me think the issue is specific to TFTP. I went and checked my username / password, and for some reason the web interface was dropping part of the password for the user I provided. I changed the user to something that has the same access but a plain text password. The web interface likes that just fine, but I get the same

    TFTP.
    Exiting

    Screen when booting over PXE. Are there other usual suspects in the TFTP settings I should be cluing in on?



  • [quote=“Tom Elliott, post: 30474, member: 7271”]Do you have another DHCP server on your network, or is FOG the only one?[/quote]

    I have my DHCP service running on Active Directory as well, though it doesn’t have a scope for the IP that my fog server is on


  • Senior Developer

    Do you have another DHCP server on your network, or is FOG the only one?



  • Just to see what would happen, I made a symlink like Tom had suggested, but I made it to pxelinux.0.old. No change when booting a client over PXE



  • DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.6.116.243;
    filename “undionly.kpxe”;

    subnet 10.6.116.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 10.6.116.10 10.6.116.254;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 10.6.116.246;
    option routers 10.6.116.246;
    filename “undionly.kpxe”;
    }


  • Developer

    Any chance we can get a direct copy? PM it to Tom or something.



  • [quote=“Junkhacker, post: 30464, member: 21583”]if that is a direct copy, i see the issue

    undionly.kxpe should be undionly.kpxe[/quote]

    not a direct copy, so just a dumb typo. Good catch, though, you made me double-take for a second between screens :eek:


  • Developer

    [quote=“NickConrad, post: 30463, member: 24656”]Tom, the following is my dhcpd.conf located in /etc/dhcp3, did I goof somewhere along the way here?

    [INDENT=1]use-host-decl-names on;[/INDENT]
    [INDENT=1]ddns-update style interim;[/INDENT]
    [INDENT=1]ignore client-updates ;[/INDENT]
    [INDENT=1]next-server xxx.xxx.xxx.xxx.[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]subnet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx {[/INDENT]
    [INDENT=2]option subnet-mask xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=2]range dynamic-bootp xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=2]default-lease-time 216000;[/INDENT]
    [INDENT=2]max-lease-time 43200;[/INDENT]
    [INDENT=2]option domain-name-servers xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=3]option routers xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=3] [/INDENT]
    [INDENT=2]filename “undionly.kxpe”;[/INDENT]
    [INDENT=1]}[/INDENT]
    [INDENT=2] [/INDENT]
    [/quote]

    if that is a direct copy, i see the issue

    undionly.kxpe should be undionly.kpxe



  • [quote=“NickConrad, post: 30457, member: 24656”]the full error was “pxelinux.0: no such file or directory” which is why I figured it was that.

    As for undionly, it’s in tftboot as a .kkpxe, .kpxe, .kpxe.INTEL, and .pxe.[/quote]

    Tom, the following is my dhcpd.conf located in /etc/dhcp3, did I goof somewhere along the way here?

    [INDENT=1]use-host-decl-names on;[/INDENT]
    [INDENT=1]ddns-update style interim;[/INDENT]
    [INDENT=1]ignore client-updates ;[/INDENT]
    [INDENT=1]next-server xxx.xxx.xxx.xxx.[/INDENT]
    [INDENT=1] [/INDENT]
    [INDENT=1]subnet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx {[/INDENT]
    [INDENT=2]option subnet-mask xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=2]range dynamic-bootp xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=2]default-lease-time 216000;[/INDENT]
    [INDENT=2]max-lease-time 43200;[/INDENT]
    [INDENT=2]option domain-name-servers xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=3]option routers xxx.xxx.xxx.xxx;[/INDENT]
    [INDENT=3] [/INDENT]
    [INDENT=2]filename “undionly.kpxe”;[/INDENT]
    [INDENT=1]}[/INDENT]
    [INDENT=2] [/INDENT]



  • [quote=“Tom Elliott, post: 30454, member: 7271”][code]sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code]

    Will create the link for you. I’m already aware that pxelinux.0 doesn’t exist. What that command “no such file or directory” is telling you and maybe me is that /tftpboot/undionly.kpxe doesn’t exist on your system. This might very well be your issue.[/quote]

    the full error was “pxelinux.0: no such file or directory” which is why I figured it was that.

    As for undionly, it’s in tftboot as a .kkpxe, .kpxe, .kpxe.INTEL, and .pxe.


  • Senior Developer

    [code]sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code]

    Will create the link for you. I’m already aware that pxelinux.0 doesn’t exist. What that command “no such file or directory” is telling you and maybe me is that /tftpboot/undionly.kpxe doesn’t exist on your system. This might very well be your issue.



  • [quote=“Wolfbane8653, post: 30452, member: 3362”]This shows that the file exists and it is accessible to the network without firewall conflicts. Next I would direct you to your option 66 and 67 settings but Tom is already on that. Soooo…keep with him.[/quote]

    Will do, and thanks for your help thus far


  • Developer

    [quote=“NickConrad, post: 30450, member: 24656”]Transfer successful[/quote]

    This shows that the file exists and it is accessible to the network without firewall conflicts. Next I would direct you to your option 66 and 67 settings but Tom is already on that. Soooo…keep with him.



  • [quote=“Tom Elliott, post: 30448, member: 7271”]Is option 67 set to undionly.kpxe? Is it possible your network needs shorter name? What happens if you create a link as pxelinux.0?

    [code]sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code][/quote]

    I get a “no such file or directory” on that because pxelinux.0 has a .old on the end of it now. I guess I could drop the suffix?

    As to option 67. I am guessing this is somehow the issue, so is there a stupid proof way to check this? In my config files both in dhcp and dhcp3 I am pointed to undionly.kpxe.



  • [quote=“Wolfbane8653, post: 30449, member: 3362”]From a Windows 7 machine can you run the folowing where x.x.x.x is your fog server ip. You may need to install the service under your “Add Windows features/services”

    [I][SIZE=12px][CODE]tftp x.x.x.x get undionly.kpxe[/CODE][/SIZE][/I][/quote]

    Transfer successful


  • Developer

    From a Windows 7 machine can you run the folowing where x.x.x.x is your fog server ip. You may need to install the service under your “Add Windows features/services”

    [I][SIZE=12px][CODE]tftp x.x.x.x get undionly.kpxe[/CODE][/SIZE][/I]


  • Senior Developer

    Is option 67 set to undionly.kpxe? Is it possible your network needs shorter name? What happens if you create a link as pxelinux.0?

    [code]sudo ln -s /tftpboot/undionly.kpxe /tftpboot/pxelinux.0[/code]



  • [quote=“Wolfbane8653, post: 30442, member: 3362”]Have you tried restarting tftpd-hpa service?
    Is your firewall disabled?[/quote]

    Don’t think the firewall is coming in to play here as this was working without a hitch pre-upgrade (except for the T520 ThinkPads that prompted the upgrade in the first place). Restarted the tftpd-hpa service just now, but I get the same deal.


Log in to reply
 

361
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.