Task Management is Blank & Invalid OS ID Windows 7 (5)

  • Developer

    Good morning!

    It’s been a while for listing problems b/c I just “NAG” Tom directly but I thought this would be a good idea to at least post this… I updated this morning (6/9/2014 @ 8:10am)

    I was in the process of registering machines and I miss pressed a key when adding a HOST to a Group. The group ID I wanted was 3 and I pressed 4 in my haste. At this time Group 4 does not exist. I then continued and told Fog to image the machine. On the next boot I received “An error has been detected ***** Invalid OS ID Windows 7 (5) ***** An error has been detected”

    I tried deleting the host from the Host Management and it would not delete using fog’s delete function due to the id field came up ID=0. So, I ran:
    [CODE]delete from hosts where hostName=’<HOSTNAME>’;[/CODE]

    This deleted the host out of the HOST Management but when I went to delete the task for imaging this Host the Task Management page is blank. Here is what I get in the apache2 error log.

    [QUOTE][FONT=arial][COLOR=#222222]PHP Fatal error: Call to a member function __toString() on a non-object in /var/www/fog/lib/pages/TaskManagementPage.class.php on line 419, referer: [url][/url][/COLOR][/FONT]

    I have rebooted the Fog server and restarted apache2 service. Any ideas?

    fog v1.1.0-r1799


  • Developer


    I truncated the entire tasks table, removed the bad member reference in groupMembers, and anything else related to this 'BAD HOST"…The Invalid OS ID is due to a small bug in r1799.

    Issue resolved.


  • Developer

    [S]I have fixed the Task Management page by Clearing the Tasks table were nameTask is “AutoRegTask”.[/S]
    [S]For you coders out there:[/S]
    [S][CODE]delete from tasks where taskName=‘AutoRegtask’;[/CODE][/S]

    [S]Going to try to image machine see if I still get the “Invalid OS ID Windows 7 (5)” error.[/S]

    [B]Edit:[/B] This did not fix the issue. The Task Management page is blank again as soon as I registered the next HOST and I am still getting the Invalid OS ID.

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.