IPXE issues - work around



  • Hi Guys,

    As a few people have had issues with iPXE booting correctly (me included)
    I thought I would post this and see if it helps anyone.

    In the /tftpboot/ folder:
    I ended up symlinking pxelinux.0.old to pxelinux.0
    creating pxelinux.cfg folder then creating default inside that.
    inside pxelinux.cfg/default I created the options:

    [CODE]
    DEFAULT vesamenu.c32
    MENU TITLE Fog Reimage Menu

    MENU COLOR TITLE 1;36;44 #ffffffff #00000000 std
    MENU BACKGROUND images/black.png

    LABEL iPXE Boot
    MENU DEFAULT
    KERNEL ipxe.krn
    APPEND dhcp && chain http://10.0.0.253/fog/service/ipxe/boot.php?mac=${net0/mac}
    PROMPT 0
    TIMEOUT 1
    [/CODE]

    After that I changed the pxeboot service to point at pxelinux.0 instead of the undionly.kkpxe file

    Its not ideal I guess but it means I don’t have to change and play with fogs default files.

    Cheers,


  • Developer

    Hi dl550,
    I can’t see how this is related to the other posts in the thread!? To be honest I don’t really understand what you are asking for! Probably a good idea to open up a complete new post and describe what exactly goes wrong. Are you trying to have french keyboard layout?



  • Hello,
    I’m new to the list but a user ferving FOG.
    I can not change the configuration of the keyboard in QWERTY.
    I changed in the “General Settings” -> KEYMAP_FOG = en without success.
    I checked the language available: [url]http://fogproject.org/wiki/index.php/Boot_Image_Key_Map[/url]
    I get good at the launch of bzimage:
    bzImage32 kernel root = / dev / ram0 rw = 127000 ramdisk_size ip = dhcp dns = 192.168.1.3 web keymap = fr 192.168.1.3 /
    fog / consoleblank loglevel = 4 = 0 mode = manreg
    This has no effect, I’m interested in a solution.
    Thank you for your response.
    DL550


  • Developer


  • Developer

    No. No EUFI.


  • Moderator

    Are all of these in UEFI mode by any chance?

    Also, no necro.


  • Developer

    In one browser
    [url]http://FOGSERVERIP/fog/service/ipxe/boot.php?mac=00:21:70:46:4d:f2[/url]

    The answer is:

    [CODE]#!ipxe
    kernel bzImage32 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 keymap= web=10.0.15.4/fog/ consoleblank=0 loglevel=4 mac=00:21:70:46:4d:f2 ftp=10.0.15.4 storage=10.0.15.4:/images/dev/ storageip=10.0.15.4 web=10.0.15.4/fog/ osid=50 loglevel=4 consoleblank=0 irqpoll hostname=u001021 chkdsk=0 img=centos imgType=mps imgPartitionType=all imgid=1 imgFormat= PIGZ_COMP=-9 hostearly=1 pct=5 ignorepg=1 mining=1 miningcores=1 miningpath=http://fogproject.org/fogpackage.zip type=up
    imgfetch init_32.xz
    boot[/CODE]


  • Developer

    Hi,

    I have tries this solution but don’t works. The error is "[B]Could not start download: operation not supported[/B]"
    I have tested it under different hardwares (optiplex 755, HP 8300) and the result is the same.

    I have installed FOG r2407 in a physical server and the dhcp server is not in the FOG server, and we use dnsmasq.



  • Whoops - spoke to soon - it worked once!

    I tried to deploy the antivirus quarantine to test things and it went back to looping. Will I ever see the Fog menu again???

    Terry

    EDIT - removed the antivirus task and the menu booted. I’ll try some debug tasks next.

    EDIT 2 - the moment I remove a task, it loads the menu. Until then, it just keeps looping. Tried with download debug and debug tasks.



  • [quote=“Tom Elliott, post: 29539, member: 7271”]From the image you provided, the init.xz file you have is corrupted, can you try manually downloading the init.xz again on your fog server:
    [code]cd /var/www/fog/service/ipxe/
    rm init.xz init_32.xz
    wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/init.xz
    wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/init_32.xz[/code][/quote]

    This just worked for me - I was getting loops after it started loading ipxe.init until I replaced the versions I had (in 1.2.0) with these. Thank goodness!!! Now I’m anxious to really give this a workout! :-)

    Terry



  • Sorry for so much trouble!

    I [SIZE=3][COLOR=#000000]went in and ran: [/COLOR][/SIZE]

    [SIZE=3][COLOR=#000000]sudo passwd fog (reset fog user password)[/COLOR][/SIZE]

    [SIZE=3][COLOR=#000000]then [/COLOR][/SIZE]

    [FONT=Consolas][SIZE=3][COLOR=#000000]chown -R fog:root /var/www/fog/service/ipxe[/COLOR][/SIZE][/FONT]
    [FONT=Consolas][COLOR=#000000][SIZE=3]chown -R fog:root /images[/SIZE][/COLOR][/FONT]

    [FONT=Consolas][SIZE=3][COLOR=#000000]then on FOG interface: [/COLOR][/SIZE][/FONT]

    [COLOR=#000000][SIZE=3][FONT=Consolas]Storage Management -> [FONT=Ubuntu]Management Username / Password to fog / (**fog user password - same as used on passwd line above)[/FONT][/FONT][/SIZE][/COLOR]
    [COLOR=#000000][SIZE=3][FONT=Ubuntu]FOG - Configuration ->Settings -> [/FONT][/SIZE][/COLOR][FONT=Tahoma]FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD. (same as user/pass as Storage Management )[/FONT]

    [COLOR=#000000][SIZE=3][FONT=Tahoma]FINALLY SOLVED! [/FONT][/SIZE][/COLOR]

    [COLOR=#000000][SIZE=3][FONT=Tahoma]I think my problems were that I had another user for logging to FOG web interface, and that user was also the one in the Storage [/FONT][/SIZE][/COLOR][FONT=Tahoma]and TFTP settings (not the fog user). [/FONT]

    [COLOR=#000000][SIZE=3][FONT=Tahoma]Previously on 0.32b I had it that way and worked OK. After updating to FOG 1.1.0 I started having trouble with either uploading, [/FONT][/SIZE][/COLOR][FONT=Tahoma]kernel update, etc. [/FONT]
    [FONT=Consolas][SIZE=3][COLOR=#000000]Does everything have to be with the “fog” user?[/COLOR][/SIZE] [/FONT]



  • Still can’t update the kernels thru the FOG interface.

    I think I have a permissions issue in one or more folders.

    I try to image a new computer (upload) and it starts imaging, everything ok until it finishes which shows:

    • FOGFTP: Failed to rename file. Remote Path: /images/temp**** , Local Path: /images/dev/fb8c******, Error: ftp_rename(): Rename failed.

  • Senior Developer

    Try checking: FOG Configuration (? icon) -> FOG Settings -> TFTP Settings -> FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD.



  • Ok I just double checked everything. I just noticed that on FOG 1.x.x under “Storage Management” you now have the “Management username” and “Management Password” over there. I noticed that upon FOG 1.1.0 install, it changed that information (fog and a really long password), I changed it to the user/password that I have always used with FOG, restarted the server. And now everything is OK with image uploading.

    I also ran sudo apt-get update and sudo apt-get upgrade to update all the software in my installation. Apparently all those steps did the trick.

    However, I still can’t update any kernels thru the FOG web interface. It downloads the kernel but stops at “[FONT=Ubuntu][COLOR=#555555]Download Completed! Moving [COLOR=#000000]file to TFTP server…” [/COLOR][/COLOR][/FONT]



  • Confirmed the bad RAM issue with a bootcd (Memtest86+).

    On the FTP issue, I uploaded two images while I was on 1.0.1. Upon changing to 1.1.0, I just checked and I CAN’T!!! .
    When I try I get the: “Can’t mount NFS volume!” When trying to upload.

    I regularly use Filezilla to connect to the FOG server to transfer files. I normally connect to it via SFTP. After upgrading from 1.0.1 to 1.1.0 I can connect using SFTP, but NOT via FTP. vsftp is version 2.3.5.

    What files do I have to check?


  • Senior Developer

    [quote=“Elias Santiago, post: 29532, member: 3245”]Is this related to this error I’m having?

    [IMG]http://i57.tinypic.com/ot2r88.jpg[/IMG]

    Also, I try to update the Kernel thru the FOG 1.1.0 interface, it downloads then stays at this screen indefinetely…
    [IMG]http://i61.tinypic.com/1rvvid.jpg[/IMG][/quote]

    This this on any gx520 machine you’re seeing? I ask because the informatoin looks like it could be bad RAM on that system.

    iPXE loads the kernel and init into RAM. Kernel loads then tries to load init, the sector of RAM that the init is sitting at could be bad which would be why you’re getting the corrupt message.

    As for the FTP issue, are you able to upload images to your FOG Server? I’m guessing that, as of right now, you’re only trying to download an image to client machines or you haven’t tried anything yet. What version of vsftpd do you have on your system?

    Have you verified the permissions of the /var/www/fog/service/ipxe are set as: fog:root? You can ensure this is the case with:
    [code]chown -R fog:root /var/www/fog/service/ipxe[/code]



  • Updated, [B]same[/B] error, [B]same[/B] spot. I’m just selecting the “Verify Client Compatibility” menu option from FOG iPXe menu.

    HOWEVER, I tried PXE booting another PC (Optiplex 745) and selecting the “Client Compatibility” menu option to verify and it continues correctly. I suspect it must be something with Optiplex GX520 which is the one giving me the error I showed before.

    FOG 1.1.0
    OS Ubuntu 12.04 LTS


  • Senior Developer

    From the image you provided, the init.xz file you have is corrupted, can you try manually downloading the init.xz again on your fog server:
    [code]cd /var/www/fog/service/ipxe/
    rm init.xz init_32.xz
    wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/init.xz
    wget https://svn.code.sf.net/p/freeghost/code/trunk/packages/web/service/ipxe/init_32.xz[/code]



  • I’m trying to image (previously worked with FOG 0.32) a Dell Optiplex GX520

    I updgraded from FOG 0.32 as soon as 1.0.1 was out, imaged many computers with 1.0.1.
    Now moved to FOG 1.1.0, and having this issue.



  • Is this related to this error I’m having?

    [IMG]http://i57.tinypic.com/ot2r88.jpg[/IMG]

    Also, I try to update the Kernel thru the FOG 1.1.0 interface, it downloads then stays at this screen indefinetely…
    [IMG]http://i61.tinypic.com/1rvvid.jpg[/IMG]


Log in to reply
 

337
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.