PXE boots to laptop, but not to desktops



  • Hello all…

    I just installed a fresh copy of 14.04, and 1.0.1 using all the standard no frills choices. I am using fog as my dhcp server.
    I can boot to fog on my Latitude E5510, but not to my Dell 3010.

    Attached is a screenshot of one of my 3010’s failing to boot to fog, and going right into Windows.[ATTACH=full]872[/ATTACH]

    I admit I’m fairly lost when it comes to linux, but I’ve stumbled my way through my previous .32 fog server for the past year.

    Thanks in advance for the help!

    Steve

    [url="/_imported_xf_attachments/0/872_20140602_145443_Madison Ave.jpg?:"]20140602_145443_Madison Ave.jpg[/url]





  • Ok…so, I just got 1.0.1 working…and now I see that its not the most current version? wth…someone please send me a link to update…something a non-linux guy can understand. Thanks!



  • Ok…so I restarted the TFTP service…and all seemed to go well…except. The pc instead of booting into the FOG menu, it just reboots. It’s a dell 3010, and the PXE file I’m using is ipxe.kpxe.
    Any suggestions for a working pxe boot file?


  • Developer

    Since you rebooted you may need to restart the TFTP service



  • Both…and then checked the boot of the client again…i seems to connect, and then stays at PXE-E32 TFTP open timout for about 5 min’s.
    The only thing I’m seeing in the syslog is DHCPACK and DHCPREQUEST.


  • Senior Developer

    Which computer did you reboot? The server? The client?



  • I rebooted the computer…will that suffice?


  • Developer

    some dhcp servers require a restart of the service for config changes to take effect. did you restart the service?


  • Senior Developer

    [quote=“SteveL, post: 29040, member: 24457”]I did make the change to the dhcpd.conf file, and yes…it was just a type o.[/quote]
    What change?

    If you copied the file ipxe.kpxe as: undionly.kpxe, then you shouldn’t be getting file not found.

    If you copied the file ipxe.kpxe as: ipxe.kpxe and moved undionly.kpxe to undionly.kpxe.orig, this is likely your issue. The file can’t be found because it doesn’t exist.

    What wolfbane is asking, if you changed the dhcpd.conf file to point at ipxe.kpxe, then did you restart dhcpd services?



  • I did make the change to the dhcpd.conf file, and yes…it was just a type o.


  • Developer

    [quote=“SteveL, post: 29031, member: 24457”]Hey Tom…thanks for the quick reply. I tried renaming undionly.kpxe.orig, and placed ipxe.kpke file in the tftpboot folder, and now when I boot one of my dell 3010’s, it says tftp file not found…am I missing something?[/quote]

    Did you change your DCHP server to reflect that setting change from undionly.kpxe --> ipxe.kpxe

    oh and you spelled ipxe.kpke I hope you meant ipxe.kpxe.



  • Hey Tom…thanks for the quick reply. I tried renaming undionly.kpxe.orig, and placed ipxe.kpke file in the tftpboot folder, and now when I boot one of my dell 3010’s, it says tftp file not found…am I missing something?


  • Senior Developer

    There were known issues with previous undionly.kpxe files, but ipxe has fixed the 040ee119 errors.

    If you’re still having problems I say try one of the ipxe labeled files (particularly ipxe.kpxe) for your environment.


  • Developer

    please update to the latest version of undionly.kpxe in the svn trunk. we believe we may have the issue finally fixed.
    details: [url]http://fogproject.org/forum/threads/040ee119-error-on-boot.10493/page-3#post-28887[/url]


Log in to reply
 

403
Online

38953
Users

10706
Topics

101571
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.