IPXE PHP boot files not found

  • Hi all,
    Thanks to the developers for all of your work, the new edition of FOG is great. I did search for this issue and I did not see it mentioned, but perhaps I didn’t search hard enough…
    When building a new box I tried installing FOG 1.0.1 from scratch and on iPXE boot it has a message that boot.php or other iPXE files cannot be found:
    [url][/url]… file not found
    It seems okay if you install FOG 1.0.0 and upgrade to 1.0.1 (still testing) but in my environment a direct install of 1.0.1 on a fresh installation is causing this issue.
    I’ve attached a screenshot,


  • The MySQL Issues could play into account as much of the data Polled comes out of the database. So it’s not too surprising to see the issue. This may also explain why a reinstall seems to help fix some of the issues. Not a complete reinstall from scratch, just simply rerunning the installer in place.

  • Developer

    PXE is a Network boot option. The TFTP service is configured in the fog install to “share” the files in /tftpboot. Then the undionly.kpxe(Boot file) file “chains” or links to the files located in /var/www/fog/service/ipxe. The ipxe folder contains the “Kernels” that are needed to run the selections made in the Fog Menu.

    I’m not sure on the SQL but there are many issues with 14.10 considering its only been released for 2 months.

  • Hi,
    Sorry I should have included more information. It’s Ubuntu 14.04 x64, fresh install of FOG 1.0.1.

    There’s nothing in /var/lib/tftpboot, and there is no /var/lib/tftp directory, everything is in /tftpboot/

    I don’t quite understand how iPXE works, but isn’t it pointing to /var/www/fog/service/ipxe for these files? That is what the screenshot seems to indicate. I know that it gets undionly.kpxe from /tftpboot/ but boot.php, bzImage, and init.xz are all in /var/www/fog/service/ipxe

    Does FOG store operational data (to function) inside SQL? Because as strange as it sounds the problem seems to be related to SQL crashing as described in this thread:


    Once SQL stops working (with “unable to connect to database” message) the whole system becomes unstable and machines are no longer able to find the necessary iPXE/tftpboot files. I know that it sounds like the 2 issues should be unrelated, but this is just what I’ve experienced - perhaps the paths or some other data is stored in SQL that is needed during the boot process?

    Thanks Tom, you’re the best,

  • What’s the OS you’re seeing this issue on? I ask because I ran a fresh install on my FOG Server CentOS 6.5 and had NO issues. I also ran another fresh install on Debian 7.5 and had no issues.

    I’ve been hearing/helping/seeing reports of some systems installing tftp in /var/lib/tftp or /var/lib/tftpboot but the installfog.sh is installing tftpboot files in /tftpboot. The initial load out works perfectly by running through the undionly.kpxe located in /tftpboot, but after that point it’s looking in /var/lib/{tftp||tftpboot} and failing because the files aren’t located there.

  • Okay,
    I take it back, it is still happening, even with TFTP working…

    The good news is that I’m pretty sure that everything is fine if you install 1.0.0 and upgrade, but if anyone has any advice I would definitely test/tweak further just for information, etc. because a direct install of the latest version is always the best way…

    For now I guess I will use my 1.0.0 --> 1.0.1 box and go from there…


  • Hi,
    Yes I could log in to the web UI even with this error present.

    After more digging, I’ve been told that this issue is the upstart TFTP problem again. For some reason I thought that TFTP’s work was done once the host was loaded into PXE, but I guess not.

    After applying the upstart TFTP fix it seems to be working, I will test further.

    THANKS FOG team,

  • Developer

    can you log into the webgui?