Linux mint 17 deployment issue



  • I am using fog .32 and trying to deploy linux mint to some older laptops. When I created the image, I setup the partitions as follows:
    /dev/sda1 is ext3 mounted to / with 32.6GiB
    /dev/sda2 is linux-swap with 4.66Gib
    Only a 40GiB hdd. Im trying to run deployment again to see what it is saying after it finishes the first partition. What happens is that after it finishes, it restarts and goes to bios screen and keeps restarting in a loop. I am wondering if I set up the partitions of the hard drive up correctly??? I will post pics from my phone in a few mins after posting this.


  • Testers

    In case anyone else is interested in doing this I’ve updated my instructions on the fog wiki to describe
    [LIST]
    [*][URL=‘http://fogproject.org/wiki/index.php/Include_SystemRescueCD’]how to include SystemRescueCD [wiki][/URL]
    [/LIST]
    You [I]can[/I] do it by just booting from the CD instead, but we found it a really handy addition for resetting admin passwords, fscking filesystems, recovering broken systems etc. so we put it into fog.


  • Testers

    It sounds like grub might be messed up, I’ve seen this quite a lot on 0.32. The short answer is that if you don’t have a big investment in your current fog setup, replace it with 1.1.0 and things should start to work (they did for me). The long answer is much cooler :) here it is…

    You need to reinstall grub but to do that you need the linux system mounted. To get around this chicken-and-egg problem you need to boot from a liveCD then switch to the linux system with chroot. I use systemrescueCD to fix things like this, there are instructions on the [URL=‘http://www.sysresccd.org/Sysresccd-Partitioning-EN-Repairing-a-damaged-Grub’]sytemrescueCD website here[/URL]. Here is a summary, the lines starting with a “#” are my running commentary…

    [CODE]

    I’m assuming your disk shows up as /dev/sda, if not change it as appropriate.

    Mount the root partition somewhere (assuming single partition setup)

    $ mount /dev/sda1 /mnt/windows

    Mount the proc, dev and sys filesystems inside the linux root

    $ mount -o bind /proc /mnt/windows/proc
    $ mount -o bind /dev /mnt/windows/dev
    $ mount -o bind /sys /mnt/windows/dev

    Chroot into the linux system with a bash shell (systemresuceCD uses zsh which probably won’t be available in the chroot)

    $ chroot /mnt/windows /bin/bash

    Reinstall grub, you should get a success message or there is a problem with the grub configuration.

    $ grub-install /dev/sda
    [/CODE]

    If you have a different partition setup there are some modifications to the mount steps but that is basically it, again the [URL=‘http://www.sysresccd.org/Sysresccd-Partitioning-EN-Repairing-a-damaged-Grub’]systemrescueCD page[/URL] has good information on this. It also tells you how to get out of the chroot and then unmount everything, but I usually just hit Ctrl-D then reboot. The system should boot into grub now.

    We had to do this so frequently that I actually added systemrescueCD as a boot option in the fog menu. It lets you run filesystem checks and reset passwords etc very easily - just make sure the entry is password protected.

    I hope this helps, but as I said at the top, try fog 1.1.0; the grub and linux partition handling is much better, I have a bunch of linux images working now for RHEL, Mint and Ubuntu.



  • Sorry been away for a bit. Tom, I mean that when I turn the computer on, it goes to the screen where it says press f2 to enter setup and then restarts and repeats this process. I think my problem is that I am unsure of how to set up my partitions in linux. I do have it setup for ext3 file system, but beyond that I’m not sure.


  • Developer

    he is running 0.32, so it shouldn’t be a undionly.kpxe problem. i would say that i think this is more likely a “0.32 doesn’t like linux” issue, but the screenshots look like the image profile settings don’t match the actual image file data.


  • Senior Developer

    What do you mean the system is in a restart loop?

    The system isn’t loading to windows, it’s failing to get dhcp from IPXE and just reboots after that?

    I ask because I don’t think it’s an imaging problem causing your “reboot” loop, but rather the dreaded 040ee119 error we’ve seen.

    Try replacing your /tftpboot/undionly.kpxe with this:
    [code]mv /tftpboot/undionly.kpxe /tftpboot/undionly.kpxe_rbloop
    wget -O /tftpboot/undionly.kpxe --no-check-certificate https://mastacontrola.com/ipxe/d6300-DEFAULT-GOOD/undionly.kpxe[/code]

    Hopefully all will work for you.



  • Ok, I went back to the multiple partition single disk and had to kill the previous task and it was back to normal. I’m still having trouble with the original problem. Anybody have any ideas about that?


  • Developer

    so far as i know, single disk resizable is only usable on ntfs partitions



  • Quick update, I tried changing the imaging type to single disk re-sizable and re uploading the image. I got hit with an error that said invalid OS id (Linux 50!). I then went back and changed it to multiple partition non re-sizable and still getting the error. Not sure what thats about either



  • Here are the pics

    [url="/_imported_xf_attachments/0/861_IMG_20140530_162138_219.jpg?:"]IMG_20140530_162138_219.jpg[/url][url="/_imported_xf_attachments/0/862_IMG_20140530_161530_603.jpg?:"]IMG_20140530_161530_603.jpg[/url]


Log in to reply
 

411
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.