Fog 1.0.1 and Ubuntu 14.04 network printers



  • I have successfully installed FOG 1.0.1 and Ubuntu 14.04 for the server, installed and imported the client into FOG web GUI, imaging upload and downloading works flawlessly, however, when I try to setup network printers I can’t get the server to push them to the client

    checking the fog.txt log file on the client it shows it connecting to the server and checking for printers however it says there is 0 printers found on server

    [INDENT=1][I]5/23/2014 8:50 AM FOG:PrinterManager Printer update was request from fog tray…[/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager Management level = 1[/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager Adding new printers to host…[/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager 0 found on server side.[/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager Failed to connect to fog server![/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager This is typically caused by a network error![/I][/INDENT]
    [INDENT=1][I] 5/23/2014 8:50 AM FOG:PrinterManager Sleeping for 1 minute.[/I][/INDENT]
    This is how I have the printer configured FOG web GUI, but it’s setup as a network printer with \server\printer name

    i have tried multiple variations

    \server\SecondFloorOperations - Xerox 7775
    smb://server/SecondFloorOperations%20-%20Xerox%207775
    \ipofserver\SecondFloorOperations - Xerox 7775

    maybe even a couple others, is there something I am missing? does the printer have to be locally installed in the OS?

    I changed my server name to “server” for security purposes

    Thanks!


  • Senior Developer

    @zacharylewis07, post: 29144, member: 24431 said:

    Having Printer Issues Also…
    I’ve installed FOG 1.1.0 with patches from svn version 1780, yet I’m still having issues with PrinterManager adding and removing printers. I have “Add and Remove” selected for all hosts under “Printers” in Host Management.

    Experiencing the following…

    • Random comments in the FOG log: PrinterManager Service is disabled and I get no printers deployed at all.
    • When printers do finally decide to deploy, I can’t remove them afterwards without cleaning up the registry.

    Any help is greatly appreciated.

    User since FOG 0.26 (Love the software)

    Did you upgrade from 0.32 or is this a “fresh” install of 1.1.0?



  • Having Printer Issues Also…
    I’ve installed FOG 1.1.0 with patches from svn version 1780, yet I’m still having issues with PrinterManager adding and removing printers. I have “Add and Remove” selected for all hosts under “Printers” in Host Management.

    Experiencing the following…

    • Random comments in the FOG log: PrinterManager Service is disabled and I get no printers deployed at all.
    • When printers do finally decide to deploy, I can’t remove them afterwards without cleaning up the registry.

    Any help is greatly appreciated.
    User since FOG 0.26 (Love the software)



  • Thank you very kindly sir!


  • Developer

    we have found this problem and are verifying a fix for it.


Log in to reply
 

392
Online

38920
Users

10688
Topics

101407
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.