Latest Development FOG

  • can you try 2574?

  • Ditto on Ray’s post. using 2571.

  • Tom,

    Im running 2570 and just did a unicast to one client and the image completes but at the end it says sending to database and I get this.

    Continuously scrolling and in task manager in the gui it says imaging still in progress.

  • SVN 2563 released.

    Hopefully made some more progress in the never ending quest for fixing the large result set returned issue we’ve been seeing, though I’m not expecting much. It appears to give a pretty good overall performance improvement on the GUI side though so just maybe?

    Also add’s a new get request to get the snapin args of snapins for post download scripts in the snapcheck.php file.

  • SVN 2559 released.

    Hopefully this will have better handling of memory by freeing up the memory used by the database connection. This connection cannot be freed from the MySQL class otherwise you’ll only ever get the first returned set whether using store_result or use_result. I don’t think it’ll help but quite possibly?

    Hopefully this fixes any/all of the pressing issues (e.g. Image definition creation, installation on Ubuntu/Debian, reports blank page, etc…)

    I’m not expecting any miracles but maybe, just maybe I’m heading in the right direction?

    Also, A few things to note incase I missed things and figure it’d be nice to just know about in general.

    1. ) This is probably the largest pressing item: memory_limit in php.ini does not need to be adjusted any more, nor’ will it work with FOG any longer. I’ve made a new value setting in FOG Configuration->FOG Settings->General Settings called FOG_MEMORY_LIMIT. Set your value here, I’ve defaulted it to 128 as is the default php starts out with. Anything non-numeric or lower than this number will be reset to 128.

    2. ) Snapin’s now have group-group relationships as do images. This means images and snapins can be replicated across groups as well as their relevant group’s nodes. Does this mean there’s no bugs? Probably not, but feel it’s good to know about.

    3. ) Hidden menu now has it’s own timeout setting separate from the regular timeout. Also, when hidden menu is in use, the timeout on the regular options is set to 0 which should mean it just waits for you to make a selection. It’s quite possible I need to change this though as I believe --timeout 0 will just boot right to the first item rather than wait indefinitely. Will need people to test this for me if possible.

    4. ) You can now email imaging tasks as they complete. It, right now, is only valid for Unicast imaging, or anything that hits the Post_Stage3.php file on completion. However, it should work. Settings for this are found in FOG Configuration->FOG Settings->FOG Email Settings. They should be rather self explanatory.

  • Well I was working on something else and messed things up even more… lol?

    I’m not using this in production, just seeing what I can mess up and testing

    Anyways I just left the database alone, I didn’t touch anything at all when updating
    But before running the 1.2 installer while on 2556 none of my images would show in the list and if I tried to create another one they wouldn’t show up either

    Hosts show up and I can create new ones on 2556 if that matters at all

    At the end of the apache error log there’s several PHP warnings
    [QUOTE]PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/fog/lib/pages/ImageManagementPage.class.php on line 351, referer: [url][/url][/QUOTE]

    There’s also this warning
    [QUOTE]PHP Warning: MySQL::sqlerror(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 180, referer: [url][/url][/QUOTE]

    I’m not too worried about fixing this, like I said, it’s a test machine but thought I’d bring it up just in case

  • David,

    Can you verify your apache error logs?

    2558 is now the most current. I think it’s got something to do with the switch from a single storage group vs multiple storage groups. When you “reinstalled” 1.2, did you just copy back the db or did you leave the database alone? Reverting the two otherwise should’ve cause serious issues.

  • [quote=“ArchFan, post: 38653, member: 19266”]Where are your images stored, /images?[/quote]

    Correct, I’ve always had everything set to the default

  • [quote=“David Herrington, post: 38651, member: 3549”]I just went from 1.2 to build 2556 and none of my images show up under image management now
    If I run the 1.2 installer again, they show up like nothing has changed

    Have any idea why that would be?[/quote]

    Where are your images stored, /images?

  • I just went from 1.2 to build 2556 and none of my images show up under image management now
    If I run the 1.2 installer again, they show up like nothing has changed

    Have any idea why that would be?

  • Okay, I’m leaving it as it is, for now, it appears to work much more better even though it is spitting out query no packages found or something like that. I don’t mind that if the installer works properly.

  • I found another issue as it basically just reverted it back to how it was working. I’m trying another approach that will hopefully work much better. 2556

  • Sorry I suck so much sometimes lol!

  • And the crowd goes wild for 2555.

    Thx mate.

  • Try 2555?

  • [quote=“sudburr, post: 38643, member: 4706”]No love for 2554 either. Still failing at php5-json.[/quote]

  • No love for 2554 either. Still failing at php5-json.

  • Okay,

    Maybe, finally, and fully? 2554?

  • Your favourite, ubuntu-14.04.1-server-amd64 .

  • I’m not seeing the same issues, though it’s still trying to install fog as I’m on my laptop for the vm containing my debian install.