IPXE issue



  • Hi All,

    Recently upgraded to 1.0.1 and encountering some issues.
    [LIST]
    []We did the upgrade as per the instructions
    [
    ]Changed option 67 to undionly.kpxe
    [/LIST]

    This is the error we are getting when booting to pxe

    Configuring (net0 MAC ADDRESS)… Error 0x040ee119 ([url]http://ipxe.org/040ee119[/url])
    After this we don’t get the fog menu containing registration, quick image ect.
    It just boots to hdd

    Any help would be much appreciated.

    Many Thanks,
    Seb



  • Hi Tom,
    Thanks for your help,
    My setup is working now, i had changed the ports through which machines were booting.
    Now it is working.

    thanks and regards,
    sushant j


  • Senior Developer

    The latest undionly files can be downloaded from:
    [code]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp[/code]

    I don’t have an update because I don’t know exactly what’s wrong. If your switches don’t have STP enabled, then is it the delay between the request and acknowledgement of the DHCP address? How long does it take for your system, or systems, to receive a DHCP address?



  • Hi Tom,
    Do you have any update on this?
    If possible, Can you please share me latest undionly.kpxe file for my scenario.



  • Hi tom,
    My switches dont have STP enabled.


  • Senior Developer

    When you say, “My switches are not STP”, what do you mean? They’re not STP brand, or they’re don’t have STP Enabled?



  • HI
    i had problem with undionly.kpxe, so i tried Chainloading PXE to iPXE using pxelinux.0
    Now i have problem, when i open website , i am getting message “unable to connect to database”

    I am using fog 1.1.0 installed on ubuntu 14.



  • My switches are not STP
    Where do you think should i enable portfast, between fog side and dhcp server???
    what do you think problem is, is it time response between DHCP and Client or DHCP and FOG server.???

    can you give me link to download latest undionly.kpxe???

    thanks,
    sushant



  • Hello Tom,

    Thanks for your prompt help. I will provide you STP details in few minutes, till i have one more input for you.

    We have FOG Server which have 4 1G Ethernet ports and we have created bond0 from ubuntu side so that we will get 4g pipe.
    At switch side we have Nexus 2010 switch on which we have configured portchannel of this 4 ports.

    So do you think we have to disable or enable portfast/Rapid STP on this 4 ports.

    Just for your info we have tried replacing below kpxe files, but no luck with it
    [B][/B]

    Thanks,
    Sushant


  • Senior Developer

    [quote=“sushant jangale, post: 36508, member: 25752”]Not working for me…
    same error…
    Configuring (net0 <MAC ADDRESS>)…Error 0x040ee119
    and reboots[/quote]

    We need more info.

    The switches your working from are setup for STP? Can you disable or enable Portfast/Rapid STP?



  • Not working for me…
    same error…
    Configuring (net0 <MAC ADDRESS>)…Error 0x040ee119
    and reboots


  • Developer

    If you want to keep on the cutting edge with fog follow this thread. I know it says 0.33 but its a sync to the latest revision.

    [url]http://fogproject.org/forum/threads/keep-up-to-date-with-all-the-fog-0-33-updates.10300/[/url]


  • Developer



  • [quote=“Junkhacker, post: 28386, member: 21583”]try the latest undionly.kpxe, a longer max wait time for DHCP responses has been added and it seems to help a lot[/quote]

    Where can i find the latest undionly.kpxe? I’m sort of losing track of all the ones that i have tried.


  • Developer

    try the latest undionly.kpxe, a longer max wait time for DHCP responses has been added and it seems to help a lot


  • Developer

    I will talk to Tom today and get some new pxe’s to try out see if we can get it down to one solid file. I’m currently using undionly.kpxe.1312 from release 1312. It seems stable for my machines.



  • Is anyone else getting this issue still? Or have others been sorted out? Maybe there is something wrong with our spec?
    We are currently running ubuntu 12.04, should i try going to 13.04/13.10?


  • Senior Developer

    [quote=“Steven Chew, post: 28339, member: 21664”]Well I finally got everything working for me. The issue turned out not to be fog related or kpxe file related at all…The issue was a second DHCP server running on my network - I tracked it down using WireShark. I inherited a mess of a network and should have thought of looking for a rogue DHCP to begin with. Anyways things are working now though it does seem a bit slow I can deal with that I am doing my first upload and it started at about 250MB/min it’s running at 350MB/min right now.

    I don’t know what could be the cause of that I have this running on a Ubuntu 14.04 VM on a Hyper-V 2012 R2 Server only one other VM on it that isn’t heavily utilized. Anyways if anyone could point me in the right direction with the speed that would be great otherwise oh well at least its flipping running![/quote]

    VM’s have known “slowness” issues on upload compared to physical systems typically, but as Junkhacker states, the compression affects upload speeds as well. In 0.32 there was no “easy” way to adjust the compression rating, but with 1.X.X, you can specify this in FOG Configuration->FOG Settings->FOG Boot Settings->FOG_PIGZ_COMP slider bar. 9 means MAX compression which basically means it will be the slowest to upload, but compress to the smallest size. 0 means least compression but takes up the most space on the server. You can play with these settings to see if it will help you out.


  • Developer

    decreasing your compression rate can speed up uploads, but will have little effect on downloads, which are quite fast anyway



  • Well I finally got everything working for me. The issue turned out not to be fog related or kpxe file related at all…The issue was a second DHCP server running on my network - I tracked it down using WireShark. I inherited a mess of a network and should have thought of looking for a rogue DHCP to begin with. Anyways things are working now though it does seem a bit slow I can deal with that I am doing my first upload and it started at about 250MB/min it’s running at 350MB/min right now.

    I don’t know what could be the cause of that I have this running on a Ubuntu 14.04 VM on a Hyper-V 2012 R2 Server only one other VM on it that isn’t heavily utilized. Anyways if anyone could point me in the right direction with the speed that would be great otherwise oh well at least its flipping running!


Log in to reply
 

476
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.