Error received from TFTP server



  • OS: CentOS 6.5 64x (VMware 10)
    I keep getting the following error.
    I tried the following.
    [url]http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP[/url]
    Then I downloaded the VMFogServer .30v file and it ran properly but I need to image windows 8 computers. So this solution didn’t work. I tried this solution just in cased my network setting were incorrect.

    I need to run this Fog Server from my laptop using CentOS 6.5 x86_64 in a VMware environment.
    I also, found these error codes.
    [url]http://www.fogproject.org/wiki/index.php/PXE_error_code[/url]
    any help would be great. Thanks.[ATTACH=full]791[/ATTACH]

    [url="/_imported_xf_attachments/0/791_Windows 8 x64-2014-05-19-00-16-18.png?:"]Windows 8 x64-2014-05-19-00-16-18.png[/url]



  • I also followed the wiki installation instructions Step-by-Step. FTP was missing from my install and SeLinux didn’t actually disable. I would verify the /etc/selinux/config has SELINUX=disable.


  • Senior Developer

    When you ran the installer, did any part of it fail? Maybe Apache install? I ask because if vsftpd wasn’t installed, something happened and FOG wouldn’t have been completely installed yet.



  • Yeah, one of the things that I read was from the Wiki. Is one of the first steps to pre-installing Fog project.
    Source: [url]http://www.fogproject.org/wiki/index.php/Installation_on_CentOS_6.4[/url]


  • Senior Developer

    [code]sed -i ‘s/SELINUX=enforcing/SELINUX=disabled/’ /etc/sysconfig/selinux[/code]

    File is located in /etc/sysconfig/selinux or /etc/selinux/config.

    The /etc/sysconfig/selinux is usually just a symbolic link to /etc/selinux/config.



  • I had the same error. I don’t remember exactly where the file is located. I can tell you tomorrow when I get into work but you need to disable SeLinux. Once you do that restart the fog server and then when it comes back up the image should finish almost immediately.



  • I wasn’t able to connect to my box using ftp, because it wasn’t installed for some reason. After I installed it I was able to connect to the server but I need to reset the password. I’ll keep working on that.

    [code]
    cted to 192.168.106.130 (192.168.106.130).
    220 (vsFTPd 2.2.2)
    Name (192.168.106.130:root): fog
    331 Please specify the password.
    Password:
    530 Login incorrect.
    Login failed.[/code]

    Checking for vsftpd.
    [code][root@localhost ipxe]# /etc/init.d/vsftpd status
    vsftpd (pid 38063) is running…[/code]

    Checking chkconfig list
    [code][root@localhost ipxe]# chkconfig --list vsftpd
    vsftpd 0:off1:off2:on3:on4:on5:on6:off[/code]

    Source::
    [url]http://www.fogproject.org/wiki/index.php/Password_Central[/url]


  • Developer

    first check that ftp is running, and you can connect with the credentials set in the fog webgui



  • How do I approach this issue?


  • Developer

    if you’re getting far enough to get those FOGFTP errors, then your tftpboot folder is fine. the problem you’re having is with the /images folder connection with ftp



  • [quote=“Tom Elliott, post: 27410, member: 7271”]My guess as to the issue. Did you change the file that the DHCP server looks for on tftp? In 33b and up, it’s should be set to undionly.kpxe.

    On Windows DHCP server you much change the Option 67 part to look for this new file. In the past it was pxelinux.0, now it’s undionly.kpxe.

    Also, make sure the permissions are correct as the file in /tftpboot should be owned by the FOG user which can be ensured by running, as root user, the command:

    [code]chown -R fog:root /tftpboot[/code]

    Hopefully this helps.[/quote]

    There is problem that I saw with this folder path. For some reason. [code]chown -R fog:root /tftpboot[/code] didn’t work, so I came across this in. [code]restorecon -Rv /tftproot[/code][COLOR=#000000] so I was able to get to upload an image up to 99.80% when it fails. There is a problem I haven’t figured out how to setup the proper ownership on this folder (/tftpd). At the moment I’m trying to add the fog user and my local accounts to the root folder to see if that makes any difference. [/COLOR]
    [COLOR=#000000]Here is my ls -Zal output[/COLOR]

    [COLOR=#000000][code][/COLOR]
    [COLOR=#000000]root@localhost /]# ls -Zal[/COLOR]
    [COLOR=#000000]total 118[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 25 system_u:object_r:root_t:s0 root root 4096 Jun 3 10:33 [/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 25 system_u:object_r:root_t:s0 root root 4096 Jun 3 10:33 [/COLOR]
    [COLOR=#000000]-rw-r–r--. 1 system_u:object_r:etc_runtime_t:s0 root root 0 Jun 3 10:33 .autofsck[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 2 system_u:object_r:bin_t:s0 root root 4096 Jun 2 13:22 bin[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 5 system_u:object_r:boot_t:s0 root root 1024 May 21 15:55 boot[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 18 system_u:object_r:device_t:s0 root root 3720 Jun 3 10:33 dev[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 105 system_u:object_r:etc_t:s0 root root 12288 Jun 3 10:34 etc[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 4 system_u:object_r:home_root_t:s0 root root 4096 Jun 2 11:29 home[/COLOR]
    [COLOR=#000000]drwxrwxrwx. 3 unconfined_u:object_r:default_t:s0 root root 4096 Jun 2 11:29 images[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 10 system_u:object_r:lib_t:s0 root root 4096 May 21 02:31 lib[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 9 system_u:object_r:lib_t:s0 root root 12288 Jun 2 13:22 lib64[/COLOR]
    [COLOR=#000000]drwx------. 2 system_u:object_r:lost_found_t:s0 root root 16384 May 21 02:27 lost+found[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 2 system_u:object_r:mnt_t:s0 root root 4096 Jun 2 13:56 media[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 3 system_u:object_r:mnt_t:s0 root root 4096 May 21 02:36 mnt[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 4 system_u:object_r:usr_t:s0 root root 4096 Jun 2 11:29 opt[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 184 system_u:object_r:proc_t:s0 root root 0 Jun 3 10:33 proc[/COLOR]
    [COLOR=#000000]dr-xr-x—. 3 system_u:object_r:admin_home_t:s0 root root 4096 Jun 3 10:37 root[/COLOR]
    [COLOR=#000000]dr-xr-xr-x. 2 system_u:object_r:bin_t:s0 root root 12288 Jun 2 13:22 sbin[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 7 system_u:object_r:security_t:s0 root root 0 Jun 3 10:33 selinux[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 2 system_u:object_r:var_t:s0 root root 4096 Sep 23 2011 srv[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 13 system_u:object_r:sysfs_t:s0 root root 0 Jun 3 10:33 sys[/COLOR]
    [COLOR=#000000]drwxrwxrwx. 3 unconfined_u:object_r:tftpdir_t:s0 drnatas root 4096 Jun 2 14:21 tftpboot[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 3 unconfined_u:object_r:tftpdir_t:s0 fog drnatas 4096 Jun 2 14:05 tftpboot.prev[/COLOR]
    [COLOR=#000000]drwxrwxrwt. 23 system_u:object_r:tmp_t:s0 fog root 4096 Jun 3 10:37 tmp[/COLOR]
    [COLOR=#000000]-rw-r–r--. 1 unconfined_u:object_r:etc_runtime_t:s0 root root 0 Jun 2 14:08 undionly.kpxe[/COLOR]
    [COLOR=#000000]-rw-r–r--. 1 unconfined_u:object_r:etc_runtime_t:s0 root root 0 Jun 2 14:07 unidionly.kpxe[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 13 system_u:object_r:usr_t:s0 root root 4096 May 21 02:27 usr[/COLOR]
    [COLOR=#000000]drwxr-xr-x. 22 system_u:object_r:var_t:s0 root root 4096 Jun 2 11:29 var[/COLOR]
    [COLOR=#000000][/code][ATTACH=full]881[/ATTACH][/COLOR]

    [url="/_imported_xf_attachments/0/881_Windows 8-2014-06-03-08-24-36.png?:"]Windows 8-2014-06-03-08-24-36.png[/url]


  • Developer

    The upload speed is slow because of compression. in the latest version of fog, the compression is set to 9, previously it was set to 3. i personally set this to 6. this primarily affects uploads, downloads are quite fast. i regularly get speeds downloading in the 3GB range.



  • I changed the Option 67 to what you said and now I’m able to upload my images and such but it is way to slow. My upload is like 436MB where as before it was a little over a Gig. Anyway to fix this or have I made my FOG server pretty much unusable now?


  • Senior Developer

    My guess as to the issue. Did you change the file that the DHCP server looks for on tftp? In 33b and up, it’s should be set to undionly.kpxe.

    On Windows DHCP server you much change the Option 67 part to look for this new file. In the past it was pxelinux.0, now it’s undionly.kpxe.

    Also, make sure the permissions are correct as the file in /tftpboot should be owned by the FOG user which can be ensured by running, as root user, the command:

    [code]chown -R fog:root /tftpboot[/code]

    Hopefully this helps.



  • This post is deleted!

Log in to reply
 

442
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.