Error received from TFTP server



  • OS: CentOS 6.5 64x (VMware 10)
    I keep getting the following error.
    I tried the following.
    http://www.fogproject.org/wiki/index.php/Unable_to_connect_to_TFTP
    Then I downloaded the VMFogServer .30v file and it ran properly but I need to image windows 8 computers. So this solution didn’t work. I tried this solution just in cased my network setting were incorrect.

    I need to run this Fog Server from my laptop using CentOS 6.5 x86_64 in a VMware environment.
    I also, found these error codes.
    http://www.fogproject.org/wiki/index.php/PXE_error_code
    any help would be great. Thanks.Windows 8 x64-2014-05-19-00-16-18.png



  • I also followed the wiki installation instructions Step-by-Step. FTP was missing from my install and SeLinux didn’t actually disable. I would verify the /etc/selinux/config has SELINUX=disable.


  • Senior Developer

    When you ran the installer, did any part of it fail? Maybe Apache install? I ask because if vsftpd wasn’t installed, something happened and FOG wouldn’t have been completely installed yet.



  • Yeah, one of the things that I read was from the Wiki. Is one of the first steps to pre-installing Fog project.
    Source: http://www.fogproject.org/wiki/index.php/Installation_on_CentOS_6.4


  • Senior Developer

    sed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/sysconfig/selinux
    

    File is located in /etc/sysconfig/selinux or /etc/selinux/config.

    The /etc/sysconfig/selinux is usually just a symbolic link to /etc/selinux/config.



  • I had the same error. I don’t remember exactly where the file is located. I can tell you tomorrow when I get into work but you need to disable SeLinux. Once you do that restart the fog server and then when it comes back up the image should finish almost immediately.



  • I wasn’t able to connect to my box using ftp, because it wasn’t installed for some reason. After I installed it I was able to connect to the server but I need to reset the password. I’ll keep working on that.

    http://www.fogproject.org/wiki/index.php/Password_Central


  • Developer

    first check that ftp is running, and you can connect with the credentials set in the fog webgui



  • How do I approach this issue?


  • Developer

    if you’re getting far enough to get those FOGFTP errors, then your tftpboot folder is fine. the problem you’re having is with the /images folder connection with ftp



  • Windows 8-2014-06-03-08-24-36.png


  • Developer

    The upload speed is slow because of compression. in the latest version of fog, the compression is set to 9, previously it was set to 3. i personally set this to 6. this primarily affects uploads, downloads are quite fast. i regularly get speeds downloading in the 3GB range.



  • I changed the Option 67 to what you said and now I’m able to upload my images and such but it is way to slow. My upload is like 436MB where as before it was a little over a Gig. Anyway to fix this or have I made my FOG server pretty much unusable now?


  • Senior Developer

    My guess as to the issue. Did you change the file that the DHCP server looks for on tftp? In 33b and up, it’s should be set to undionly.kpxe.

    On Windows DHCP server you much change the Option 67 part to look for this new file. In the past it was pxelinux.0, now it’s undionly.kpxe.

    Also, make sure the permissions are correct as the file in /tftpboot should be owned by the FOG user which can be ensured by running, as root user, the command:

    chown -R fog:root /tftpboot
    

    Hopefully this helps.



  • This post is deleted!

Log in to reply
 

509
Online

38925
Users

10691
Topics

101434
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.