Grub2 et fog 1.0.1


  • Developer

    Did your Ubuntu installation go to logical or primary partitions? I’ve got a demo client system with windows 7 (primary partitions 1 & 2), and ubuntu 14.04 (primary partition 3 = /, 4 = swap), using grub 2. It appears to be working well. I did have problems when I did the default install, which put the ubuntu partitions as logical (5,6), since it appears these partitions are not cloned correctly.


  • Senior Developer

    [quote=“raumin, post: 27659, member: 22348”]Ok, i think Grub2 is not guilty…

    I noticed that my ext4 partitions are not properly imaged ! the / partition should be around 10Gb but the file is 246MB…So Grub2 cannot boot on an non existing FS…

    SO, question…is ext4 well supported with partclone ? I tried with a machine test, all is the same, i just changed the FS with ext3 and the image works great ! I’ll start soon the download on another client…[/quote]

    ext4 support IS supported with partclone.

    The File size isn’t the determining factor. If on your server the file size is 246 MB, what’s the actual Data Size in use on the system?

    Ext3 should also be the same. It uses the exact same method to image ext3, for 4 so nothing should change between them.



  • Ok, so everything works great with ext3…a bit disappointed :’(



  • Ok, i think Grub2 is not guilty…

    I noticed that my ext4 partitions are not properly imaged ! the / partition should be around 10Gb but the file is 246MB…So Grub2 cannot boot on an non existing FS…

    SO, question…is ext4 well supported with partclone ? I tried with a machine test, all is the same, i just changed the FS with ext3 and the image works great ! I’ll start soon the download on another client…


Log in to reply
 

348
Online

6.5k
Users

13.9k
Topics

131.3k
Posts